Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel - Conteggio valori uguali contigui

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel - Conteggio valori uguali contigui

Postdi giabrid » 14/11/17 22:07

Ciao, ho letto altri quesiti simili, ma non riesco ad uscircene...
Stò lavorando su un file di turni di lavoro, quindi e vorrei contare quante volte capita il riposo "R" di sabato e domenica

il mio file è più o meno strutturato così
Riga 1 numero giorno della settimana (lun 1 --> dom 7)
Colonna 1 nome operatore dalla colonna B alla colonna Z e poi ovviamente giù per varie righe tabella dei turni... diversi per ciascuno, in fonto alla riga o messo dei vari conta.se (mattina - pomeriggi notti ecc ecc) vorrei aggiungerne uno per contare quante volte trovo R ed R di sabato e domenica, quindi quante volte (in quel turno/riga) quel operatore sta a casa tutto il week-end

Spero di esser stato chiaro... se possibile mi sarebbe più facile trovare una formula (anche complessa) ma non utilizzare Macro (semplicemente perché non le conosco)

Grazie G
giabrid
Newbie
 
Post: 5
Iscritto il: 14/11/17 21:57

Sponsor
 

Re: Excel - Conteggio valori uguali contigui

Postdi Anthony47 » 15/11/17 00:14

Ho separato la tua richiesta da quella gestita 5 anni fa per altro utente a cui ti eri accodato (vedi viewtopic.php?f=26&t=94686)

Da quello che ho capito, da A2 verso il basso hai gia' il giorno della settimana (1=Lunedi', 7=Domenica); mentre da B2 verso il basso hai i dati del primo utente di cui vuoi contare i Riposi nel weekend completo.
Se e' cosi', allora in B33 o riga successiva puoi usare questa formula:
Codice: Seleziona tutto
=SOMMA(($A$2:$A$31=6)*(B$2:B$31="R")*($A$3:$A$32=7)*(B$3:B$32="R"))

Va confermata con Contr-Maiusc-Enter, non il solo Enter; poi puoi copiarla verso destra per gli altri utenti elencati in riga 1

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 15991
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Excel - Conteggio valori uguali contigui

Postdi giabrid » 15/11/17 11:32

Grazie, ma non funziona...
diciamo che il sistema è sviluppato in orizzontale e non in colonne, ma poco cambia, ho sostituito gli intervalli con quelli del mio foglio, ma il risultato è sempre 0...
Capisco il principio di moltiplicare i giorni = a sabato con i giorni = a R e poi moltiplicare i giorni = a domenica con i giorni = a R, ma perchè tutto sotto la funzione somma? e perché confermare con Contr-Maiusc-Enter?

Ti ringrazio se mi aiuti a capire meglio questa funzione...
Ultima modifica di giabrid su 15/11/17 11:44, modificato 1 volte in totale.
giabrid
Newbie
 
Post: 5
Iscritto il: 14/11/17 21:57

Re: Excel - Conteggio valori uguali contigui

Postdi giabrid » 15/11/17 11:41

https://ibb.co/khtAa6
Questa l'ultimo passaggio della valutazione delle formula, si vede che c'è un riposo di sabato ed un riposo di domenica, ma il risultato della moltiplicazione per 0 è ovviamnte sempre 0
giabrid
Newbie
 
Post: 5
Iscritto il: 14/11/17 21:57

Re: Excel - Conteggio valori uguali contigui

Postdi giabrid » 15/11/17 14:54

Codice: Seleziona tutto
=SOMMA(($D$55:$AH$55>5)*($D60:$AH60="R"))

Questo mi da una cosa più simile a ciò che mi aspetto,
poi faccio fatica a districarmi da quest'ultima valutazione, https://ibb.co/kg6fsm
a questo punto dovrei contare solo i contigui... ma che formula uso?
Grazie
giabrid
Newbie
 
Post: 5
Iscritto il: 14/11/17 21:57

Re: Excel - Conteggio valori uguali contigui

Postdi Anthony47 » 15/11/17 15:52

Che la struttura si sviluppasse in verticale per i giorni e in orizzontale per i nominativi era la mia migliore interpretazione delle tue informazioni:
giabrid ha scritto:Riga 1 numero giorno della settimana (lun 1 --> dom 7)
Colonna 1 nome operatore dalla colonna B alla colonna Z


Se l'ultimo "1" (nell'immagine linkata dal tuo penultimo messaggio) corrisponde a una Domenica allora significa che non hai "sfalsato" (nell'ultima parte della formula) il secondo intervallo delle presenze, come fatto nella formula che ti ho proposto
Se non "ti torna" o non risolvi allora pubblica la formula che hai usato e almeno una immagine dei tuoi dati, o il file con dati e formula.
Per le istruzioni su come allegare un file o una immagine:
viewtopic.php?f=26&t=103893

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 15991
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Excel - Conteggio valori uguali contigui

Postdi giabrid » 15/11/17 16:24

non hai "sfalsato" (nell'ultima parte della formula)


dalla fretta la gatta fece i gattini ciechi...

Grazie infinite, sembra funzioni perfettamente!
giabrid
Newbie
 
Post: 5
Iscritto il: 14/11/17 21:57


Torna a Applicazioni Office Windows


Topic correlati a "Excel - Conteggio valori uguali contigui":


Chi c’è in linea

Visitano il forum: Marius44 e 23 ospiti