Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

cerca.vert concatenati

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

cerca.vert concatenati

Postdi karug64 » 01/11/17 11:12

Salve a tutti.
Ho questa problematica da risolvere:
Foglio "Base_dati" ho questi valori

A B C
1) Verifica 1 test-1
1) Verifica 2 Test -2
2) Verifica 1 Test -2.1
2) Verifica 2 Test - 2.2
2) Verifica 3 Test - 2.3
3) Verifica 1 Test 3-1

Sul foglio1, ad intervalli non specificati, ho in colonna A e B il corrispondente di quello che c'e' nel foglio Base_dati. In colonna C ho il valore della colonna C.

Vorrei automatizzare la compilazione del foglio1 in modo da scrivere tutti i dati nel foglio "Base_dati" e riportare sul foglio1 quelli necessari.

Se nella cella A3 foglio1 c'e' scritto 1) e nella cella B3 c'e' scritto "Verifica 1" allora in C3 dovro scrivere test-1
Se nella cella A5 foglio1 c'e' scritto 3) e nella cella B5 c'e' scritto "Verifica 1" allora in C5 dovro scrivere test-3-1
Se nella cella A30 foglio1 c'e' scritto 2) e nella cella B30 c'e' scritto "Verifica 3" allora in C30 dovro scrivere test-2.3

In pratica mi occorrerebbe avere una formula, da mettere nelle celle della colonna "C" del foglio1, che faccia DUE cerca.vert nidificati cercando sia in colonna A che B del foglio "Base_dati" e restituisca il valore trovato.

Ovviamente il foglio "Base_dati" posso strutturalo come voglio e come meglio è possibile per ottenere la soluzione cercata.

Grazie
Office 2010
karug64
Utente Senior
 
Post: 747
Iscritto il: 20/11/11 21:22

Sponsor
 

Re: cerca.vert concatenati

Postdi alfrimpa » 01/11/17 13:53

Karug64 ma perché non alleghi un file di esempio con dati, spiegazione e risultato desiderato inserito a mano in moda da non costringere che volesse rispondere a doverselo ricostruire da solo?
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 1201
Iscritto il: 30/12/13 17:01
Località: Napoli

Re: cerca.vert concatenati

Postdi karug64 » 01/11/17 15:33

Office 2010
karug64
Utente Senior
 
Post: 747
Iscritto il: 20/11/11 21:22

Re: cerca.vert concatenati

Postdi Marius44 » 01/11/17 16:12

Ciao
con le formule ... mi viene l'orticaria :)
Proverei con VBA e con questa macro (da associare ad un pulsante da mettere nel Foglio1)
Codice: Seleziona tutto
Option Explicit

Sub Riporta()
Dim ur1 As Long, ur2 As Long, i As Long, j As Long
Dim nr As String, vr As String
ur1 = Sheets("Foglio1").Cells(Rows.Count, 1).End(xlUp).Row
ur2 = Sheets("Base_dati").Cells(Rows.Count, 1).End(xlUp).Row
Range("D3:D" & ur1).ClearContents
For i = 1 To ur1
    nr = Cells(i, 1).Value: If nr = "" Then GoTo altro
    vr = Cells(i, 2).Value
    For j = 1 To ur2
        With Sheets("Base_dati")
            If .Cells(j, 1) = nr And .Cells(j, 2) = vr Then
                Cells(i, 4) = .Cells(j, 3).Value
                Exit For
            End If
        End With
    Next j
altro:
Next i
End Sub


Fai sapere. Ciao,
Mario
Marius44
Utente Senior
 
Post: 545
Iscritto il: 07/09/15 22:00

Re: cerca.vert concatenati

Postdi karug64 » 01/11/17 16:34

Grazie Marius.
La soluzione proposta va bene, ma sono alla ricerca di formule in quanto dovrei aggiornare automaticamente i risultati sul primo foglio in base alle modifiche eventualmente apportate sul foglio Base_dati.

Avrei trovato un'altra soluzione con le formule.
Ho aggiunto una colonna di appoggio ("C") al foglio Base_dati in cui ho scritto la formula:
Codice: Seleziona tutto
=CONCATENA(A1;B1)

e l'ho trascinata fino alla fine

Poi nella cella C3 ho scritto la formula:

Codice: Seleziona tutto
=SE.ERRORE(CERCA.VERT(CONCATENA(A3;B3);Base_dati!$C$1:$D$10;2;FALSO);"")


trascinata fino ala fine ..... e sembrerebbe funzionare ....

Se esiste una soluzione senza l'uso della colonna di appoggio ben venga ..... ovviamente

Grazie
Office 2010
karug64
Utente Senior
 
Post: 747
Iscritto il: 20/11/11 21:22

Re: cerca.vert concatenati

Postdi cromagno » 01/11/17 21:08

Ciao a tutti,
potresti usare una formula matriciale (quindi da confermare con la combinazione di tasti CTRL+MAIUSC+INVIO anzichè solo con INVIO) da mettere nella C3 e copiare poi in basso fin dove serve:
=SE.ERRORE(INDICE(Base_dati!$C$1:$C$10;CONFRONTA(Foglio1!A3&Foglio1!B3;Base_dati!$A$1:$A$10&Base_dati!$B$1:$B$10;0));"")

Ciao
Tore
Windows 10 + Office 2013 64bit(ita)
"Sono le persone che nessuno immagina che possano fare certe cose, quelle che fanno cose che nessuno può immaginare."
Avatar utente
cromagno
Utente Junior
 
Post: 65
Iscritto il: 08/10/16 16:33
Località: Sardegna

Re: cerca.vert concatenati

Postdi karug64 » 01/11/17 21:23

Grazie
Office 2010
karug64
Utente Senior
 
Post: 747
Iscritto il: 20/11/11 21:22


Torna a Applicazioni Office Windows


Topic correlati a "cerca.vert concatenati":


Chi c’è in linea

Visitano il forum: Nessuno e 65 ospiti