Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Sommare o contare numeri in celle non contigue

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Sommare o contare numeri in celle non contigue

Postdi elevation1 » 18/10/17 07:51

Salve,
in un foglio excel ho utilizzato le funzioni somma e conta.numeri per delle celle non contigue... il set di dati è lo stesso... solo che ogni volta che devo aggiungere una cella devo farlo manualmente sia in somma che in conta.numeri... c'è una funzione per mettere le celle in una sorta di matrice tipo 20X1... aggiungo lì le celle e in automatico mi somma o mi conta numeri etc... grazie mille per l'aiuto
elevation1
Utente Junior
 
Post: 13
Iscritto il: 07/10/17 13:23

Sponsor
 

Re: Sommare o contare numeri in celle non contigue

Postdi wallace&gromit » 18/10/17 16:10

Ci sono vari metodi, la scelta dipende dalla struttura dei tuoi dati.
Per esempio con questa formula messa in A4 ti calcola la somma dei valori sulla riga 4, e si aggiorna a mano a mano che aggiungi valori nelle colonne a destra:
Codice: Seleziona tutto
=SOMMA(SCARTO(A4;0;1;1;CONTA.VALORI(4:4)))
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1779
Iscritto il: 16/01/12 14:21

Re: Sommare o contare numeri in celle non contigue

Postdi Anthony47 » 18/10/17 22:25

@ elevation: E se non risolvi con lo spunto di W&G allora allega un file dimostrativo con il layout dei tuoi dati.

Per le istruzioni su come allegare un file:
viewtopic.php?f=26&t=103893&p=605487#p605487

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 15731
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Sommare o contare numeri in celle non contigue

Postdi elevation1 » 20/10/17 10:42

per capirci devo sommare in d3 tutti i numeri presenti in m3;s3 etc... ogni 6 celle... ma solo quelli quindi non m3:s3 ma m3;s3;y3 etc...
p.s. in n3,o3,p3 ci sono altri numeri ma non mi interessa sommarli... al momento per risolvere ho usato il classico comando ctrl selezionando solo le celle che mi servivano ma non è una soluzione "elegante"... grazie
elevation1
Utente Junior
 
Post: 13
Iscritto il: 07/10/17 13:23

Re: Sommare o contare numeri in celle non contigue

Postdi wallace&gromit » 20/10/17 11:16

così diventa più complesso,
prova con questa formula matriciale, dopo averla inserita devi confermare con Ctrl+Maiusc+Enter, non solo Enter:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(M3:AA3;SE(RESTO(RIF.COLONNA(M3:AA3)+5;6)=0;1;0))
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1779
Iscritto il: 16/01/12 14:21

Re: Sommare o contare numeri in celle non contigue

Postdi elevation1 » 20/10/17 14:09

funziona... ovviamente non era AA3 l'ultima cella però va benissimo... il problema è che non ho capito come fa a funzionare e non va bene :) potresti farmelo capire scomponendo la funzione? grazie mille
p.s. ora ho il problema di contare i valori delle stesse celle (non sommarli!) ho provato con conta valori al posto di matr.somma.prodotto ma non va...
elevation1
Utente Junior
 
Post: 13
Iscritto il: 07/10/17 13:23

Re: Sommare o contare numeri in celle non contigue

Postdi elevation1 » 20/10/17 14:24

vediamo se ho capito il rif. colonna dice che le colonne sono da 13 in poi (m3)... addizionando 5 quindi avremo da 18 in poi... divido per 6 e ho resto 0 (la prima colonna) quindi quando è verificato (0=0) mette 1 altrimenti 0 e fa la somma della matrice (m3:hi3)*(1;0;0;0;0;0;1.....) quindi somma ogni 6 colonne... se il discorso è corretto per contare solo i valori dovrei fare =conta.più.se((SE(RESTO(RIF.COLONNA(M3:HI3)+5;6)=0;1;0);1)) ma non funge
elevation1
Utente Junior
 
Post: 13
Iscritto il: 07/10/17 13:23

Re: Sommare o contare numeri in celle non contigue

Postdi wallace&gromit » 20/10/17 14:45

la chiave di tutto è ovviamente quello di lavorare con le matrici, se vuoi introdurre un conteggio invece del valore, nella prima matrice del matr.somma.prodotto devi aggiungere una condizione che ti dia 1 solo nei casi in cui desideri tu.
Invece costruire una nuova formula matriciale con il conta.più.se è possibile, ma bisogna ripensarla bene.
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1779
Iscritto il: 16/01/12 14:21

Re: Sommare o contare numeri in celle non contigue

Postdi elevation1 » 20/10/17 17:28

la funzione SE(RESTO(RIF.COLONNA(M3:HI3)+5;6)=0;1;0) mi da come risultati:
1/0/0/0/0/0 che si ripete ciclicamente... a me serve contare quegli 1 per cui credevo che con la funzione:
Conta.piu.se (SE(RESTO(RIF.COLONNA(M3:HI3)+5;6)=0;1;0);1) avrei risolto... invece mi dà errore
elevation1
Utente Junior
 
Post: 13
Iscritto il: 07/10/17 13:23

Re: Sommare o contare numeri in celle non contigue

Postdi Anthony47 » 20/10/17 19:36

Per contare i valori, tra le tante possibilita':
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(M3:AA3<>"");--(RESTO(RIF.COLONNA(M3:AA3)+5;6)=0))

oppure
Codice: Seleziona tutto
=SOMMA(SE((M3:AA3<>"")*(RESTO(RIF.COLONNA(M3:AA3)+5;6)=0);1;0))

Ambedue da confermare con Contr-Maiusc-Enter, non il solo Enter

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 15731
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Sommare o contare numeri in celle non contigue":


Chi c’è in linea

Visitano il forum: Nessuno e 24 ospiti