Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Associare un numero ad una parola su file excel

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Associare un numero ad una parola su file excel

Postdi pierov » 07/10/17 17:03

Buonasera,
dovrei creare un foglio di calcolo in questo modo.
Praticamente avrei bisogno di associare 22 parole a 22 cifre.
Le parole andranno inserite nei righi G2 A G23 e nel momento che metto una parola vorrei che questa corrispondesse ad un numero che andrebbe a comparire nei righi I2 al rigo I23.
Ho provato con la funzione se ma excel mi permette di fare solo 7 nidificazioni.
Per semplificare ho messo le cifre da associare nei righi che vanno da L2 a L23.
Mi aiutate per favore
Ciao
Grazie
Piero
pierov
Utente Junior
 
Post: 10
Iscritto il: 07/10/17 17:01

Sponsor
 

Re: Associare un numero ad una parola su file excel

Postdi Statix » 07/10/17 17:44

Ciao,
puoi usare il cerca.verticale,
metti i nomi in K2:K23
in i2 metti la formula
=se.errore(cerca.vert($G2;$K$2:$L$23);6;0);"")
e copiala fino alla I23
cosi quando metti una parola nella colonna G in I avrai il numero associato
Statix
Windows 10,
Office 2013,
Statix
Utente Senior
 
Post: 1261
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Associare un numero ad una parola su file excel

Postdi pierov » 07/10/17 18:03

Ciao Statix.
Ho messo i nomi in M2:M23 visto che in K ho altri valori
Ho messo la formula
=se.errore(cerca.vert($G2;$M$2:$L$23);6;0);"")
ma il sistema mi dice che sono state immessi argomenti insufficienti per questa formula.
Come mai?
pierov
Utente Junior
 
Post: 10
Iscritto il: 07/10/17 17:01

Re: Associare un numero ad una parola su file excel

Postdi Statix » 07/10/17 18:04

devi cambiare la formula =
se.errore(cerca.vert($G2;$M$2:$L$23);6;0);"")
il range non è corretto la colonna M devi metterla dopo la colonna L

=se.errore(cerca.vert($G2;$G$2:$M$23);7;0);"")
nella colonna L2:L23 metti i nomi mentre nella colonna M2:M23 i valori associati
Ultima modifica di Statix su 07/10/17 18:17, modificato 5 volte in totale.
Statix
Windows 10,
Office 2013,
Statix
Utente Senior
 
Post: 1261
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Associare un numero ad una parola su file excel

Postdi pierov » 07/10/17 18:09

Mi dà sempre lo stesso errore. COme mai?
L'indice in base a cosa si cambia?
pierov
Utente Junior
 
Post: 10
Iscritto il: 07/10/17 17:01

Re: Associare un numero ad una parola su file excel

Postdi Statix » 07/10/17 18:14

ho corretto la formula nel post precedente,
Statix
Windows 10,
Office 2013,
Statix
Utente Senior
 
Post: 1261
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Associare un numero ad una parola su file excel

Postdi pierov » 07/10/17 18:19

sempre errore
pierov
Utente Junior
 
Post: 10
Iscritto il: 07/10/17 17:01

Re: Associare un numero ad una parola su file excel

Postdi Statix » 07/10/17 18:23

ok, ti metto la formula giusta è che il sito sembra intasato
formula da mettere in I2 che poi trascinerai verso il basso fino a I23
=SE.ERRORE(CERCA.VERT($G2;$L$2:$M$23;2;0);"")
Statix
Windows 10,
Office 2013,
Statix
Utente Senior
 
Post: 1261
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Associare un numero ad una parola su file excel

Postdi pierov » 07/10/17 18:37

Ciao Statix ora funziona.
grazie veramente tante.
Ma una cosa....l'indice in base a cosa lo cambi?
Scusami ma sono ancora agli inizi
pierov
Utente Junior
 
Post: 10
Iscritto il: 07/10/17 17:01

Re: Associare un numero ad una parola su file excel

Postdi Statix » 07/10/17 18:42

=INDICE(intervallo dati; numero riga; numero colonna)

•Intervallo dati è l’elenco dei dati presi in esame (il range) come, ad esempio A1:B6
•Numero riga è il numero della riga che contiene il valore si vuole recuperare all’interno dell’elenco
•Numero colonna è il numero della colonna che contiene il valore che si vuole recuperare all’interno dell’elenco
E’ più facile a farsi che a dirsi

=INDICE(A1:B6;3;2)
Restituisce il valore di B3.
Statix
Windows 10,
Office 2013,
Statix
Utente Senior
 
Post: 1261
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Associare un numero ad una parola su file excel

Postdi pierov » 07/10/17 18:58

Nel mio caso
l'indice dovrebbe essere
=INDICE (L2:M23; 2;0)
il valore 2 è il numero della riga che contiene il valore che voglio recuperare
Ma il valore 0 cosa rappresenta?
pierov
Utente Junior
 
Post: 10
Iscritto il: 07/10/17 17:01

Re: Associare un numero ad una parola su file excel

Postdi Anthony47 » 08/10/17 22:28

Humm....
Non vi seguo... La formula che pierov dice che funziona e' =SE.ERRORE(CERCA.VERT($G2;$L$2:$M$23;2;0);"")

Perche' vi siete messi poi a parlare della funzione Indice?
Non e' che pierov volesse spiegazioni sul parametro "indice" della funzione Cerca.Vert? Nella formula di prima e' messo a 2, e indica quale colonna della tabella viene restituita quando il Cerca.Vert trova il valore cercato. Nella formula va messa su 2 affinche' la formula restituisca il valore di colonna M.

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17441
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Associare un numero ad una parola su file excel

Postdi pierov » 13/12/20 19:15

Buonasera,
e se devo aggiungere valori e nomi come cambio la formula?
Ringrazio anticipatamente per chi mi risponderà
pierov
Utente Junior
 
Post: 10
Iscritto il: 07/10/17 17:01

Re: Associare un numero ad una parola su file excel

Postdi Anthony47 » 14/12/20 15:40

Non avevo contribuito alla soluzione iniziale, dico la mia vista l'assenza di Statix...

Se alla fine usavi una formula con CERCA.VERT e vuoi allungare la tabella in cui Cerca.Vert va a cercare allora non hai particolari problemi a prevedere ad esempio una tabella di 100 righe, cioe' invece che la formula =SE.ERRORE(CERCA.VERT($G2;$L$2:$M$23;2;0);"") puoi usare:
Codice: Seleziona tutto
=SE.ERRORE(CERCA.VERT($G2;$L$2:$M$100;2;0);"")

Non c'e' bisogno che tutte le righe citate nella formula (L2:M100, nella formula proposta) siano piene, perche' Cerca.Vert (come e' usata in questa formula, cioe' con l'ultimo parametro posto a 0) cerca una corrispondenza esatta, quindi le righe vuote non hanno impatto sul risultato.

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17441
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Associare un numero ad una parola su file excel

Postdi pierov » 14/12/20 16:12

Ciao Anthony, prima di tutto grazie tantissime per la pronta risposta.
Scusa la mia ignoranza ma ti chiedo una conferma facendo un esempio pratico
Metti che io compilo 30 righe ma indico la formula fino a 100 come mi hai indicato tu:
=SE.ERRORE(CERCA.VERT($G2;$L$2:$M$100;2;0);"")
Come mi specifichi tu il cerca vert cera una corripondenza esatta e quindi le righe vuote non hanno impatto sul risultato.
Salvo il file excel così e lo uso per un determinato periodo con 30 righe compilate.
Poi lo riprendo, aggiungo una decina di valori in dieci righe.
Posso usarlo così senza modificare la formula?
pierov
Utente Junior
 
Post: 10
Iscritto il: 07/10/17 17:01

Re: Associare un numero ad una parola su file excel

Postdi Anthony47 » 14/12/20 16:30

Certo, non hai bisogno di modificare la formula perche' essa esamina sempre fino alla riga 100.
E volendo metti 1000 invece di 100 e hai spazio per mooolte piu' aggiunte...

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17441
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Associare un numero ad una parola su file excel

Postdi pierov » 14/12/20 17:44

Grazie Anthony
Ancora un consiglio per favore.
Non sono un informatico ma per il mio lavoro utilizzo tanto excel. Per acquisire una buona dimestichezza su excel hai qualche corso, pubblicazione, altro da consigliarmi?
pierov
Utente Junior
 
Post: 10
Iscritto il: 07/10/17 17:01


Re: Associare un numero ad una parola su file excel

Postdi pierov » 14/12/20 19:50

Grazie Anthony per l'aiuto della formula e per i link per excel
Buona serata
Ciao
Piero
pierov
Utente Junior
 
Post: 10
Iscritto il: 07/10/17 17:01


Torna a Applicazioni Office Windows


Topic correlati a "Associare un numero ad una parola su file excel":


Chi c’è in linea

Visitano il forum: Nessuno e 39 ospiti