Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[VBA Excel] Come scrivere su una cella il link di un altra

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[VBA Excel] Come scrivere su una cella il link di un altra

Postdi peterparker0607 » 20/08/17 17:05

Ciao ragazzi! Una domandina semplice semplice :lol:

In cella A1 ho scritto "Google" e c'è il collegamento a "www.google.it" (classica scritta blu sottolineata).
Non riesco a capire come fare a prendere il link, ovvero io vorrei scrivere nella cella B2 "www.google.it"

Illuminatemi...
Grazie!
peterparker0607
Utente Junior
 
Post: 10
Iscritto il: 09/09/16 10:06

Sponsor
 

Re: [VBA Excel] Come scrivere su una cella il link di un alt

Postdi Anthony47 » 21/08/17 00:21

Non credo che si possa fare con funzioni native Excel; si puo' fare con vba, ad esempio con questa "Funzione Utente":
Codice: Seleziona tutto
Function hLink(ByRef SSrc As Range)
Dim lCount As Long
'
lCount = SSrc.Range("A1").Hyperlinks.Count
If lCount > 0 Then
    hLink = SSrc.Hyperlinks(1).Address
Else
    hLink = "NoLink"
End If
End Function

Inserisci il codice in un "modulo standard" del vba, es Modulo1, poi su excel potrai usare la formula del tipo
Codice: Seleziona tutto
=hLink(A1)

La sintassi della funzione e' hLink(Intervallo)

La funzione restiuira' la destinazione dell'hyperlink presente nella cella "1" dell'Intervallo, oppure la stringa "NoLink" se nella cella non c'e' un hyperlink.
La funzione si comporta come tutte le funzioni native; la formula puoi copiarla e spostarla come si fa con tutte le formule, o puoi usare la funzione in formule piu' complesse ad es.
Codice: Seleziona tutto
=SE(hLink(A1)="http://www.google.com/";"Google";"Ignoto")

Ciao

keyword
estrarre indirizzo collegamento ipertestuale hyperlink link address
read get hyperlink address udf

Avatar utente
Anthony47
Moderatore
 
Post: 17446
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [VBA Excel] Come scrivere su una cella il link di un alt

Postdi peterparker0607 » 21/08/17 14:31

Non perfetto.... di più!!!

Grazie!
peterparker0607
Utente Junior
 
Post: 10
Iscritto il: 09/09/16 10:06


Torna a Applicazioni Office Windows


Topic correlati a "[VBA Excel] Come scrivere su una cella il link di un altra":

Link che non funziona
Autore: danibi60
Forum: Software Windows
Risposte: 2

Chi c’è in linea

Visitano il forum: raimea e 37 ospiti