Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Associare un codice a barre ad una cartella di lavoro

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Associare un codice a barre ad una cartella di lavoro

Postdi il_puttologo » 10/05/17 10:32

Ciao a tutti, mi domandavo se fosse possibile associare un codice a barre a un file excel, in modo tale che una volta letto il codice a barre con la mia pistola mi si apra sul computer la cartella excel ad esso associato? Se sì, come devo fare?
Grazie in anticipo dell 'attenzione!
il_puttologo
Utente Junior
 
Post: 22
Iscritto il: 06/03/17 17:44

Sponsor
 

Re: Associare un codice a barre ad una cartella di lavoro

Postdi Anthony47 » 10/05/17 23:35

mi domandavo se fosse possibile associare un codice a barre a un file excel [. . .]
Si puo' fare qualcosa, ma questa "associazione" la devi fare a mano...

[. . . ] in modo tale che una volta letto il codice a barre con la mia pistola mi si apra sul computer la cartella excel ad esso associato
Questo si puo' fare in automatico...

Su un foglio Excel creati una tabella di equivalenza tra il barcode e il file relativo; supponiamo che sia in colonna O (barcode) e P (percorso e nome file)
Adesso supponiamo che il tuo barcode reader sia configurato per popolare colonna A del foglio di lavoro corrente; in B2 inserisci la formula
Codice: Seleziona tutto
=SE.ERRORE(CERCA.VERT(A2;O:P;2;0);"")
Copia verso il basso per le righe che compilerai col barcode reader

In questo modo avrai in colonna B il nome file associato ai codici che leggi

Oa inserisci questa macro nel "modulo vba" del foglio su cui lavori (per accedere a questi "moduli": da Excel, tasto dx sul tab col nome del foglio, scegliere Visualizza codice):
Codice: Seleziona tutto
Private Sub Worksheet_Change(ByVal Target As Range)
If Target.Column = 1 Then
On Error Resume Next
    Workbooks.Open Target.Offset(0, 1)
On Error GoTo 0
End If
End Sub


Prova digitando a mano un codice che ha un nome file associato; se funziona prova col lettore barcode.

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 16625
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Associare un codice a barre ad una cartella di lavoro

Postdi il_puttologo » 12/05/17 09:57

Forse sbaglio qualcosa ma non mi funziona. Ti allego il file excel così è più facile risolvere il problema!

http://dropcanvas.com/ix9at
il_puttologo
Utente Junior
 
Post: 22
Iscritto il: 06/03/17 17:44

Re: Associare un codice a barre ad una cartella di lavoro

Postdi Anthony47 » 12/05/17 15:03

Anthony ha scritto: Su un foglio Excel creati una tabella di equivalenza tra il barcode e il file relativo; supponiamo che sia in colonna O (barcode) e P (percorso e nome file)
Adesso supponiamo che il tuo barcode reader sia configurato per popolare colonna A del foglio di lavoro corrente; in B2 inserisci la formula
Codice: Seleziona tutto
    =SE.ERRORE(CERCA.VERT(A2;O:P;2;0);"")

Copia verso il basso per le righe che compilerai col barcode reader

In questo modo avrai in colonna B il nome file associato ai codici che leggi
Non vedo in colonna B traccia di questa formula.

Pero', guardando il file, mi viene spontanea una domanda: ma tu col barcode reader leggi una cosa che contiene (a) Drive/Percorso/Nome file, o (b) un codice che poi va associato al Drive/Percorso/Nome file?
Perche' se (a) allora non c'e' bisogno della tabella della "tabella di equivalenza tra il barcode e il file relativo" (quella che avevamo creato in colonne O-P) e della formula in B; bastera' modificare nella Sub Worksheet_Change la riga
Workbooks.Open Target.Offset(0, 1) in
Codice: Seleziona tutto
Workbooks.Open Target.Value


Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 16625
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Associare un codice a barre ad una cartella di lavoro

Postdi il_puttologo » 16/05/17 06:58

In effetti non lo avevo spiegato bene. La mia idea iniziale era di trasformare il Drive/Percorso/Nome file in codice a barre perchè pensavo fosse più immediata l'associazione/apertura del file. Però se mi dici che diventa più complicato allora cambio strategia!
il_puttologo
Utente Junior
 
Post: 22
Iscritto il: 06/03/17 17:44

Re: Associare un codice a barre ad una cartella di lavoro

Postdi Anthony47 » 16/05/17 20:49

Io ho detto che se nel codice a barre c'e' solo un codice che separatamente devi associare a un Percorso + File allora ti serve la tabella e poi la formula con Cerca.Vert (risposta del 10-5 sera); ma se nel codice a barre c'e' gia' Percorso e Nome file allora non ti servira' ne' la tabella di conversione ne' la cella col Cerca.Vert (risposta del 12-5).
Vedi tu quale e' piu' facile da realizzare, tenendo presente che ti ho descritto la soluzione sia al caso 1 che al caso 2.

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 16625
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Associare un codice a barre ad una cartella di lavoro

Postdi il_puttologo » 22/05/17 13:50

Ah ok adesso ho capito! Le soluzioni in effetti funzionano entrambe...grazie mille!
il_puttologo
Utente Junior
 
Post: 22
Iscritto il: 06/03/17 17:44

Re: Associare un codice a barre ad una cartella di lavoro

Postdi Anthony47 » 24/05/17 23:36

Se invece non funziona proprio bene allora ti conviene chiedere qui ;)
Avatar utente
Anthony47
Moderatore
 
Post: 16625
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Associare un codice a barre ad una cartella di lavoro

Postdi il_puttologo » 06/06/17 11:45

Anthony47 ha scritto:Se invece non funziona proprio bene allora ti conviene chiedere qui ;)

In effetti avevo chiuso la discussione troppo in fretta :oops:
Però sono riuscito a risolvere con le mie forze :) Grazie ancora! ;)
il_puttologo
Utente Junior
 
Post: 22
Iscritto il: 06/03/17 17:44


Torna a Applicazioni Office Windows


Topic correlati a "Associare un codice a barre ad una cartella di lavoro":


Chi c’è in linea

Visitano il forum: Francesco53, raimea e 33 ospiti