Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

funziona TROVA o altro

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

funziona TROVA o altro

Postdi giostacchio » 21/04/17 14:09

buongiorno, in alcune celle mi trovo un elenco di stringhe che contengono delle parole che mi serve estrarre
ho provato con la funzione =SE(TROVA("BODY";C111);"BODY";E(SE(TROVA("BAR";C111);"BAR")))
ma nulla da fare mi scrive solo "BODY"...
io avrei bisogno di estrarre esempio da queste stringhe che sono in celle
cella A1 cella A2
12"NOM OD-10.52" ID IN PUP PUP
BAR BAR
BODY 30" 330 bar BODY
CLOSURE 30" 330 bar CLOSURE
FORGED BAR BAR
FORGED BODY 16" 900 BODY
FORGED GATE SLAB 2" 1/16 15K GATE
FORGED GL.TRUNNION 8" 650 bar TRUNNION
FORGED SEAT BALL 14" 450 bar SEAT
GLAND TRUNNION BALL 16" 7500 TRUNNION

AVETE ideeeeeeee
grazie
giostacchio
Utente Junior
 
Post: 90
Iscritto il: 14/10/16 07:36

Sponsor
 

Re: funziona TROVA o altro

Postdi wallace&gromit » 21/04/17 17:08

Per forza scrive solo "BODY", glielo dici tu di farlo:
SE([condizione]; [se vero]; [se falso]) nella parte [se vero] hai scritto "BODY", quindi uscirà quello.
Nella parte [se falso] hai messo un E(SE(... che non funziona, la sintassi è SE(E([condizione1];[condizione2]);....
Serve per valutare assieme due condizioni che devono essere entrambe valide per andare avanti con la valutazione del SE [vero] o [falso].

Spiega quindi bene cosa vorresti ottenere e in quali celle si trovano i dati (parli di A1 e A2 ma nella formula hai messo C111) e vedremo cosa fare, magari un file di esempio non guasterebbe.
Office2016 + 2019 su win10
Avatar utente
wallace&gromit
Utente Senior
 
Post: 2054
Iscritto il: 16/01/12 14:21

Re: funziona TROVA o altro

Postdi Anthony47 » 24/04/17 01:11

Per le istruzioni su come allegare un file:
viewtopic.php?f=26&t=103893&p=605487#p605487

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17646
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: funziona TROVA o altro

Postdi giostacchio » 26/04/17 10:12

ehm si non mi sono piegato molto bene. :oops:
ora allego file. :undecided:
praticamente dovrei estrarre dalle stringhe che si trovano nella colonna da C7 a C233, solo delle parole fondamentali
ad esempio da C22 che mi esca solo " Flange" da C28 solo " Body" da C30 solo " GAte" ecc...
ma con la funzione che ho inserito non riesco
qualche idea ? ;)

https://we.tl/RrbX4EPYqn
giostacchio
Utente Junior
 
Post: 90
Iscritto il: 14/10/16 07:36

Re: funziona TROVA o altro

Postdi giostacchio » 26/04/17 10:13

giostacchio ha scritto:ehm si non mi sono piegato molto bene. :oops:
ora allego file. :undecided:
praticamente dovrei estrarre dalle stringhe che si trovano nella colonna da C7 a C233, solo delle parole fondamentali
ad esempio da C22 che mi esca solo " Flange" da C28 solo " Body" da C30 solo " GAte" ecc...
ma con la funzione che ho inserito non riesco
qualche idea ? ;)

https://we.tl/RrbX4EPYqn



o forse da qui ?
https://wetransfer.com/downloads/07d201 ... 937/4cccf3
giostacchio
Utente Junior
 
Post: 90
Iscritto il: 14/10/16 07:36

Re: funziona TROVA o altro

Postdi wallace&gromit » 27/04/17 14:03

una soluzione potrebbe essere questa formula:
Codice: Seleziona tutto
=SE(VAL.ERRORE(TROVA("BODY";C7));"";"BODY") & SE(VAL.ERRORE(TROVA("CLOSURE";C7));"";"CLOSURE") & SE(VAL.ERRORE(TROVA("BAR";C7));"";"BAR") & SE(VAL.ERRORE(TROVA("BONNET";C7));"";"BONNET")
, ma se la lista di nomi da cercare è più lunga mi sa che conviene passare ad una userfunction apposita con macro.
Office2016 + 2019 su win10
Avatar utente
wallace&gromit
Utente Senior
 
Post: 2054
Iscritto il: 16/01/12 14:21

Re: funziona TROVA o altro

Postdi Anthony47 » 29/04/17 01:59

giostacchio ha scritto:praticamente dovrei estrarre dalle stringhe che si trovano nella colonna da C7 a C233, solo delle parole fondamentali
ad esempio da C22 che mi esca solo " Flange" da C28 solo " Body" da C30 solo " GAte" ecc...
Confrontando queste informazioni col contenuto del file io non ho trovato nessuna corrispondenza col contenuto di col C, quindi non ho capito se c'e' una regola con cui ragionare per identificare il testo da cercare.
In aggiunta al suggerimento di W&G (vedi sopra) quindi suggerisco di inserire in una colonna di appoggio il testo da cercare e poi usare TROVA con questa colonna.
Es se la colonna di appoggio fosse la P, in K7
Codice: Seleziona tutto
=SE(VAL.ERRORE(TROVA(P7;C7));"";P7)

Da copiare poi verso il basso.

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17646
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: funziona TROVA o altro

Postdi giostacchio » 11/05/17 13:51

wallace&gromit ha scritto:una soluzione potrebbe essere questa formula:
Codice: Seleziona tutto
=SE(VAL.ERRORE(TROVA("BODY";C7));"";"BODY") & SE(VAL.ERRORE(TROVA("CLOSURE";C7));"";"CLOSURE") & SE(VAL.ERRORE(TROVA("BAR";C7));"";"BAR") & SE(VAL.ERRORE(TROVA("BONNET";C7));"";"BONNET")
, ma se la lista di nomi da cercare è più lunga mi sa che conviene passare ad una userfunction apposita con macro.



grazie,grazie,grazie perfettooo :lol: :lol: :lol: :lol: :lol:
giostacchio
Utente Junior
 
Post: 90
Iscritto il: 14/10/16 07:36


Torna a Applicazioni Office Windows


Topic correlati a "funziona TROVA o altro":

Bluetooth non funziona.
Autore: hcb
Forum: Software Windows
Risposte: 2

Chi c’è in linea

Visitano il forum: Nessuno e 29 ospiti