Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Macro per isolare valori di una serie storica

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Macro per isolare valori di una serie storica

Postdi noumann » 23/03/17 19:38

Salve a tutti,
avrei bisogno di un aiuto per impostare una macro che,per una data serie storica,mi restituisca solo i valori della serie corrispondenti all'ultimo giorno del mese disponibile.Dato cioè il seguente foglio:

https://www.dropbox.com/s/ym7khfloh4lri ... .xlsx?dl=0

in un altro foglio vorrei isolare solo data e valore della serie corrispondente all'ultimo giorno del mese disponibile(che non sempre corrisponde all'ultimo giorno del mese solare,come ho evidenziato in neretto nel foglio).
Grazie mille a tutti per l'attenzione!
noumann
Newbie
 
Post: 5
Iscritto il: 11/03/17 09:27

Sponsor
 

Re: Macro per isolare valori di una serie storica

Postdi wallace&gromit » 23/03/17 22:09

Puoi risolvere anche con una formula.
Assumendo che in H2 hai l'anno (1994) e in I2 il mese (6); in J2 inserisci questa formula:
Codice: Seleziona tutto
=CERCA.VERT(DATA(H2;I2;MAX(SE(ANNO($C$1:$C$3921)=H2;SE(MESE($C$1:$C$3921)=I2;GIORNO($C$1:$C$3921)))));$C$1:$D$3921;2;0)
per confermare la formula non premi solo enter ma la combinazione Ctrl + Maiusc + Enter, nella barra della formula vedrai che sarà racchiusa da parentesi graffe che stanno a significare che la formula è in formato matriciale e nella cella ti apparirà 447.63.
Poi compili per tutti gli anni ed i mesi che ti interessano le colonne H e I.

P.S. ovviamente puoi fare questo anche su un altro foglio, ma prima fai una prova come ti ho indicato per vedere se fin qui ci sei.
Office2016 + 2019 su win10
Avatar utente
wallace&gromit
Utente Senior
 
Post: 2067
Iscritto il: 16/01/12 14:21

Re: Macro per isolare valori di una serie storica

Postdi noumann » 23/03/17 22:57

Grazie per la risposta,solo che io ho la data in una sola cella nel formato che vedi.
noumann
Newbie
 
Post: 5
Iscritto il: 11/03/17 09:27

Re: Macro per isolare valori di una serie storica

Postdi Anthony47 » 24/03/17 00:05

Se vuoi ottenere tutte le date piu' recenti di tutti i mesi in elenco, lavorando sempre via formule:

In A2 di Foglio2:
Codice: Seleziona tutto
=PICCOLO(SE(MESE(Foglio1!C$1:C$5000)<>MESE(Foglio1!C$2:C$5001);RIF.RIGA(Foglio1!$C$1:$C$5000);"");RIF.RIGA(Foglio1!A1:A200))
Potrebbe restituirti errore, non farti impressionare. Poi selezioni A2:A201, premi F2, premi Contr-Maiusc-Enter

In B2 di Foglio2:
Codice: Seleziona tutto
=INDICE(Foglio1!C:C;$A2)

Copi B2 in C2
Poi copi B2:C2 verso il basso fino a B201

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17790
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Macro per isolare valori di una serie storica":


Chi c’è in linea

Visitano il forum: Marius44 e 31 ospiti