Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[EXCELL]Molteplice convalida dati su celle

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[EXCELL]Molteplice convalida dati su celle

Postdi tommolo » 20/11/16 19:11

Ciao a tutti,

Sto cercando di fare in modo che una colonna excell
non accetti duplicati e al contempo non accetti numeri che non siano fatti di 6 cifre
(andrebbe bene anche dirgli num>99999 e& num<10000000)

Tramite la convalida dei dati sono riuscito ad impedire l'inserimento di multipli grazie a questa formula
=CONTA.SE($A$2:$A$13;A2)=1

Ma non riesco ad annidare / accostare ad essa anche il secondo controllo che ho specificato sopra.

Qualcuno esperto ha gia' in mente la soluzione?
Avatar utente
tommolo
Utente Senior
 
Post: 237
Iscritto il: 03/12/10 00:02

Sponsor
 

Re: [EXCELL]Molteplice convalida dati su celle

Postdi alfrimpa » 20/11/16 20:37

Scusa tommolo non capisco bene quale deve essere la seconda condizione.

Puoi specificare meglio?
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 1201
Iscritto il: 30/12/13 17:01
Località: Napoli

Re: [EXCELL]Molteplice convalida dati su celle

Postdi Anthony47 » 20/11/16 22:39

Credo che la convalida cercata corrisponda alla formula
Codice: Seleziona tutto
=E(CONTA.SE($A$2:$A$13;A2)=1;A2>99999;A2<1000000)

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 17438
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [EXCELL]Molteplice convalida dati su celle

Postdi tommolo » 21/11/16 20:39

Si sembra funzionare.

La seconda condizione doveva far si che il numero fosse di 6 cifre.

Questi componenti registrati nel record di una db access sono distinti da un codice a 6 cifre
che e' diverso per ogni componente, quindi funge anche da chiave primaria
Avatar utente
tommolo
Utente Senior
 
Post: 237
Iscritto il: 03/12/10 00:02


Torna a Applicazioni Office Windows


Topic correlati a "[EXCELL]Molteplice convalida dati su celle":


Chi c’è in linea

Visitano il forum: Nessuno e 13 ospiti