Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

(Excel) Somma fino a (condizione)

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

(Excel) Somma fino a (condizione)

Postdi marcoc » 03/07/16 21:54

Salve a tutti.
Semplificando il mio caso, ho una tabella di due colonne; nella A ho dei valori in ogni cella, dalla riga 1 alla 10. Nella B ho valori solo in due righe (es. In riga 6 e in riga 10). Quello che mi servirebbe è una formula in una terza colonna, dove mi somma i valori della colonna A dall'inizio alla riga dove è presente il valore nella colonna B, ovvero somma da A1 a A6 in C6 e somma da A7 a A10 in C10. Sapete aiutarmi?
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano

Sponsor
 

Re: (Excel) Somma fino a (condizione)

Postdi Flash30005 » 04/07/16 06:17

Se ti può andare ugualmente bene una macro
che si avvii al variare di un cambiamento di una cella posta ad esempio nella colonna B
(quindi non manualmente ed è come se ci fosse la formula da te richiesta)

posso postarla al prossimo tuo intervento se mi dai l'ok
ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: (Excel) Somma fino a (condizione)

Postdi Anthony47 » 06/07/16 01:34

Con formula, prova
Codice: Seleziona tutto
=SOMMA(SCARTO(A1;0;0;PICCOLO(SE(B1:B12<>"";RIF.RIGA(B1:B12);"");1);1))

Da confermare con Contr-Maiusc-Enter, non il solo Enter.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: (Excel) Somma fino a (condizione)

Postdi marcoc » 07/07/16 08:19

Grazie per le risposte. Nel caso mi servisse invece una formula in una cella unica con il totale della colonna A dalla riga 1 all'ultima riga in cui è presente un valore nella colonna B, come sarebbe la formula?
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano

Re: (Excel) Somma fino a (condizione)

Postdi Anthony47 » 07/07/16 13:02

Sostrituisci PICCOLO con GRANDE, e adatta B1:B12 al tuo caso
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: (Excel) Somma fino a (condizione)

Postdi marcoc » 07/07/16 14:59

Perfetto, grazie!
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano


Torna a Applicazioni Office Windows


Topic correlati a "(Excel) Somma fino a (condizione)":


Chi c’è in linea

Visitano il forum: Nessuno e 13 ospiti