Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Cerca.vert con parole uguali

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Cerca.vert con parole uguali

Postdi Cedamido » 12/05/16 22:37

Nella colonna A da A101 ad A199 ci sono i numeri da 1 a 199
nella colonna B da B101 a B199 ci sono i nominativi non uguali
nella colonna C da C101 a C199 ci sono le Nazioni degli atleti molte sono uguali
nella colonna D da D101 a D199 ci sono le squadre di appartenenza degli atleti molte sono uguali
nella colonna E da E101 a E199 ci sono le Nazioni delle squadre molte sono uguali
Sino alla colonna B il cerca.vert funziona, dalla colonna C sino alla colonna E non funziona.
Grazie
excel 2003
Cedamido
Utente Senior
 
Post: 234
Iscritto il: 17/08/08 23:26

Sponsor
 

Re: Cerca.vert con parole uguali

Postdi ricky53 » 13/05/16 00:49

Ciao,
cerca di essere più chiaro nel descrivere la problematica: per esempio che formula hai scritto utilizzando la funzione "CERCA.VERT" ?
Più esponi più capiremo.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Cerca.vert con parole uguali

Postdi mirmidone21 » 13/05/16 08:40

allega anche un file di esempio
Windows 7 sp1 -- Office 2013
Intel i5 4430 -- 3.00 ghz ---- 4gb RAM
mirmidone21
Utente Senior
 
Post: 124
Iscritto il: 26/10/15 16:48

Re: Cerca.vert con parole uguali

Postdi Cedamido » 13/05/16 11:01

Spero di spiegarmi meglio:
Nella cella A3 ho inserito un filtro convalida da A99 ad A199 numeri da 1 a 199
nella cella B3 ho messo =cerca.vert(a3;a99:a199;2;falso) appare il nominativo quindi funziona
Aprendo il filtro in A3 dovrebbe risultare nella cella C3 la Nazione dell'atleta
nella cella D3 la Nazione di appartenenza dell'atleta
nella cella E3 la squadra di appartenenza della Nazione, esempio:
cella A3 numero 1
cella B3 nominativo classifica
cella C3 nazione dell'atleta per esempio Germania
cella D3 come si chiama la squadra dell'atleta per esempio Astana
cella E3 la Nazione della squadra per esempio Kazakistan.
excel 2003
Cedamido
Utente Senior
 
Post: 234
Iscritto il: 17/08/08 23:26

Re: Cerca.vert con parole uguali

Postdi Cedamido » 13/05/16 15:35

Ho usato questo formula, funziona sino alla colonna C
colonna B
=CERCA.VERT(A3;A101:B298;2;FALSO)
colonna C
=SE(VAL.NON.DISP(CERCA.VERT(B3;B101:C298;2;FALSO));0;CERCA.VERT(B3;B101:C298;2;FALSO))
colonna D
=SE(VAL.NON.DISP(CERCA.VERT(C3;C101:D298;2;FALSO));0;CERCA.VERT(C3;C101:D298;2;FALSO))
colonna E
=SE(VAL.NON.DISP(CERCA.VERT(D3;D101:E298;2;FALSO));0;CERCA.VERT(D3;D101:E298;2;FALSO))
excel 2003
Cedamido
Utente Senior
 
Post: 234
Iscritto il: 17/08/08 23:26

Re: Cerca.vert con parole uguali

Postdi Marius44 » 13/05/16 16:02

Buon pomeriggio a tutti

Penso che il problema, visto quanto hai dichiarato nel post #1, sia la funzione utilizzata: la CERCA.VERT si "ferma alla prima istanza trovata". Poichè tu dici che dalla C in poi i nomi possono essere "uguali", ecco che vien fuori l'inghippo.

Sono d'accordo, comunque, che per avere chiaro il problema sarebbe necessario un tuo file.

Cia,
Mario
Marius44
Utente Senior
 
Post: 143
Iscritto il: 07/09/15 22:00

Re: Cerca.vert con parole uguali

Postdi Cedamido » 14/05/16 00:26

excel 2003
Cedamido
Utente Senior
 
Post: 234
Iscritto il: 17/08/08 23:26

Re: Cerca.vert con parole uguali

Postdi wallace&gromit » 14/05/16 09:19

Cedamido, tu sei dell'UCAS (Ufficio Complicazione Affari Semplici) vero? :D
ecco la formula valida per tutte le colonne:
Codice: Seleziona tutto
=CERCA.VERT($A3;$A$102:$E$299;RIF.COLONNA();0)


P.S. e forza Bartali!
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: Cerca.vert con parole uguali

Postdi Cedamido » 16/05/16 20:59

Funziona bene, grazie.
excel 2003
Cedamido
Utente Senior
 
Post: 234
Iscritto il: 17/08/08 23:26

Re: Cerca.vert con parole uguali

Postdi wallace&gromit » 16/05/16 22:07

Spero che non te la sia presa per la mia battutaccia... siamo tutti qui ad imparare ovviamente.
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21

Re: Cerca.vert con parole uguali

Postdi Cedamido » 17/05/16 21:35

No assolutamente, è vero che devo imparare molto.
excel 2003
Cedamido
Utente Senior
 
Post: 234
Iscritto il: 17/08/08 23:26


Torna a Applicazioni Office Windows


Topic correlati a "Cerca.vert con parole uguali":


Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti