Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Formula che punta a cella con un altra formula

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Formula che punta a cella con un altra formula

Postdi Baldo78 » 10/03/16 17:08

Salve a tutti,
sono nuovo...ho cercato tra i vari topic ma non ho trovato nulla che risolvesse il mio problema ed ho un urgenza a lavoro molto critica.
Il problema è questo nella colonna A ho questi valori
A2 NOME
A3 (vuota)
A4 CODICE
A5 CODICE
A6 CODICE
A7 (vuota)
A8 NOME
A9 CODICE
A10 CODICE
...e cosi via...
Nella cella C4 ho impostato questa formula =SE(B4=1;(SOMMA(B4+C3)))
Nella celle C5 ho impostato questa formula =SE(B5=1;(SOMMA(B5+C4))) e così via
Arrivo al punto....vorrei che nella colonna B mi saltasse fuori il valore 1 se la colonna A contiene il valore "CODICE"
mentre vorrei che mi restituisse lo 0 se ,sempre la colonna A, contiene un valore diverso da "CODICE"
In questo modo nella colonna C avrei un conteggio progressivo dei CODICI
Avevo impostato questa formula nella colonna B =SE(ANNULLA.SPAZI(A4)="";0;SE(VAL.NUMERO(A4);A4;"1"))
che effettivamente funziona restituendomi 1 o 0 nella colonna A
Il problema è che poi nella colonna C mi salta fuori "FALSO" perchè non riconosce il nr 1 o 0 nella colonna B
mentre se (per prova) nella colonna B vado io ad inserire 1 o 0 la formula della colonna C funziona perfettamente.
Insomma...da ignorante mi pare di capire che se una formula punta ad una cella con un altra formula tenga in considerazione
l'intestazione della formula piuttosto che il valore che questa restituisce
Spero di essermi spiegato...vi prego aiutatemi perchè non ne esco!!

P.S.
MI SONO PURE SBAGLIATO...HO SCRITTO IL TOPIC ANCHE IN UNA SEZIONE SBAGLIATA E NON SO COME SI FA PER TOGLIERLO!!
Baldo78
Newbie
 
Post: 3
Iscritto il: 10/03/16 16:38

Sponsor
 

Re: Formula che punta a cella con un altra formula

Postdi wallace&gromit » 10/03/16 17:32

Mi sembra che fai in modo complesso qualcosa di semplice, penso si possa ristrutturare con calma il tutto, però come prima misura togli le virgolette dal valore 1.
Con quelle sei tu che imponi un testo con la scritta 1
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1420
Iscritto il: 16/01/12 14:21

Re: Formula che punta a cella con un altra formula

Postdi Baldo78 » 10/03/16 17:42

Grazie mille Wallace...risolto togliendo le virgolette!
Anche io ho la tua stessa impressione ma essendo totalmente ignorante in materia di formule
mi sono dovuto arrangiare dati anche i tempi piuttosto stretti!
Mi hai salvato!
Baldo78
Newbie
 
Post: 3
Iscritto il: 10/03/16 16:38

Re: Formula che punta a cella con un altra formula

Postdi wallace&gromit » 10/03/16 17:50

Con calma, quando avrai tempo, si potrà vedere come migliorare.
Hai già imparato un paio di cosette, frequentando il forum potrai impararne molte di più.
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1420
Iscritto il: 16/01/12 14:21


Torna a Applicazioni Office Windows


Topic correlati a "Formula che punta a cella con un altra formula":


Chi c’è in linea

Visitano il forum: Anthony47 e 7 ospiti