Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

funzione stringa.estrai per estrae i numeri e ultime 6 games

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

funzione stringa.estrai per estrae i numeri e ultime 6 games

Postdi davide2574 » 25/02/16 13:43

Ciao

allego il file, vorrei sapere se ho sbagliato qualcosa su stringa.estrai perché non mi restituisce esattamente come potrà vedere l'allegato.
Esiste la possibilità che si estrae le ultime 6 partite sia casa , sia fuori e totale quando si aggiorna le ultime partite?
Grazie
Spero che nel file si capisce e ho evidenziato.





https://www.dropbox.com/s/wpzyn6nx17p5g ... .xlsx?dl=0
davide2574
Utente Junior
 
Post: 46
Iscritto il: 15/11/15 16:42

Sponsor
 

Re: funzione stringa.estrai per estrae i numeri e ultime 6 g

Postdi Anthony47 » 25/02/16 14:59

Da una formula che non funziona non si potra' mai scoprire che cosa si voleva ottenere.
Quindi dovresti descrivere quali sono, nel file che hai allegato, i dati di partenza e che cosa si vorrebbe calcolare.
Tuttavia non capisco il significato della formula che usi:
Codice: Seleziona tutto
=SE(E10="";"";CONCATENA(SE(STRINGA.ESTRAI(E10;1;1)="C";(SE(STRINGA.ESTRAI(E10;2;1)>STRINGA.ESTRAI(E10;4;1);"3";SE(STRINGA.ESTRAI(E10;2;1)=STRINGA.ESTRAI(E10;4;1);"1";"0")));"")))

Essa infatti fa riferimento al 4° carattere di una cella che ne contiene solamente 2 (es F0) falsando quindi tutti i confronti previsti nella formula.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: funzione stringa.estrai per estrae i numeri e ultime 6 g

Postdi davide2574 » 28/02/16 00:45

eccomi,

ho risolto problema quelle stringhe che ho sbagliato a selezionare. che scemo sono stato.
ora ho provato ad inserire ma mi restituisce tutti numero 1? come ho evidenziato giallo e le frecce che vorrei estrarre le ultime sei parte e ci sono anche le celle vuote ma deve ignorare.
Spero che stavolta ho spiegato meglio. :roll:

Ecco il file allegato:

https://www.dropbox.com/s/8pgclsfv1m3hk83/ESTRAZIONE%20ULTIME%206%20PARTITE.xlsx?dl=0

grazie ancora.
davide2574
Utente Junior
 
Post: 46
Iscritto il: 15/11/15 16:42

Re: funzione stringa.estrai per estrae i numeri e ultime 6 g

Postdi Anthony47 » 28/02/16 16:34

Prova in B102:
Codice: Seleziona tutto
=INDICE($A2:$AZ2;GRANDE(SE($A2:$AZ2<>"";RIF.COLONNA($A2:$AZ2);"");7-RIF.COLONNA(A1)))

Da confermare con Contr-Maiusc-Enter, non il solo Enter; poi copiare verso destra e poi verso il basso

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: funzione stringa.estrai per estrae i numeri e ultime 6 g

Postdi davide2574 » 28/02/16 21:51

ciao antonhy

sei sempre gentile e disponibile come sempre.
Grazie.
Ma non riesco a capire il perchè.
Quel file che avevo allegato ultima volta e ho inserito la tua formula e funziona benissimo. mentre se inserisco altro file con celle diversi ma le tabelle sono identiche e mi da l'errore #NUM ? :?: :eeh:
davide2574
Utente Junior
 
Post: 46
Iscritto il: 15/11/15 16:42

Re: funzione stringa.estrai per estrae i numeri e ultime 6 g

Postdi Anthony47 » 29/02/16 00:24

Ipotesi a caso:
-Hai meno di 6 risultati disponibili
-Hai "adattato" erroneamente la formula
-La tabella sembra uguale ma e' diversa

Con questo livello di dettaglio, comunque, se vuoi ipotesi piu' attendibili devi chiedere sul forum di www.lostregone.it

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "funzione stringa.estrai per estrae i numeri e ultime 6 games":


Chi c’è in linea

Visitano il forum: Nessuno e 20 ospiti