Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

tabella turni

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

tabella turni

Postdi robi1112 » 20/01/16 11:01

ciao a tutti
in colonna aj mi sommo i vari turni del mese dando valore di 6 alla M e 7 alla P. questo mi va bene dal lunedi al venerdi'
Di sabato i valori dovrebbero essere rispettivamente di M= 5 e P= 6
come posso fare?
http://www.filedropper.com/prova_4
grazie per l'aiuto
robi1112
Utente Junior
 
Post: 45
Iscritto il: 29/10/13 17:05

Sponsor
 

Re: tabella turni

Postdi Anthony47 » 20/01/16 23:46

Immagino che parli del conteggio fatto in AJ11 e sottostanti...
La formula che usi contiene queste componenti (insieme a diverse altre):
Codice: Seleziona tutto
CONTA.SE(E11:AI11;"P")*7;CONTA.SE(E11:AI11;"M")*6;

Devi sostituirli con queste altre:
Codice: Seleziona tutto
(E11:AI11="P")*SE(GIORNO.SETTIMANA($E$9:$AI$9;2)<6;7;6);(E11:AI11="M")*SE(GIORNO.SETTIMANA($E$9:$AI$9;2)<6;6;5);

La formula finale andra' pero' confermata con Contr-Maiusc-Enter, non il solo Enter; poi potra' essere copiata verso il basso.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: tabella turni

Postdi robi1112 » 22/01/16 14:41

perdona l'ignoranza
ma non riesco a confermare la formula :oops: :oops:
robi1112
Utente Junior
 
Post: 45
Iscritto il: 29/10/13 17:05

Re: tabella turni

Postdi alfrimpa » 22/01/16 16:29

Devi tenere premuti i tasti CTRL, MAIUSC (quello con la freccia in su) e dare INVIO.
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 842
Iscritto il: 30/12/13 17:01
Località: Napoli

Re: tabella turni

Postdi robi1112 » 22/01/16 17:07

cosi faccio,ma non succede nulla
robi1112
Utente Junior
 
Post: 45
Iscritto il: 29/10/13 17:05

Re: tabella turni

Postdi robi1112 » 23/01/16 10:31

devo aggiungere qualcosa alle formule?
robi1112
Utente Junior
 
Post: 45
Iscritto il: 29/10/13 17:05

Re: tabella turni

Postdi Anthony47 » 23/01/16 21:51

cosi faccio,ma non succede nulla
Allora devi accendere il pc, perche' se il pc e' gia acceso allora qualcosa dovrebbe essere successo, tipo "mi visualizza un errore", "mi dice che la fomula e' sbagliata", "vedo la formula nella barra della formula ma non c'e' nessun risultato nella cella", "mi restituisce un risultato che e' palesemente errato perche'.... "

Nella cella AJ11 ora usi la formula
Codice: Seleziona tutto
=SOMMA(CONTA.SE(E11:AI11;"P")*7;CONTA.SE(E11:AI11;"M")*6;CONTA.SE(E11:AI11;"N")*10;CONTA.SE(E11:AI11;"F")*7,2;CONTA.SE(E11:AI11;"MN")*16;CONTA.SE(E11:AI11;"MA")*6;CONTA.SE(E11:AI11;"CM")*6;CONTA.SE(E11:AI11;"PR")*6;CONTA.SE(E11:AI11;"PM")*5;CONTA.SE(E11:AI11;"MM")*5;CONTA.SE(E11:AI11;"G")*7;CONTA.SE(E11:AI11;"g1")*7,5;CONTA.SE(E11:AI11;"smn")*10;CONTA.SE(E11:AI11;"msn")*7;CONTA.SE(E11:AI11;"m1")*8;CONTA.SE(E11:AI11;"p1")*8;CONTA.SE(E11:AI11;"104")*6;CONTA.SE(E11:AI11;"C")*7,5;CONTA.SE(E11:AI11;"rf")*6)

Questa e' la "somma" di tanti "casi"; io ti ho suggerito di cambiare i primi due "casi", quelli che se le celle giornaliere sono marcate P ti conta 7 ore e se invece sono marcate M ti conta 6 ore.
La nuova formula complessiva e'
Codice: Seleziona tutto
=SOMMA((E11:AI11="P")*SE(GIORNO.SETTIMANA($E$9:$AI$9;2)<6;7;6);(E11:AI11="M")*SE(GIORNO.SETTIMANA($E$9:$AI$9;2)<6;6;5);CONTA.SE(E11:AI11;"N")*10;CONTA.SE(E11:AI11;"F")*7,2;CONTA.SE(E11:AI11;"MN")*16;CONTA.SE(E11:AI11;"MA")*6;CONTA.SE(E11:AI11;"CM")*6;CONTA.SE(E11:AI11;"PR")*6;CONTA.SE(E11:AI11;"PM")*5;CONTA.SE(E11:AI11;"MM")*5;CONTA.SE(E11:AI11;"G")*7;CONTA.SE(E11:AI11;"g1")*7,5;CONTA.SE(E11:AI11;"smn")*10;CONTA.SE(E11:AI11;"msn")*7;CONTA.SE(E11:AI11;"m1")*8;CONTA.SE(E11:AI11;"p1")*8;CONTA.SE(E11:AI11;"104")*6;CONTA.SE(E11:AI11;"C")*7,5;CONTA.SE(E11:AI11;"rf")*6)


Operativamente, dopo aver accesso il pc e avviato il tuo foglio di lavoro ;) :
-Seleziona la cella AJ11
-Copia la formula e incollala nella barra della formula
-quindi premi e mantieni premuti in successione i tasti Contr Maiusc Enter; rilascia Enter e poi gli altri due tasti (per le formule "normali" basta invece premere il solo Enter). Dovresti vedere (nella barra della formula) la formula contornata da parentesi graffe {} (inserire le graffe da tastiera non e' la stessa cosa...)

Controlla che il risultato restituito sia corretto; se Ok allora copia AJ11 e incollala nelle celle sottostanti.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "tabella turni":


Chi c’è in linea

Visitano il forum: raimea e 6 ospiti