Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

numero progressivo e stampa

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

numero progressivo e stampa

Postdi apocrimata75 » 17/12/15 13:03

Salve, vorrei creare una macro che aggiorni la cella "B20" con valori da quanto indicato nella cella "L4" (inizio, esempio: 1) alla cella "M4" (fine, esempio: 60).

La cella B23 contiene la formula

Codice: Seleziona tutto
=CERCA.VERT(allegati!B20;Foglio4!C4:D500;2;FALSO)


pertanto ad ogni numero di B20 corrisponde un valore diverso in B23 (valori presi dal foglio4).

e stampare i 60 fogli creati.

Esempio:

la macro inserisce il valore 1 in B20 (così si modifica da sola b23)
e stampa il foglio con
Codice: Seleziona tutto
Sub stampa()
'

    ActiveWindow.SelectedSheets.PrintOut From:=1, To:=1, Copies:=1
End Sub



Poi inserisce il valore 2 e stampa

ecc. ecc. fino a 60 (valore in M4).

Avete una soluzione?.

Grazie mille.
Windows 7 - Office 2010
apocrimata75
Utente Senior
 
Post: 181
Iscritto il: 28/05/11 13:22

Sponsor
 

Re: numero progressivo e stampa

Postdi Marius44 » 17/12/15 13:32

E' sempre cosa buona e giusta allegare un file d'esempio, con i tentativi e gli eventuali errori.
Così come hai scritto io non ho capito nulla.

Ciao,
Mario
Marius44
Utente Senior
 
Post: 142
Iscritto il: 07/09/15 22:00

Re: numero progressivo e stampa

Postdi apocrimata75 » 17/12/15 13:47

Concordo, purtroppo non essendo amministratore di rete non riesco a collegarmi ad alcun sito (dropbox ecc.) per allegarlo.
Windows 7 - Office 2010
apocrimata75
Utente Senior
 
Post: 181
Iscritto il: 28/05/11 13:22

Re: numero progressivo e stampa

Postdi apocrimata75 » 17/12/15 16:28

Ho risolto così

Codice: Seleziona tutto
Sub stampanew()

If [n4] <= 0 Then Exit Sub
Do While [b20] < [m4]
  [b20] = [b20] + [n4]
  DoEvents
  Call stampa
Loop
End Sub
Windows 7 - Office 2010
apocrimata75
Utente Senior
 
Post: 181
Iscritto il: 28/05/11 13:22


Torna a Applicazioni Office Windows


Topic correlati a "numero progressivo e stampa":


Chi c’è in linea

Visitano il forum: Nessuno e 18 ospiti