Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Cerca verticale avanzato

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Cerca verticale avanzato

Postdi gemini89 » 26/11/15 13:06

Ciao a tutti,
devo associare delle nomenclature a dei dati. Dato che è molto + difficile spiegare riporto un es.

80035 225
81025 143
80133 131
80078 105

so che

80035 VN32
VN46
VN52
VN67

come aggiungere accanto a 225 i valori associati a 80035 (VN32, VN46, VN52, VN67).

Ho provato con un cerca verticale (Vlook up) ma non sono riuscito.

Avete qualche suggerimento??

Grazie
gemini89
Newbie
 
Post: 1
Iscritto il: 26/11/15 13:01

Sponsor
 

Re: Cerca verticale avanzato

Postdi wallace&gromit » 26/11/15 15:12

ciao gemini, benvenuto nel forum.

Un'idea su cui lavorare potrebbe essere questa:
Codice: Seleziona tutto
=INDICE($K$2:$K$5;PICCOLO(SE($J$2:$J$5=$A2;RIF.RIGA($J$2:$J$5)-1);RIF.COLONNA()-2))
è una formula matriciale, che va inserita in C2 e confermata con Ctrl+Maiusc+Enter e non con il solo enter.
Poi può essere trascinata fino a F2 e si popola con i numeri.

Presuppone che:
la lista iniziale si trova nelle celle da B2 a C5.
La lista di confronto nelle celle da J2 a k5.
Nella colonna J il numero 80035 è ripetuto per ogni occorrenza dei vari VN...

Ovviamente questa è solo la partenza, però se il concetto va bene lo si può poi adattare ai tuoi range reali e impedire messaggi di errore.
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21


Torna a Applicazioni Office Windows


Topic correlati a "Cerca verticale avanzato":


Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti