Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Cerca vert, con indice variabile

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Cerca vert, con indice variabile

Postdi Ubuntus » 18/11/15 16:18

ciao

c'è un modo di utilizzare il cerca vert con indice variabile?

se io ho una foglio excel con dati da A-D, e su questa matrice di dati ci applico il cerca vert cosa succede quando nel mezzo ci aggiungo una colonna ?

si puo fare che indice sia variabile e comprenda quando viene inserito una colonna nuova nella matrice

grazie
Ubuntus
Utente Junior
 
Post: 73
Iscritto il: 24/07/15 15:56

Sponsor
 

Re: Cerca vert, con indice variabile

Postdi alfrimpa » 18/11/15 16:22

Ciao

Ora sono fuori casa e non posso provare ma credo che se inserisci una colonna nella matrice il CERCA.VERT si adatti automaticamente; hai provato a farlo?
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 840
Iscritto il: 30/12/13 17:01
Località: Napoli

Re: Cerca vert, con indice variabile

Postdi ninai » 19/11/15 15:37

ciao
inserendo una colonna in mezzo, la matrice di aggiorna, il problema potrebbe essere l'indice.
per questo bisogna usare un sistema dinamico tipo rif.colonna() oppure colonne() da calibrare in base a quale è la colonna da estrarre.

un esempio concreto e definito permetterebbe di esssere più precisi.
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: Cerca vert, con indice variabile

Postdi Anthony47 » 19/11/15 23:16

Immagine
host immagini
In E3 ho usato questa formula per ottenere il contenuto della colonna intestata "Due":
Codice: Seleziona tutto
=CERCA.VERT(3;A1:D20;CONFRONTA("due";A1:D1;0);0)

L'indice e' ottenuto tramite la funzione Confronta.

Ciao a tutti.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Cerca vert, con indice variabile

Postdi ninai » 20/11/15 07:51

ciao
con l'esempio di Anthony la mia proposta di prima, sarebbe stata:
=CERCA.VERT(3;A1:D20;COLONNE(A1:C1);0)
OPPURE
=CERCA.VERT(3;A1:D20;RIF.COLONNA(C1);0)
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: Cerca vert, con indice variabile

Postdi Ubuntus » 20/11/15 15:48

ciao

l'ho risolto con un indice es $D1$, quando aggiungo una colonna aggiorno a mano l'indice

grazie provero con la vostra versione dinamica
Ubuntus
Utente Junior
 
Post: 73
Iscritto il: 24/07/15 15:56


Torna a Applicazioni Office Windows


Topic correlati a "Cerca vert, con indice variabile":


Chi c’è in linea

Visitano il forum: Marius44, raimea e 14 ospiti