Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Piu convalida dati nella stessa Cella

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Piu convalida dati nella stessa Cella

Postdi Zagor57 » 27/07/15 18:22

Buongiorno a tutto il forum
E' possibile inserire più convalida dati nella stessa cella
es:Convalida dati in C10
1) Consenti> elenco >=$AO$12:$AO$31<<<<Elenco scelta Articoli
2) Consenti> Personalizzato>=SE(A10=100;1;0)<<<<<<<se la cella A10= a 100 devo inserire i dati se =a Zero la cella deve essere disibilitata all'inserimento dati, meglio ancora se protetta

Però sembra che le due cose fatte così non funziona
Naturalmente ci sono tante celle con convalida dati differenti ed elenchi diversi
Allego una foto del problema
http://www.filedropper.com/tettoie
le celle con stesso colore dello sfondo in questo caso devono essere" protette ",ma anchesse a loro volta anno una convalida dati con elenco,cioe a situazioni diverse avranno colore bianco da poter consentire la scelta dell'elenco
Spero di aver dato l'idea di ciò che intendo :?:
chiedo aiuto a trovare una soluzione
Zagor57

Impegno e costanza
ciao da Salvatore
Avatar utente
Zagor57
Utente Junior
 
Post: 70
Iscritto il: 04/05/15 19:35
Località: Massafra TA

Sponsor
 

Re: Piu convalida dati nella stessa Cella

Postdi Flash30005 » 28/07/15 00:29

Pei i file è corretto usare Filedropper come host
ma per le immagini sarebbe opportuno usare
http://postimage.org/
Copiare l'indirizzo (URL) fornito dopo l'upload e incollarlo nel post

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Piu convalida dati nella stessa Cella

Postdi Zagor57 » 28/07/15 07:49

OK Flash non sapevo
Grazie per l'interessamento

Immagine

Ciao
Zagor57

Impegno e costanza
ciao da Salvatore
Avatar utente
Zagor57
Utente Junior
 
Post: 70
Iscritto il: 04/05/15 19:35
Località: Massafra TA

Re: Piu convalida dati nella stessa Cella

Postdi Anthony47 » 30/07/15 01:48

Allora imposta la convalida "da elenco" nella cella; poi crei una Sub Worksheet_Change che, qualora il Target.Address sia pari a "$A$10", se il Target.Value = 100 allora rimuove la protezione alle celle, se il valore e' diverso applica la protezione alle celle.
Ovviamente protezione delle celle presuppone la protezione del foglio, con le relative conseguenze.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Piu convalida dati nella stessa Cella":


Chi c’è in linea

Visitano il forum: Nessuno e 8 ospiti