Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[excel 2007] medie ponderate

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[excel 2007] medie ponderate

Postdi gio969 » 23/07/15 13:05

ciao a tutti,
ho bisogno di un aiutino per calcolare i prezzi medi ponderati di un elenco filtrato. è possibile?
il mio foglio è composto da una serie di colonne:
colonna "a" nome prodotto
colonna "b" quantità
colonna "c" prezzo
le righe sono molte cosi come i prodotti, utilizzando un filtro visualizzo solo il prodotto che mi interessa con le relative quantità e prezzi.
è possibile calcolare il prezzo medio ponderato dell' elenco che sto visualizzando attraverso il filtro?
ho provato con matr.somma prodotto ma chiaramente mi calcola anche tutto il resto nn visualizzato.
grazie anticipatamente
gio969
Utente Junior
 
Post: 40
Iscritto il: 31/05/12 11:20

Sponsor
 

Re: [excel 2007] medie ponderate

Postdi CANAPONE » 23/07/15 13:20

Ciao,

nel database c'è anche una colonna che moltiplica le quantità per il prezzo unitario: se questi valori fossero nella colonna D potrebbe bastare

Codice: Seleziona tutto
=SUBTOTALE(9;D3:D100)/SUBTOTALE(9;B3:B100)


Spero di aver capito
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: [excel 2007] medie ponderate

Postdi gio969 » 23/07/15 13:32

hai centrato in pieno. grazie infinite !!!!
gio969
Utente Junior
 
Post: 40
Iscritto il: 31/05/12 11:20

Re: [excel 2007] medie ponderate

Postdi CANAPONE » 23/07/15 13:33

Ciao

se il database non ha questa colonna D, puoi provare anche una formula di questo tipo:

Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(SUBTOTALE(9;SCARTO(B3:B100;RIF.RIGA(3:100)-MIN(RIF.RIGA(3:100));;1))*SUBTOTALE(9;SCARTO(C3:C100;RIF.RIGA(3:100)-MIN(RIF.RIGA(3:100));;1)))/MATR.SOMMA.PRODOTTO(SUBTOTALE(9;SCARTO(B3:B100;RIF.RIGA(3:100)-MIN(RIF.RIGA(3:100));;1)))




Nell'esempio la formula legge i dati dalla riga 3.
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: [excel 2007] medie ponderate

Postdi CANAPONE » 23/07/15 13:33

Scusa, non avevo visto la tua risposta.

La seconda formula è inutilmente complicata.

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze


Torna a Applicazioni Office Windows


Topic correlati a "[excel 2007] medie ponderate":


Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti