Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Contare Valori restituiti da Formule

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Contare Valori restituiti da Formule

Postdi Omocaig » 09/07/15 14:29

Ciao, questa volta ho un problema abbastanza difficile da spiegare, quindi allego file:

http://www.filedropper.com/esempio_1

Le formule presenti alla riga 6, contano i numeri di records e non il numero di celle che restituiscono un valore.
Ho provato a mediare creando una macro automatica che copi i valori in un intervallo adiacente ( quindi tralasciando e formule ) ma il problema persiste in maniera uguale.
Vi ringrazio molto !

Saluti !
Xp + Office 2003 Ita
Omocaig
Utente Junior
 
Post: 76
Iscritto il: 11/05/15 15:08

Sponsor
 

Re: Contare Valori restituiti da Formule

Postdi ninai » 09/07/15 18:58

Ciao
non so se ho ben capito, prova in C6:
=CONTA.SE(C12:C9997;C11)
e trascina a destra

oppure, se le stringhe in una colonna possono essere diverse:
=CONTA.SE(C12:C9997;"> *")
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: Contare Valori restituiti da Formule

Postdi Omocaig » 10/07/15 10:16

Ciao, è fantastico, funziona ! ho usato =SOMMA.SE(C12:C9997;"> 0") per fare lo stesso ma sommando i numeri estratti in un altro lavoro.
Grazie Mille !
Xp + Office 2003 Ita
Omocaig
Utente Junior
 
Post: 76
Iscritto il: 11/05/15 15:08

Re: Contare Valori restituiti da Formule

Postdi Omocaig » 15/07/15 14:55

Ciao, ho un nuovo problema con un file simile a quello del primo esempio, ovviamente non riesco ad usare la formula che citavo come perfetta nel mio post sopra:

http://www.filedropper.com/esempio2

Qualcuno saprebbe indicarmi come fare a sommare i risultati delle formule ?

Grazie ! Ciao a tutti !
Xp + Office 2003 Ita
Omocaig
Utente Junior
 
Post: 76
Iscritto il: 11/05/15 15:08

Re: Contare Valori restituiti da Formule

Postdi Anthony47 » 16/07/15 02:17

Ma nelle celle che sono richiamate nella formula Somma.Se (C12 e adiacenti) tu non hai numeri ma testo, e il testo non e' fatto per essere sommato...
Per ottenere Numeri in C12 usa la formula
Codice: Seleziona tutto
=SE(VAL.ERRORE(ANNULLA.SPAZI(SOSTITUISCI(STRINGA.ESTRAI($B12;TROVA(C$1;$B12)-5;5);",";"")));"";--ANNULLA.SPAZI(SOSTITUISCI(STRINGA.ESTRAI($B12;TROVA(C$1;$B12)-5;5);",";"")))


Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Contare Valori restituiti da Formule

Postdi Omocaig » 16/07/15 10:40

Ciao, mi pongo il problema perchè sono riuscito ad ottenere il risultato sperato con la formula precedente ( giuro ) ma continuando a lavorare sul file ho modificato qualcosa senza accorgermene e la somma non veniva più attuata, perplesso ho pensato proprio che la formula mi restituisse del testo, un po' come per il concetto di assegnare un colore alla cella con la formattazione condizionata piuttosto che colorarla direttamente, così ho provato a cambiare la formattazione delle celle C12 e adiacenti e quelle con la somma ma non ha prodotto risultato, non sapendo come tornare indietro in quanto i back up erano troppo vecchi, ho chiesto aiuto, non credevo bastasse un doppio trattino per curare il fegato.

Grazie come sempre !

-
Xp + Office 2003 Ita
Omocaig
Utente Junior
 
Post: 76
Iscritto il: 11/05/15 15:08


Torna a Applicazioni Office Windows


Topic correlati a "Contare Valori restituiti da Formule":


Chi c’è in linea

Visitano il forum: Nessuno e 12 ospiti