Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

MEDIARE VALORI A DUE A DUE

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

MEDIARE VALORI A DUE A DUE

Postdi pany221 » 22/06/15 09:22

Buongiorno,
vorrei una formula che facesse la media dei valori a due a due nel modo seguente:

media tra A1 e A2
media tra A3 e A4
media tra A5 e A6

ETC


Qualcuno mi sa dare indicazioni???


grazie 1000
pany221
Utente Junior
 
Post: 43
Iscritto il: 06/05/15 10:08

Sponsor
 

Re: MEDIARE VALORI A DUE A DUE

Postdi CANAPONE » 22/06/15 10:49

Ciao


un modo potrebbe essere questo:

Codice: Seleziona tutto
=SOMMA(INDICE($A$1:$A$100;1+2*RIF.RIGA(A1)-2):INDICE($A$1:$A$100;2+2*RIF.RIGA(A1)-2))/2



Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: MEDIARE VALORI A DUE A DUE

Postdi CANAPONE » 22/06/15 11:17

Ciao,

condivido qualche alternativa, usando SCARTO ed INDIRETTO, funzioni volatili delle quali sarebbe meglio non abusare

Codice: Seleziona tutto
=SE.ERRORE(MEDIA(SCARTO(A1;RIF.RIGA(A1)-1;;2));"")


Codice: Seleziona tutto
=(INDIRETTO("A"&1+(RIF.RIGA(A1)-1)*2)+INDIRETTO("A"&RIF.RIGA(A1)*2))/2


Da queste formule ottieni - più o meno - gli stessi risultati.

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: MEDIARE VALORI A DUE A DUE

Postdi pany221 » 22/06/15 13:05

grazie 1000
pany221
Utente Junior
 
Post: 43
Iscritto il: 06/05/15 10:08

Re: MEDIARE VALORI A DUE A DUE

Postdi pany221 » 22/06/15 13:18

grazie...
e se invece volessi scrivere un valore ogni due


es:
ho i seguenti valori
A1 : trial 1
A2 : trial 2
A3 : trial 3
A4 : trial 4

e voglio riportare solo
trial 1
trial 3



come posso fare????
pany221
Utente Junior
 
Post: 43
Iscritto il: 06/05/15 10:08

Re: MEDIARE VALORI A DUE A DUE

Postdi pany221 » 22/06/15 13:30

CANAPONE ha scritto:Ciao


un modo potrebbe essere questo:

Codice: Seleziona tutto
=SOMMA(INDICE($A$1:$A$100;1+2*RIF.RIGA(A1)-2):INDICE($A$1:$A$100;2+2*RIF.RIGA(A1)-2))/2



Saluti




CIAO,
questa funzione mi da alcuni errori se la tiro per tante righe...ti mando il file su cui devo eseguire la media due a due...la colonna su cui devo eseguire la media due a due è la colonna C
pany221
Utente Junior
 
Post: 43
Iscritto il: 06/05/15 10:08

Re: MEDIARE VALORI A DUE A DUE

Postdi pany221 » 22/06/15 13:32

pany221
Utente Junior
 
Post: 43
Iscritto il: 06/05/15 10:08

Re: MEDIARE VALORI A DUE A DUE

Postdi Anthony47 » 22/06/15 13:33

Per il quesito precedente, prova in B1:
Codice: Seleziona tutto
=SCARTO(A$1;(RIF.RIGA(A1)-1)*2;0)
poi copi verso il basso

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: MEDIARE VALORI A DUE A DUE

Postdi CANAPONE » 22/06/15 16:41

Ciao,

aggiustando i riferimenti,


=SOMMA(INDICE($C$2:$C$65336;1+2*RIF.RIGA(A1)-2):INDICE($C$2:$C$65336;2+2*RIF.RIGA(A1)-2))/2


mi restituisce la media C2:C3, C4:C5 sino all'ultima riga pari accoppiabile C65534:C65535

=SE.ERRORE(MEDIA(SCARTO(C2;RIF.RIGA(A1)-1;;2));"")


Spero sia d'aiuto
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: MEDIARE VALORI A DUE A DUE

Postdi CANAPONE » 22/06/15 16:52

Ciao,

ho letto ora tua seconda domanda

Per ottenere un elenco dalla colonna C estraendo un valore sì ed uno no


=INDICE($C$2:$C$65536;RIF.RIGA(A1)*2-1)

da copiare in basso
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze


Torna a Applicazioni Office Windows


Topic correlati a "MEDIARE VALORI A DUE A DUE":


Chi c’è in linea

Visitano il forum: Nessuno e 12 ospiti

cron