Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

conta valori univoci a intervalli variabili

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

conta valori univoci a intervalli variabili

Postdi colcoz » 25/03/15 11:57

Buongiorno a tutti.
intanto grazie ancora per il supporto che ogni volta mi fornite.
ho cercato di risolvere il problema leggendo i diversi forum e una parte l'ho portata a casa.
sostanzialmente nella colonna G ho una serie di nomi che si ripetono, a volte sono si ripetono 1 volta a volte n volte in maniera sparsa. Devo contare i Valori univoci presenti e ho trovato queste 2 formule:

=SOMMA(SE(FREQUENZA(CONFRONTA(G9:G1376;G9:G1376;0);CONFRONTA(G9:G1376;G9:G1376;0))>0;1))

=SOMMA(SE(FREQUENZA(SE(LUNGHEZZA(G9:G5000)>0;CONFRONTA(G9:G5000;G9:G5000;0);""); SE(LUNGHEZZA(G9:G5000)>0;CONFRONTA(G9:G5000;G9:G5000;0);""))>0;1))

la seconda inserita come formula matriciale e funzionano entrambe. (io necessito della seconda perchè nell'intervallo ho anche delle celle vuote).

ora il mio problema è questo: nella colonna D ho inserita per ogni valore della colonna G una data e ho bisogno di contare i valori univoci suddivisi per data. se può servire il numero di nomi per ogni singola data varia di giorno in giorno, ma la data è inserita in modo incrementale e non sparsa.

Come posso fare?
colcoz
Utente Junior
 
Post: 27
Iscritto il: 06/02/15 15:23

Sponsor
 

Re: conta valori univoci a intervalli variabili

Postdi Anthony47 » 25/03/15 13:05

Suggerisco di farti, ad esempio da I2 verso il basso, l' elenco delle date presenti in colonna D; puoi usare per quest oil Filtro avanzato, scegliendo l' opzione Valori unici, copia in altra posizione.
Poi in J2 usi la formula
Codice: Seleziona tutto
=SOMMA(SE(FREQUENZA(SE((LUNGHEZZA($G$9:$G$5000)>0)*($D$9:$D$5000=I2);CONFRONTA($G$9:$G$5000;$G$9:$G$5000;0);""); SE((LUNGHEZZA($G$9:$G$5000)>0)*($D$9:$D$5000=I2);CONFRONTA($G$9:$G$5000;$G$9:$G$5000;0);""))>0;1))
Va inserita come "matriciale" e poi copiata verso il basso per quante date hai.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: conta valori univoci a intervalli variabili

Postdi colcoz » 25/03/15 14:01

Fantastico funziona tutto!!!
grazie mille
colcoz
Utente Junior
 
Post: 27
Iscritto il: 06/02/15 15:23


Torna a Applicazioni Office Windows


Topic correlati a "conta valori univoci a intervalli variabili":


Chi c’è in linea

Visitano il forum: enrico43 e 10 ospiti