Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Restituisce il valore di una cella da un'altra

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Restituisce il valore di una cella da un'altra

Postdi paloma » 06/03/15 21:54

Ciaoo,
dopo qualche anno di letargo riappaio per chiedere una mano per risolvere un problema penso banale.
In un foglio excel nella colonna G ho una serie di valori numerici diversi tra di loro senza alcun ordine particolare. Quello che vorrei è riportare, nella cella M100, il valore della cella della colonna B corrispondente al valore più basso (ovvero il minimo) di quelli presenti nella colonna G.
Ipotizzando di avere le due colonne così composte:
B G
3.........15
2..........8
6..........2
9..........6

In questo caso vorrei semplicemente riportare in una cella il valore 6 ovvero quello della colonna B corrispondente al più piccolo valore della colonna G.

Se qualcuno riesce a darmi una mano vi ringrazio un sacco!!! :)
paloma
Utente Junior
 
Post: 64
Iscritto il: 29/10/07 09:38

Sponsor
 

Re: Restituisce il valore di una cella da un'altra

Postdi ricky53 » 06/03/15 23:25

Ciao,
lo hai sc ritto tu "... (ovvero minimo) ..." ... hai provato con la funzione "MIN" ?
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Restituisce il valore di una cella da un'altra

Postdi Flash30005 » 07/03/15 01:56

Ciao Paloma bentornata

in M100 inserisci questa formula
Codice: Seleziona tutto
=INDICE(B1:B100;CONFRONTA(MIN(G1:G100);G1:G100;0);1)

adatta il numero riga di B e G se sono superiori a 100

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Restituisce il valore di una cella da un'altra

Postdi paloma » 08/03/15 00:47

Flash30005 ha scritto:Ciao Paloma bentornata

in M100 inserisci questa formula
Codice: Seleziona tutto
=INDICE(B1:B100;CONFRONTA(MIN(G1:G100);G1:G100;0);1)

adatta il numero riga di B e G se sono superiori a 100

ciao


FANTASTICOOOOO
funziona perfettamente! Grazie mille Flash!!
Secondo te con la stessa funzione indice e confronta potrei fare in modo di estrarre la media di tutti i valori presenti in colonna G riferiti ad un dato valore della colonna B???
Rispetto alle due colonne B e G riesco a riportare dalla cella M10 il valore medio della colonna G riferita a ciascun valore della colonna B?
Cioè con il seguente esempio:
B G
2 15
3 11
2 23
1 33
3 12
1 5
1 7
posso avere in M10 il valore medio dei corrispondenti G associati ai valori B =2 (e quindi la media tra 15 e 33) mentre in M11 il valore medio dei corrispondenti G associati ai valori B=3 ( e quindi la media tra 11 e 12)???
Grazie ancora infinite!!!
paloma
Utente Junior
 
Post: 64
Iscritto il: 29/10/07 09:38

Re: Restituisce il valore di una cella da un'altra

Postdi ricky53 » 08/03/15 01:14

Ciao,
volevi dire
e quindi la media tra 15 e 23
e non 33.
Proseguendo la media di B=1 dei valori in "G" 33, 5 e 7

Con le formule puoi utilizzare
Codice: Seleziona tutto
=SOMMA.SE(B1:B100;B101; G1:G100)/CONTA.SE(B1:B100; B101)

Dove in B101 scriverai "1", "2" ,"3" , ...

Prova anche con una tabella Pivot utilizzando le due colonne "B" e "G"
Per i campi riga utilizza la "B", per i "Dati" utilizza la colonna "G" e scegliendo come impostazione per il campo della colonna "G" su "Riepiloga per" sceglierai "Media"
Ultima modifica di ricky53 su 08/03/15 01:25, modificato 4 volte in totale.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: Restituisce il valore di una cella da un'altra

Postdi Flash30005 » 08/03/15 01:20

Non riesco a capire se in G hai dei valori dei quali vuoi fare una media o se in G hai già la media di alcuni valori e vuoi rilebare in B un certo valore di media (ma mi sembra il caso precedente)
presumo quindi che in G hai dei valori esempio
2
4
e vuoi trovare la media di questi due valori cioè 3
non ottieni nulla che corrisponda alla colonna B
se invece crei una colonna appoggio con le medie che vorresti ottenere allora puoi applicare la stessa formula di prima senza la funzione minimo un quanto la media è già un valore "consolidato" nella colonna appoggio.

Ricapitolando Min(range) è un solo valore cioè il più piccolo valore di un range ed è esistente nel range stesso e trovi la riga di appartenenza
la media è somma dei valori in un range diviso il loro numero e non necessariamente esiste nel range (anzi molto probabilmente non esiste) pertanto non si può trovare "l'indice" ovvero la riga corrispondente

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Restituisce il valore di una cella da un'altra

Postdi ninai » 08/03/15 10:46

ciao
giusto per partecipare e porgere un saluto, due formule alternative alle vostre precedenti:
Codice: Seleziona tutto
=SOMMA(INDICE(B1:B100*(G1:G100=MIN(G1:G100));))

e
Codice: Seleziona tutto
=MEDIA(INDICE(G1:G100*(B1:B100=B101);))
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: Restituisce il valore di una cella da un'altra

Postdi Anthony47 » 08/03/15 21:53

Non so se con le formule pubblicate Paloma ha risolto il problema della media; nell' ipotesi che No aggiungo la mia formula:
Codice: Seleziona tutto
=MEDIA(SE(B1:B100=I1;G1:G100;""))
Va confermata con Contr-Maiusc-Enter, non il solo Enter.
Il valore (di colonna B) per cui si vuol far la media (di quanto e' in colonna G) l'ho messo in I1.

Ciao a tutti.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Restituisce il valore di una cella da un'altra":


Chi c’è in linea

Visitano il forum: alfrimpa e 20 ospiti