Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel] contare solo le ultime N righe

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel] contare solo le ultime N righe

Postdi Zetsu » 23/02/15 19:40

Ciao ragazzi!
ho letto su questo 3d una cosa simile a quella che serve a me :

viewtopic.php?t=101057

ma io ho delle colonne separate dove conto gli 1, X, 2, i risultati delle partite, e li sparo su 3 celle con una formula come

=CONTA.SE($Q$11:$Q$1000;1)

=CONTA.SE($Q$11:$Q$1000;"X")

=CONTA.SE($Q$11:$Q$1000;2)

A me servirebbe dirgli : guarda solo gli ultimi N risultati partendo dalla riga 1.000 e non tornare più indietro della data " XX/YY/ZZ "
che si trova nella colonna A , da A10 ad A1.000, un doppio controllo insomma.

Come potrei procedere?

grazie mille a tutti dell' attenzione.

PS: mi consigliate da dove cominciare a studiare VBA?
Zetsu
Utente Junior
 
Post: 27
Iscritto il: 23/11/14 19:21

Sponsor
 

Re: [Excel] contare solo le ultime N righe

Postdi Flash30005 » 23/02/15 23:35

E' consigliabile l'invio del file da parte tua
e questa data XX/YY/ZZ come la determini?
forse impostandola in una cella?
tutto questo per impostare una macro adatta al tuo quesito

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: [Excel] contare solo le ultime N righe

Postdi Anthony47 » 24/02/15 02:09

Con formula:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(A11:A1000>T1);--(Q11:Q1000=1))
La data limite e' scritta in T1; adatta alle tue esigenze.
Questo senza chiedermi che cosa c'entra la discussione a cui fai riferimento...

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel] contare solo le ultime N righe

Postdi Zetsu » 24/02/15 14:56

scusate l' assenza...

ecco il file con scritto quello che vorrei.

sostanzialmente sì, vorrei decidere la data dalla quale partire scrivendola in una cella
e scegliere anche N sempre come " variabile ", perché sto facendo dei test.

Grazie mille per la macro, troppo gentili.

http://www.filedropper.com/test_60
Zetsu
Utente Junior
 
Post: 27
Iscritto il: 23/11/14 19:21

Re: [Excel] contare solo le ultime N righe

Postdi Anthony47 » 25/02/15 23:26

Hai provato le formule? Con quali risultati?

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel] contare solo le ultime N righe

Postdi Zetsu » 26/02/15 11:04

ciao a tutti.
Con la matrice somma prodotto che mi avete consigliato ho risolto il problema della data, adattando la formula.
resta il problema di limitare la " conta " ad N .

Se dalla data limite ad oggi ho meno di N risultati ok.
Se dalla data limite ad oggi ho più risultati allora deve fermarsi al Nsimo risultato.
E quest ultima è la parte che mi fa impazzire, perché anche dopo aver visto ore e ore di tutorial su youtube non riesco a intrecciare tutte le formule che ho visto per creare quella che mi serve.

PS : forte matrice somma prodotto!
Zetsu
Utente Junior
 
Post: 27
Iscritto il: 23/11/14 19:21

Re: [Excel] contare solo le ultime N righe

Postdi ninai » 26/02/15 16:16

ciao
un pochino contorta ma sembra funzionare,
ho dovuto usare una colonna di appoggio, in J8: =CONTA.SE($I$8:I8;"> *") e trascini in basso fino in fondo

in L24:
=CONTA.SE(INDIRETTO("I"&CONFRONTA($M$18;$A$8:$A$94;0)+7&":I"&CONFRONTA(CERCA($M$18;$A$8:$A$94;$J$8:$J$94)+$M$20;$J$8:$J$94;0)+7);L$37)
e trascini a destra
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: [Excel] contare solo le ultime N righe

Postdi Zetsu » 26/02/15 22:30

ciao, hai scritto quello a cui avevo pensato ma che non riuscivo a trasformare in formula.
la colonna di appoggio è ok, la super formula invece mi da errore #N/D.

dopo 8 ore a lavoro davanti ad un pc a fare l' equivalente di un data entry in una ditta di spedizioni non ho le capacità
necessarie a capire dove sia l' errore, anche perché per me indiretto mixato a confronta e cerca è un bel rompicapo O:)
domani guardo meglio e ti dico, intanto un grandissimo grazie di cuore a tutti :)
Zetsu
Utente Junior
 
Post: 27
Iscritto il: 23/11/14 19:21

Re: [Excel] contare solo le ultime N righe

Postdi Anthony47 » 26/02/15 23:37

Con la colonna di appoggio suggerita da ninai, in L39:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--($A$8:$A$94>=$M$18);--($J$8:$J$94>=(MAX($J$8:$J$94)-$M$20));--($I$8:$I$94=L37))

Poi copi nelle due celle adiacenti.

Ho ignorato, perche' non ne ho afferrato il significato, l' istruzione "O9 non deve essere maggiore di N, scritto in M20"

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel] contare solo le ultime N righe

Postdi ninai » 27/02/15 08:00

ciao
fermo restando che la formula di Anthony mi piace di più, ripropongo la mia precdedente che risulta tagliata nella visualizzazione:
Codice: Seleziona tutto
=CONTA.SE(INDIRETTO("I"&CONFRONTA($M$18;$A$8:$A$94;0)+7&":I"&CONFRONTA(CERCA($M$18;$A$8:$A$94;$J$8:$J$94)+$M$20;$J$8:$J$94;0)+7);L$37)
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina


Torna a Applicazioni Office Windows


Topic correlati a "[Excel] contare solo le ultime N righe":


Chi c’è in linea

Visitano il forum: Nessuno e 47 ospiti