Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

excel: funzione mese() + formula complessa

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

excel: funzione mese() + formula complessa

Postdi karug64 » 03/02/15 20:36

Salve a tutti.
Rieccomi qui, dopo tanto tempo, per chiedere ancora il vs aiuto.
Ho un file excel composto da tanti fogli chiamati col nome dell'anno (2005/2006/2007....2015)
Ognuno di queste contiene un numero di righe variabile (per esempio il 2005, 10, il 2006, 7, il 2007,19 ecc.. che sono riempite in continuo, (senza salti) ma non fino alla fine. Esempio:
foglio 2010:
righe 1-7 con dati
righe 8-9 vuote
riga 10 con dati diversi dalle prime (totali)
)
La loro composizione è, però, sempre uguale.
Nella seconda colonna ho una data
e nella "x" riga (variabile da foglio a foglio) ho in cella "Ax" la scritta "END" che identifica la fine dei dati.
Infine ho un foglio "riepilogo" in cui devo, appunto, ricapitolare dei dati rivenienti dai vari fogli.

Ok. Veniamo alle domande:
se nel foglio riepilogo scrivo (cella B2)
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(1*(MESE('2010'!$B$3:$B$10)=1))

ottengo quante volte è presente il mese Gennaio nella colonna B
Supponiamo, solo per esempio, che le 7 date siano tutte del mese di Gennaio: invece di ottenere 7 ottengo 9, cioè le due righe vuote le considera come date di gennaio ..... non capisco perchè.....
Quindi sono costretto a modificare sempre la formula cambiando $B$10 in $B$x dove x è l'ultima riga con data.

E qui arriva la seconda domanda:
come posso fare ad identificare nella formula (che ora è diventata

Codice: Seleziona tutto
=SE(MATR.SOMMA.PRODOTTO(1*(MESE('2010'!$B$3:$B$7)=1))<>0;MATR.SOMMA.PRODOTTO(1*(MESE('2010'!$B$3:$B$7)=1));"")


per evitare di vedere lo 0 se il mese non è presente )

l'ultima riga contenente una data ?

E possibile ?
Grazie

ma perchè
Office 2010
karug64
Utente Senior
 
Post: 580
Iscritto il: 20/11/11 21:22

Sponsor
 

Re: excel: funzione mese() + formula complessa

Postdi Flash30005 » 04/02/15 00:47

Penso che, per risolvere il tuo quesito, sia più idonea una macro ma dovresti inviare il file (modificando i dati sensibili)
meglio con un esempio pratico sul foglio riepilogo stesso

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: excel: funzione mese() + formula complessa

Postdi Anthony47 » 04/02/15 01:16

Stasera Flash ti smentisco, perche' non c' e' bisogno di macro...
Le celle vuote, nella logica del sistema date di Excel, corrispondono a 0-genn-1900, quindi vengono contate nella formula di karug.
Prova con questa:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(MESE('2010'!$B$3:$B$10)=1);--('2010'!B3:B10<>0))
Della seconda formula non ho capito la logica quindi non so come manipolarla; spero che quanto detto per la prima formula sia utilizzabile anche per la seconda.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: excel: funzione mese() + formula complessa

Postdi karug64 » 04/02/15 20:45

Anthony47 ha scritto:Prova con questa:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(MESE('2010'!$B$3:$B$10)=1);--('2010'!B3:B10<>0))


Della seconda formula non ho capito la logica quindi non so come manipolarla; spero che quanto detto per la prima formula sia utilizzabile anche per la seconda.



Grazie Anthony. Così ho risolto. Il secondo problema era, in effetti, legato al primo e quindi tutto risolto.

Grazie ancora.
Office 2010
karug64
Utente Senior
 
Post: 580
Iscritto il: 20/11/11 21:22


Torna a Applicazioni Office Windows


Topic correlati a "excel: funzione mese() + formula complessa":


Chi c’è in linea

Visitano il forum: Nessuno e 10 ospiti