Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel 10] Funzione che restituisca tutti i campi con..

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel 10] Funzione che restituisca tutti i campi con..

Postdi Sbarba » 15/01/15 10:46

Buongiorno a tutti,

non sapevo bene che titolo dare alla discussione con le parole a disposizione :)


Io ho una tabella del tipo:

ETÀ;NOME;SESSO;
21;Mario;maschio
21;Matteo;maschio
20;Sara;femmina
21;Simona;femmina
20;Luigi;maschio
22;Luca;maschio
23;Stefania;femmina

e mi servirebbe avere, in un altro foglio, l'elenco di tutti quelli che hanno 21 anni. del tipo:

ETÀ;NOME
21; Mario; Matteo; Simona
20; Sara, Luigi
22; Luca
23; Stefania

Con CERCA.VERT avrei solo il primo dato (in questo caso Mario per i 21 e Sara per i 20), mentre utilizzando le tabelle pivot avrei quanto desiderato, però essendo molto numerosi i campi di cui devo avere l'elenco (nell'esempio l'età), verrebbe un file troppo grosso.

Mi chiedevo quindi se ci fosse un modo per ottenere il risultato della tabella pivot, possibilmente con l'elenco disposto in orizzontale, utilizzando però una funzione.

Spero di essere riuscito a spiegarmi :)

Grazie in anticipo
Ultima modifica di Sbarba su 15/01/15 11:00, modificato 1 volte in totale.
Sbarba
Utente Junior
 
Post: 36
Iscritto il: 07/10/14 15:56

Sponsor
 

Re: [Excel] Funzione che restituisca tutti i campi con...

Postdi CANAPONE » 15/01/15 10:58

Ciao,

che versione di Excel hai a disposizione?
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: [Excel] Funzione che restituisca tutti i campi con...

Postdi Sbarba » 15/01/15 11:00

CANAPONE ha scritto:Ciao,

che versione di Excel hai a disposizione?


Ciao! Mi sono dimenticato di scriverlo, 2010
Sbarba
Utente Junior
 
Post: 36
Iscritto il: 07/10/14 15:56

Re: [Excel 10] Funzione che restituisca tutti i campi con..

Postdi CANAPONE » 15/01/15 11:04

Ciao

faccio un esempio, in B2:B100 i nomi, in A2:A100 le età, in E2 scrivi 21, in F2:


Codice: Seleziona tutto
=SE.ERRORE(INDICE($B$2:$B$100;AGGREGA(15;6;RIF.RIGA($A$2:$A$100)-1/($A$2:$A$100=$E2);COLONNE($A1:A$1)));"")



copia poi la formula verso destra per ottenere la serie.

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: [Excel 10] Funzione che restituisca tutti i campi con..

Postdi Sbarba » 15/01/15 11:11

CANAPONE ha scritto:Ciao

faccio un esempio, in B2:B100 i nomi, in A2:A100 le età, in E2 scrivi 21, in F2:


Codice: Seleziona tutto
=SE.ERRORE(INDICE($B$2:$B$100;AGGREGA(15;6;RIF.RIGA($A$2:$A$100)-1/($A$2:$A$100=$E2);COLONNE($A1:A$1)));"")



copia poi la formula verso destra per ottenere la serie.

Saluti


Fantastico! Era proprio quello che volevo, grazie mille! E grazie anche per la tempestività :)

Già che ci sono, potrei chiedere dove trovare qualche tutorial, magari in pdf, per queste funzioni più complesse? Grazie nuovamente
Sbarba
Utente Junior
 
Post: 36
Iscritto il: 07/10/14 15:56

Re: [Excel 10] Funzione che restituisca tutti i campi con..

Postdi CANAPONE » 15/01/15 11:13

Ciao,

grazie a te del riscontro

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: [Excel 10] Funzione che restituisca tutti i campi con..

Postdi CANAPONE » 15/01/15 11:28

Ciao

non ho visto i video 46-47-48, ma posso garantirti che Gerardo è molto chiaro.

https://www.youtube.com/watch?v=0aQ6nmzxnnM


Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: [Excel 10] Funzione che restituisca tutti i campi con..

Postdi Sbarba » 15/01/15 18:12

CANAPONE ha scritto:Ciao

non ho visto i video 46-47-48, ma posso garantirti che Gerardo è molto chiaro.

https://www.youtube.com/watch?v=0aQ6nmzxnnM


Saluti


Grazie mille, molto gentile. Li guarderò sicuramente, magari partendo anche dai primi

Buona serata :)
Sbarba
Utente Junior
 
Post: 36
Iscritto il: 07/10/14 15:56


Torna a Applicazioni Office Windows


Topic correlati a "[Excel 10] Funzione che restituisca tutti i campi con..":


Chi c’è in linea

Visitano il forum: Anthony47 e 5 ospiti