Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel 2013] Somma.se + media

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel 2013] Somma.se + media

Postdi fastbike73 » 31/12/14 12:39

Buongiorno e buon anno a tutto il forum,
espongo subito il quesito. Nel range A5:A370 ho il calendario del 2014 in formato
data estesa (mercoledì 1 gennaio 2014). In B ho dei valori in corrispondenza di date diverse.
Quindi da F4 a K4 ho i giorni della settimana.

Il mio intento sarebbe quello di estrarre la media dei valori in base al giorno della settimana.
Per intenderci:
Lunedi (media dei valori riscontrati in tutti i lunedì dell'anno)
Martedì (media dei valori riscontrati in tutti i martedì dell'anno).
....
Sabato (media dei valori riscontrati in tutti i sabati dell'anno).
Le formule le dovrei inserire nelle celle da F5 a K5.
Mi potreste aiutare?
fastbike73
Win 7 & Office 2013
Filemaker Pro v. 13
fastbike73
Utente Senior
 
Post: 220
Iscritto il: 23/04/14 10:54

Sponsor
 

Re: [Excel 2013] Somma.se + media

Postdi ninai » 31/12/14 12:57

Ciao
nel caso in F4:K4 i giorni siano riportati come Lunedì, Martedì ecc. ed in A i vari giorni devono tutti essere considerati (anche quelli senza un valore in B), in F5:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO((TESTO($A$5:$A$370;"GGGG")=F$4)*$B$5:$B$370)/MATR.SOMMA.PRODOTTO(--(TESTO($A$5:$A$370;"GGGG")=F$4))

e trascini a destra
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: [Excel 2013] Somma.se + media

Postdi ninai » 31/12/14 17:45

se invece vuoi escludere dalla media le date senza un valore in B:

Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO((TESTO($A$5:$A$370;"GGGG")=F$4)*$B$5:$B$370)/MATR.SOMMA.PRODOTTO(($B$5:$B$370<>"")*(TESTO($A$5:$A$370;"GGGG")=F$4))
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: [Excel 2013] Somma.se + media

Postdi fastbike73 » 03/01/15 08:33

ninai ha scritto:se invece vuoi escludere dalla media le date senza un valore in B:

Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO((TESTO($A$5:$A$370;"GGGG")=F$4)*$B$5:$B$370)/MATR.SOMMA.PRODOTTO(($B$5:$B$370<>"")*(TESTO($A$5:$A$370;"GGGG")=F$4))


Buongiorno Ninai, stranamente non vedo la risposta che avevo inviato ieri mattina. Comunque, la formula funziona correttamente. Se oltre alla media volessi cercare nel range dei valori il valore max e min per giorno della settimana come potrei modificare la formula? Inoltre se non ti è troppo disturbo potresti spiegarmi il meccanismo della formula che mi hai suggerito?
fastbike73
Win 7 & Office 2013
Filemaker Pro v. 13
fastbike73
Utente Senior
 
Post: 220
Iscritto il: 23/04/14 10:54

Re: [Excel 2013] Somma.se + media

Postdi ninai » 03/01/15 19:01

Ciao
per il max ed in min, ti potrei consigliare delle matriciali tipo:
=Max(se(TESTO($A$5:$A$370;"GGGG")=F$4;$B$5:$B$370))
=min(se(($B$5:$B$370<>"")*(TESTO($A$5:$A$370;"GGGG")=F$4);$B$5:$B$370)

NB
per il max la matriciale si potrebbe evitare attraverso INDICE()

per la spiegazione della media, le due matr.somma.prodotto() non fanno altro che sommare e contare con criteri (sarebbero un somma.se() diviso un conta.se()).
Solo che, a differenza di queste funzioni, accettano funzioni annidate e accettano più criteri.
la funzione annidata è:
TESTO($A$5:$A$370;"GGGG")=F$4
che estrae il giorno della settimana, in formato testo, dalle date in A, confrontandolo con quello in F4 restituisce vero/falso per sommare o non sommare i valori in B
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina


Torna a Applicazioni Office Windows


Topic correlati a "[Excel 2013] Somma.se + media":


Chi c’è in linea

Visitano il forum: Nessuno e 8 ospiti