Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

***Excel SE Nidificata ed errore #N/D***

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

***Excel SE Nidificata ed errore #N/D***

Postdi ProbePotter » 21/11/14 10:13

La formula qui sotto riporta l'errore #N/D, quando in B6 il campo è vuoto (quello con al città da selezionare con menu a tendina).
Ci sono due condizioni SE in B3 (tipo di Ora), allora cerca B6 (la città) nel Range (Dati!B2:M500), poi la colonna 11 e 12.

=+SE(B3="Ora Solare";CERCA.VERT(B6;Dati!B2:M500;11;0);SE(B3="Ora Legale";CERCA.VERT(B6;Dati!B2:M500;12;0);""))

Essendo nidificata, non mi è possibile aggiungere le sottofunzioni: =SE(VAL.ERRORE(ecc... ; oppure =SE(VAL.NON.DISP(ecc...
Secondo voi è possibile tramite una funzione di excel, non visualizzare l'errore #N/D, quando in B6 il campo è vuoto?

Grazie
Avatar utente
ProbePotter
Utente Senior
 
Post: 159
Iscritto il: 20/09/06 18:37

Sponsor
 

Re: ***Excel SE Nidificata ed errore #N/D***

Postdi Zer0Kelvin » 21/11/14 11:37

ProbePotter ha scritto:Essendo nidificata, non mi è possibile aggiungere le sottofunzioni...
E perchè mai :?:
Comunque basterebbe usare SE
=SE(B6="";"";SE(B3="Ora Solare";CERCA.VERT(B6;Dati!B2:M500;11;0);SE(B3="Ora Legale";CERCA.VERT(B6;Dati!B2:M500;12;0);"")))
[Win7,Office2010]
Condividere la conoscenza aumenta la ricchezza di tutti(Z0°K)
Dai ad un uomo un pesce e lo avrai sfamato per un giorno;insegnagli a pescare e lo avrai sfamato per sempre(Confucio)
Il sonno della ragione genera mostri(Francisco Goya)
Avatar utente
Zer0Kelvin
Utente Senior
 
Post: 303
Iscritto il: 08/04/12 11:23

Re: ***Excel SE Nidificata ed errore #N/D***

Postdi ninai » 21/11/14 11:55

ciao
se quando B6 non è vuoto, in B3 è sempre presente "Ora legale" oppure "Ora solare", si potrebbe eliminare un SE().
=SE(B6="";"";SE(B3="Ora Solare";CERCA.VERT(B6;Dati!B2:M500;11;0);CERCA.VERT(B6;Dati!B2:M500;12;0)))


volendo anche 2 SE()
=SE(B6="";"";CERCA.VERT(B6;Dati!B2:M500;11+(B3="Ora Legale");0)
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: ***Excel SE Nidificata ed errore #N/D***

Postdi ProbePotter » 21/11/14 12:03

Le ho provate entrambe e funzionano perfettamente.
Grazie per la collaborazione

Ciao
Avatar utente
ProbePotter
Utente Senior
 
Post: 159
Iscritto il: 20/09/06 18:37


Torna a Applicazioni Office Windows


Topic correlati a "***Excel SE Nidificata ed errore #N/D***":


Chi c’è in linea

Visitano il forum: Nessuno e 10 ospiti