Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel - ricerca confronto e restituzione valori

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel - ricerca confronto e restituzione valori

Postdi Fpas » 22/10/14 16:45

Buonasera
sono di nuovo a chiedere il vostro aiuto per lo sviluppo di un file excel.
ho provato a fare una ricerca sul forum senza riuscire a trovare niente di pertinente.
spero inoltre che il titolo sia corretto :D

provo a spiegare la mia situazione.
Ho tre fogli di lavoro (descrizione, risultato, db).

in "db", sulla colonna A, ho un elenco a cui corrisponde, sulla colonna C, un valore numerico

Immagine

in "descrizione", alle celle C14, C15 e C16, tramite una convalida dati, assegno un valore "pescato" ( :eeh:) dalla colonna A del foglio "db"

Immagine

ora vorrei che nel foglio "risultato", in una precisa posizione (poniamo K1) mi venga in automatico riportato solo l'articolo con il corrispondente valore (in db) più alto e, se fosse possibile, in L1 il valore stesso.

spero sia comprensiva la mia descrizione.

grazie in anticipo a chi vorrà aiutarmi.

ciao
Francesco

Win7 + Office 2007 Ita
Fpas
Newbie
 
Post: 7
Iscritto il: 17/10/14 12:00

Sponsor
 

Re: Excel - ricerca confronto e restituzione valori

Postdi ninai » 22/10/14 17:57

Ciao
fra il tempo che hai impiegato a mettere le immagini e quello che ho impiegato io a ricreare il file con i tre fogli, non facevi prima e meglio ad allegare il file???

SPERANDO CHE NON ABBIA SBAGLIATO NELLA RICOSTRUZIONE, ti propongo:
in K1:
Codice: Seleziona tutto
=INDICE(db!A2:A11;CONFRONTA(MAX(INDICE(db!C2:C11*CONTA.SE(descrizione!C14:C16;db!A2:A11);));INDICE(db!$C$2:$C$11*CONTA.SE(descrizione!C14:C16;db!A2:A11););0))

sicuramente ottimizzabile

in L1:
=CERCA.VERT(K1;db!$A$2:$C$11;3;FALSO)
Ultima modifica di ninai su 22/10/14 17:59, modificato 2 volte in totale.
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: Excel - ricerca confronto e restituzione valori

Postdi ninai » 22/10/14 17:57

...
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: Excel - ricerca confronto e restituzione valori

Postdi Fpas » 22/10/14 18:42

ninai ha scritto:fra il tempo che hai impiegato a mettere le immagini e quello che ho impiegato io a ricreare il file con i tre fogli, non facevi prima e meglio ad allegare il file???


:D sicuramente si! almeno la copia che avevo creato, non potendo postare il file originale (contiene dati sensibili).

comunque grazie mille.
funziona alla perfezione.
complimenti
Francesco

Win7 + Office 2007 Ita
Fpas
Newbie
 
Post: 7
Iscritto il: 17/10/14 12:00


Torna a Applicazioni Office Windows


Topic correlati a "Excel - ricerca confronto e restituzione valori":


Chi c’è in linea

Visitano il forum: alfrimpa, enrico43 e 3 ospiti