Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Adattamento Pivot o creazione nuova procedura

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Adattamento Pivot o creazione nuova procedura

Postdi MatteoPP » 09/10/14 11:16

Buongiorno a tutti.

ho un problema che davvero non so come risolvere e vi chiedo aiuto.
Vi spiego : hp due colonne A e B in cui in A ho una serie di numeri ed in B una serie di nomi. capita spesso di averi per gli stessi numeri due nomi. quello di cui avrei bisogno io è:

partendo da una situazione in cui ho due tabelle cosi composte
numeri nome
100 a
100 b
102 a
102 b
102 c
112 f
112 g
io ho bisogno di raccolgiere per quanto riguarda i numeri ma facendo una pivot l impostazione mi viene:
100
a
b
102
a
b
c
112
f
g
io avrei bisogno di un impsotazione
100 a b
(spazio)
102 a b c
112 g f

vi chiedo se per caso sapete come si possa fare questa divisione con VBA.
Grazie in anticipo
MatteoPP
Utente Junior
 
Post: 10
Iscritto il: 07/10/14 09:29

Sponsor
 

Re: Adattamento Pivot o creazione nuova procedura

Postdi MatteoPP » 09/10/14 11:40

io sto lavorando su questa il rpoblema sorge quando sono piu di due voci e devo andare sulla colonna C a copiare
avete idee oltre a quella di impostare un altra macro?

Sub prova1()


For i = 1 To 6200
If Cells(i, 1) = Cells(i + 1, 1) Then
Cells(i + 1, 2).Select
Selection.Cut
Cells(i, 3).Select
ActiveSheet.Paste
Cells(i + 1, 1).Delete
Cells(i + 1, 2).Delete
End If
Next i

End Sub
MatteoPP
Utente Junior
 
Post: 10
Iscritto il: 07/10/14 09:29

Re: Adattamento Pivot o creazione nuova procedura

Postdi Anthony47 » 15/10/14 22:33

Volendo lo puoi fare con formule:
-usando il "filtro avanzato" crei l' elenco univoco dei codici numerici; io li ho messi in colonna E, quindi da E2 verso il basso.
-in F2 ho usato la formula
Codice: Seleziona tutto
 =SE(RIF.COLONNA(A1)<=CONTA.SE($A:$A;$E2);INDICE($B:$B;PICCOLO(SE($A$1:$A$10=$E2;RIF.RIGA($A$1:$A$10);"");RIF.COLONNA(A1)));"")
Da confermare con Contr-Maiusc-Enter, non il solo Enter.
Copia quindi F2 verso destra per un numero di colonne sufficiente a coprire il numero max di nominativi che ti aspetti; poi copia l' intera righe di formule accanto ai rimanenti codici univoci.

Ciao, fai sapere se puo' andare.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13894
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Adattamento Pivot o creazione nuova procedura":


Chi c’è in linea

Visitano il forum: Nessuno e 26 ospiti