Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

EXCEL MEDIA VALORI FLUTTUANTI IN BASE AL MESE DI INIZIO

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

EXCEL MEDIA VALORI FLUTTUANTI IN BASE AL MESE DI INIZIO

Postdi savyback » 24/09/14 10:27

Ciao a tutti,
sto diventando matto per trovare una soluzione che forse è dietro l'angolo.
Ho un intervallo di valori in base ai mesi dell'anno (mesi su riga), nei valori di colonna poniamo i "clienti", assumendo che il cliente 1 potrà iniziare il servizio a gennaio, calcolo la media di fatturato con la classica funzione "media.se", ma se il cliente inizia a fatturare a febbraio o marzo o aprile, la media deve escludere i mesi più a sinistra in cui il cliente non era ancora attivo, inoltre la media dovrà contare i mesi di utilizzo del servizio vuoti/pieni, quindi cliente 2 parte da marzo ma a giugno non trova valore, oggi che è settembre restituirà una media diviso i mesi di effettivo utilizzo (7 da marzo a settembre)

gen feb mar apr mag giu lug ago set ott nov dic Media
cliente 1 20 50 80 10 15
cliente 2 30 28 65 15
cliente 3 30 20 55 58


E' possibile a vostro avviso ??
Vi ringrazio anticipatamente per qualsiasi supporto
Ciao
Salvatore
savyback
Newbie
 
Post: 7
Iscritto il: 24/09/14 10:16

Sponsor
 

Re: EXCEL MEDIA VALORI FLUTTUANTI IN BASE AL MESE DI INIZIO

Postdi ricky53 » 24/09/14 15:39

Ciao,
uhm, uhm.
E' preferibile avere un file di esempio che rispecchi le effettive condizioni dei tuoi dati.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: EXCEL MEDIA VALORI FLUTTUANTI IN BASE AL MESE DI INIZIO

Postdi savyback » 24/09/14 16:48

Si puo allegare un file?
Non trovo il bottone... :o
savyback
Newbie
 
Post: 7
Iscritto il: 24/09/14 10:16

Re: EXCEL MEDIA VALORI FLUTTUANTI IN BASE AL MESE DI INIZIO

Postdi alfrimpa » 24/09/14 16:57

Devi usare uno dei siti di file sharing tipo Filedropper o simili

Quando avrai inserito il tuo file ti verrà dato un link che dovrai copiare qui sul forum

Alfredo
Alfredo

Win7 + Office 2007
Avatar utente
alfrimpa
Utente Senior
 
Post: 840
Iscritto il: 30/12/13 17:01
Località: Napoli

Re: EXCEL MEDIA VALORI FLUTTUANTI IN BASE AL MESE DI INIZIO

Postdi savyback » 24/09/14 19:39

Ecco vi allego il file
http://www.filedropper.com/cartel1_3
Grazie mille
savyback
Newbie
 
Post: 7
Iscritto il: 24/09/14 10:16

Re: EXCEL MEDIA VALORI FLUTTUANTI IN BASE AL MESE DI INIZIO

Postdi ninai » 24/09/14 20:47

ciao
anche guardando il file, trovo discrepanze fra quanto chiedi ed i valori che tu riporti come "valore atteso", sei sicuro che vuoi ottenere quei risultati????
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: EXCEL MEDIA VALORI FLUTTUANTI IN BASE AL MESE DI INIZIO

Postdi savyback » 25/09/14 05:29

Ciao,
in sostanza, la media fluttua in funzione del mese di ingresso e quello attuale che muterà al prossimo mese (ingresso meseH nell'esempio che dovrà aggiungersi), all'interno di questo range che muta appunto i valori possono o non possono esserci e chiaramente in una o l'altra opzione sommando le celle e dividendo per il range mese il valore può cambiare.

=somma(meseA;meseB;meseC;meseD;meseE;meseF;meseG)/7
=somma(meseB;meseC;meseD;meseE;meseF;meseG)/6
=somma(meseC;meseD;meseE;meseF;meseG)/5

E cosi via, è un po complicato lo so, credo l'unica via d'uscita sia intervenire su qualche formula temporale sia in ingresso sia in uscita aggiungendola a quella più ampia e generale che gestisce la media, ma sto davvero facendo fatica...
Se qualcuno riesce a darmi qualche spunto in più..
Grazie mille per la collaborazione
Salvatore
savyback
Newbie
 
Post: 7
Iscritto il: 24/09/14 10:16

Re: EXCEL MEDIA VALORI FLUTTUANTI IN BASE AL MESE DI INIZIO

Postdi ninai » 25/09/14 07:42

ciao
sono di fretta e non l'ho potuta testare bene, prova:
=SOMMA(D3:O3)/(MESE(OGGI())-CONFRONTA(1;D3:O3^0;0)+1)
matriciale da inviare con CTRL+MAIUSCOLO+INVIO
prevede che non ci siano registrati valori futuri, nel senso che, se siamo a settembre , non vi siano registrati valori in ott, nov, o dic.
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: EXCEL MEDIA VALORI FLUTTUANTI IN BASE AL MESE DI INIZIO

Postdi ninai » 25/09/14 08:41

oppure, senza invio matriciale:
=SOMMA(D3:O3)/(MESE(OGGI())-CONFRONTA(1;INDICE(1/(D3:O3<>0););0)+1)
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: EXCEL MEDIA VALORI FLUTTUANTI IN BASE AL MESE DI INIZIO

Postdi savyback » 25/09/14 09:58

Buongiorno,
grazie intanto per il cortese supporto. Allego il file con aggiunte le formule, fornisce un dato vicino a quello atteso ma non preciso..
Che ne pensi?
La formula appare utile, possibile una piccola variazione a tuo avviso?
Grazie ancora

File raggiungibile:
www.sharinglook.com/files/Cartel1.xlsx
savyback
Newbie
 
Post: 7
Iscritto il: 24/09/14 10:16

Re: EXCEL MEDIA VALORI FLUTTUANTI IN BASE AL MESE DI INIZIO

Postdi CANAPONE » 25/09/14 10:14

Ciao,

saluto subito Ninai

Basta cambiare un segmento della formula. Invece di cercare la posizione del MESE corrispondente ad oggi, cerco la posizione dell'ultimo casella riempita con il CERCA(2;


Codice: Seleziona tutto
=SOMMA(D3:O3)/(CERCA(2;1/(D3:O3<>0);RIF.RIGA($A$1:$A$12))-CONFRONTA(1;INDICE(1/(D3:O3<>0););0)+1)



Spero sia d'aiuto

EDIT: attenzione ai riferimenti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: EXCEL MEDIA VALORI FLUTTUANTI IN BASE AL MESE DI INIZIO

Postdi savyback » 25/09/14 10:45

Ciao a tutti,
la formula funziona, solo che inserendo un futuro valore nei mesi successivi perde la media attesa.
Ho fatto una simulazione aggiundendone due, però ho notato che variando nella formula il valore (in fondo alla formula) "1" portandolo a "4" il valore appare corretto, solo che costringe ad un intervento manuale perdendo efficacia

=SOMMA(D5:O5)/(CERCA(2;1/($D$3:$O$3<>0);RIF.RIGA($A$1:$A$12))-CONFRONTA(1;INDICE(1/(D5:O5<>0););0)+1)

www.sharinglook.com/files/Cartel1.xlsx

Grazie mille comunque per lo sforzo..se riuscite vi devo un drink!
savyback
Newbie
 
Post: 7
Iscritto il: 24/09/14 10:16

Re: EXCEL MEDIA VALORI FLUTTUANTI IN BASE AL MESE DI INIZIO

Postdi CANAPONE » 25/09/14 10:54

Ciao,

se stai usando in R3

=SOMMA(D5:O5)/(CERCA(2;1/($D$3:$O$3<>0);RIF.RIGA($A$1:$A$12))-CONFRONTA(1;INDICE(1/(D5:O5<>0););0)+1)

occhio ai riferimenti

=SOMMA(D3:O3)/(CERCA(2;1/(D3:O3<>0);RIF.RIGA($A$1:$A$12))-CONFRONTA(1;INDICE(1/(D3:O3<>0););0)+1)

Dovrebbe essere questo il problema
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: [SOLVED] XCEL MEDIA VALORI FLUTTUANTI IN BASE AL MESE DI

Postdi savyback » 25/09/14 11:45

Ragazzi,
non so davvero come ringraziarvi, siete stati davvero gentili.
La formula risponde perfettamente alla mia esigenza.

Grazie ancora
Se passate da Milano, fatemi un fischio, vi devo una bevuta!!!

;)
Salvatore
savyback
Newbie
 
Post: 7
Iscritto il: 24/09/14 10:16

Re: EXCEL MEDIA VALORI FLUTTUANTI IN BASE AL MESE DI INIZIO

Postdi CANAPONE » 25/09/14 12:06

Ciao,

grazie: basta il riscontro.

Ne approfitto per risalutare Ninai.

Ciao
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: EXCEL MEDIA VALORI FLUTTUANTI IN BASE AL MESE DI INIZIO

Postdi ninai » 25/09/14 12:34

Ciao
ricambio i saluti
non ho seguito più, ma con Canapone sei in una "botte di ferro"

Ho ancora qualche dubbio sul fatto di conteggiare fino all'ultimo mese con valori, metti caso che siamo a settembre e luglio ed agosto sono senza valori, cosa succede??? tu sai l'uso specifico che ne fai ma forse potrebbe essere valido considerare come fine conteggio il mese attuale meno uno. Es. se siamo a settembre, fino ad agosto; se siamo a dicembre, fino a novembre ecc.). Vedi tu
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina


Torna a Applicazioni Office Windows


Topic correlati a "EXCEL MEDIA VALORI FLUTTUANTI IN BASE AL MESE DI INIZIO":


Chi c’è in linea

Visitano il forum: Nessuno e 12 ospiti