Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Maggiore piu' grande fra i possibili cerca.vert

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Maggiore piu' grande fra i possibili cerca.vert

Postdi ing.manca » 25/05/14 09:52

Premesso che non non so programmare e che uso excel a livello di dilettante o poco più vi prospetto
problema banale che non riesco a risolvere...
ho una colonna di codici ed altre di numeri esempio:
A B C D
X 4 1 6
X 1 4 7
Y 5 3 8
X 2 5 9
Y 1 6 7
Y 6 7 1
X 1 4 7
Y 4 5 6

Vorrei trovare senza dover ricorre al VBA una formula che mi consenta di trovare nella colonna D il massimo valore che assume la lettere per esempio y.
Se uso cerca.vert
per esempio =CERCA.VERT("Y";A1:D8;4)
mi trova dei valori apparentemente casuali.
Io invece vorrei trovare il maggiore...
Qualcuno può aiutarmi, magari anche con l'utilizzo di altre formule?
Grazie ciao
ing.manca
Newbie
 
Post: 2
Iscritto il: 25/05/14 09:43

Sponsor
 

Re: Maggiore piu' grande fra i possibili cerca.vert

Postdi CANAPONE » 25/05/14 11:24

Ciao,

prova
Codice: Seleziona tutto
=MAX(INDICE((A2:A100="Y")*D2:D100;))


Non puoi adattare la stessa formula a MIN.

Nel caso servisse
Codice: Seleziona tutto
=MIN(SE(A2:A100="Y";D2:D100))

Formula matrice da confermare con control+maiusc+invio.

Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: Maggiore piu' grande fra i possibili cerca.vert

Postdi ing.manca » 25/05/14 15:50

Grazie Canapone!
ing.manca
Newbie
 
Post: 2
Iscritto il: 25/05/14 09:43


Torna a Applicazioni Office Windows


Topic correlati a "Maggiore piu' grande fra i possibili cerca.vert":


Chi c’è in linea

Visitano il forum: Anthony47 e 5 ospiti