Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

excel e visual basic. formule automatiche

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

excel e visual basic. formule automatiche

Postdi max9 » 21/05/14 13:26

Salve a tutti. Vorrei sapere se in excel tramite vba è possibile fare in modo che inserendo una variavile in una cella(una percentuale), cenga calcolata la moltiplicazione tra il valore immesso e il valore della stessa riga nella prima colonna. In modo da non dover digitare ogni volta la formula o creare troppe colonne.
max9
Newbie
 
Post: 1
Iscritto il: 21/05/14 13:15

Sponsor
 

Re: excel e visual basic. formule automatiche

Postdi Dylan666 » 27/05/14 23:30

Sposto la discussione nella sezione giusta ;)
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

Re: excel e visual basic. formule automatiche

Postdi ricky53 » 28/05/14 00:10

Ciao Max,
prima di tutto benvenuto nel nostro forum.

Veniamo al tuo quesito:
non mi è chiaro perchè tu voglia utilizzare il VBA quando con una semplice formula avresti il risultato.

Ipotizziamo che:
in B2 tu scriva la percentuale, es. 5%
in A2 tu hai il valore "1000"
in C2 con la seguente formula
Codice: Seleziona tutto
=SE(A2<>""; A2*B2; 0)

otterrai "50"
La formula la copi in basso quel quante celle ti occorrono.

E' questo quello che ti occorre?
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia


Torna a Applicazioni Office Windows


Topic correlati a "excel e visual basic. formule automatiche":


Chi c’è in linea

Visitano il forum: patel, Zer0Kelvin e 2 ospiti