Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

media

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

media

Postdi cd7019 » 05/05/14 21:32

Ciao,
desidero eseguire la media delle celle contenenti dei numeri, però il mio caso prende in considerazione le celle vuote pari a 0 e quindi il valore ottenute è diverso da quello sperato.
Come posso non considerare le celle vuote per il calcolo della media?

http://rapidshare.com/share/787F6D8CA21ABA5C0B659213E7922078

Grazie
EXCEL 2003
cd7019
Utente Senior
 
Post: 232
Iscritto il: 26/06/12 21:38

Sponsor
 

Re: media

Postdi ninai » 05/05/14 21:57

ciao
se in ogni riga vi sono 3 numeri oppure nessun numero, puoi usare:
=SOMMA(A1:C5)/CONTA.NUMERI(A1:A5)
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: media

Postdi ninai » 05/05/14 22:13

se invece ci possono essere anche 1 o 2 numeri per riga, allora, potresti usare:
=SOMMA(A1:C5)/MATR.SOMMA.PRODOTTO(--(((A1:A5)+(B1:B5)+(C1:C5))>0))
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: media

Postdi scossa » 05/05/14 22:14

Forse:
Codice: Seleziona tutto
=MEDIA(A1:A5)+MEDIA(B1:B5)+MEDIA(C1:C5)
Bye!
scossa

Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)
Avatar utente
scossa
Utente Senior
 
Post: 424
Iscritto il: 01/04/12 16:40
Località: Provincia di Verona

Re: media

Postdi cd7019 » 06/05/14 17:30

grazie
EXCEL 2003
cd7019
Utente Senior
 
Post: 232
Iscritto il: 26/06/12 21:38

Re: media

Postdi scossa » 06/05/14 18:58

cd7019 ha scritto:grazie


Scusa, ma cosa significa "grazie"?
Nelle nostre risposte abbiamo avanzato dei dubbi e delle richieste di chiarimenti, abbiamo impiegato parte del nostro tempo per aiutarti, spero non penserai di chiudere il thread con un semplice "grazie", vero? :(
Bye!
scossa

Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)
Avatar utente
scossa
Utente Senior
 
Post: 424
Iscritto il: 01/04/12 16:40
Località: Provincia di Verona

Re: media

Postdi cd7019 » 06/05/14 23:52

Posso avere delle celle vuote e quindi la formula di ninai è perfetta.
Codice: Seleziona tutto
=SOMMA(A1:C5)/MATR.SOMMA.PRODOTTO(--(((A1:A5)+(B1:B5)+(C1:C5))>0))


Grazie
EXCEL 2003
cd7019
Utente Senior
 
Post: 232
Iscritto il: 26/06/12 21:38

Re: media

Postdi scossa » 07/05/14 07:21

cd7019 ha scritto:Posso avere delle celle vuote e quindi la formula di ninai è perfetta.
Codice: Seleziona tutto
=SOMMA(A1:C5)/MATR.SOMMA.PRODOTTO(--(((A1:A5)+(B1:B5)+(C1:C5))>0))

Grazie


Ottimo, grazie per il riscontro.
Bye!
scossa

Se tu hai una mela, e io ho una mela, e ce le scambiamo, allora tu ed io abbiamo sempre una mela per uno. Ma se tu hai un'idea, ed io ho un'idea, e ce le scambiamo, allora abbiamo entrambi due idee. (George Bernard Shaw)
Avatar utente
scossa
Utente Senior
 
Post: 424
Iscritto il: 01/04/12 16:40
Località: Provincia di Verona


Torna a Applicazioni Office Windows


Topic correlati a "media":


Chi c’è in linea

Visitano il forum: Nessuno e 11 ospiti