Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

contare numeri uguali

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

contare numeri uguali

Postdi giorgioa » 09/03/14 12:33

Salve a tutti e buona domenica,

vorrei un aiuto, su due righe dovrei contare se ci sono numeri uguali
la prima riga inizia e finisce da C5:L5
la seconda riga inizia e finisce da C6:L6
il risultato in formula in cella O5
premetto che sulla stessa riga non ci saranno numeri uguali
nell'esenpio riportato nel file immagine i numeri sono spaziati dal trattino inferiore "_"(non mi ricordo come si chiama)
e per facilitare il calcolo totale i numeri uguali fra la prima riga e la seconda sono:
44-52-63-72; quello che mi interesserebbe è il totale dei numeri trovati che in questo caso è 4.
Grazie a chi mi potrà aiutare.

Immagine
caricare immagini
giorgioa
Utente Senior
 
Post: 544
Iscritto il: 16/04/12 15:00

Sponsor
 

Re: contare numeri uguali

Postdi ninai » 09/03/14 17:55

ciao
ti propongo una soluzione con righe di appoggio:
in C8: =SINISTRA(C5;TROVA("_";C5)-1)
C9: =DESTRA(C5;LUNGHEZZA(C5)-TROVA("_";C5))
C10: =SINISTRA(C6;TROVA("_";C6)-1)
C11: =DESTRA(C6;LUNGHEZZA(C6)-TROVA("_";C6))
e le trascini a destra fino a L
in O5:
=MATR.SOMMA.PRODOTTO(CONTA.SE($C$8:$L$9;C10:L11)*1)
ovviamente le righe di appoggio li puoi mettere dove vuoi tu e nascondere
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: contare numeri uguali

Postdi giorgioa » 09/03/14 22:10

Salve ninai,
grazie dell'interessamento,
il tutto funziona perfettamente ho dovuto sistemare
le formule non sotto ma a fianco, questo perchè non lo
sapevi, quindi anche la matrice funziona perfettamente
ora per un fatto estetico mi dovresti eliminare i castelletti
o meglio #Valori perchè le formule confronta la prima riga
quindi con valori assoluti, con le righe di sotto essendo
un sistema però quando le formule trovano le caselle vuote
danno appunto #Valore.
Ti ho allegato un altro file immagine per renderti chiarezza
in quello che ti chiedo.

Immagine
host immagini


Saluti
giorgioa
Utente Senior
 
Post: 544
Iscritto il: 16/04/12 15:00

Re: contare numeri uguali

Postdi Anthony47 » 10/03/14 00:55

Quale versione Excel usi?
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: contare numeri uguali

Postdi ninai » 10/03/14 06:17

Ciao
La domanda di Anthony (un saluto con stima), probabilmente si riferisce al possibile uso di SE.ERRORE().
Dovresti racchiudere le formule di estrazione all'interno di questa funzione.
es. =SE.ERRORE(SINISTRA(C5;TROVA("_";C5)-1);"")
=SE.ERRORE(DESTRA(C5;LUNGHEZZA(C5)-TROVA("_";C5));"")
ecc.

La formula finale diventa:
=MATR.SOMMA.PRODOTTO((C5:L6<>"")*CONTA.SE($C$8:$L$9;C10:L11)*1)

per i riferimenti esatti ed il test , provvedi tu (visto che alleghi immagini invece che file excel)
w8 + Office 2010 Ita
ninai
Utente Senior
 
Post: 271
Iscritto il: 12/06/13 05:23
Località: prov. Messina

Re: contare numeri uguali [PROBLEMA RISOLTO]

Postdi giorgioa » 10/03/14 18:27

Salve Anthony

(contraccambio cordialmente i saluti), posso dirlo?
Più soddisfatto di così, va bene devo ancora migliorare.
Non ho postato il file solo perchè pieno zeppo di altre
cose e per me mettere mi è facile poi se devo separare
diventa un problema .
Le formule che mi avete consigliato fanno ciò che desidero.
Quindi aggiungo [PROBLEMA RISOLTO]
Alla prossima, anzi alla prossima vedrò di essere più chiaro.

Saluti e ringraziamenti
giorgioa
Utente Senior
 
Post: 544
Iscritto il: 16/04/12 15:00


Torna a Applicazioni Office Windows


Topic correlati a "contare numeri uguali":


Chi c’è in linea

Visitano il forum: Nessuno e 8 ospiti