Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel Copia valori da colonna a riga con controllo

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel Copia valori da colonna a riga con controllo

Postdi superzuc » 09/12/13 11:10

Ciao a tutti e grazie per l'aiuto...
utilizzo la suite office da molto ma non ho grande preparazione sul VBA ...qualcuno mi può aiutare ??
Ho una tabella come questa:

POD Fascia consumo reale f0 consumo reale f1 consumo reale f2 consumo reale f3 Quantità
IT001E04188090 F1 29
IT001E04188090 F2 18
IT001E04188090 F3 27
IT001E04189596 F1 3564
IT001E04189596 F2 1886
IT001E04189596 F3 2291
IT001E04217365 F0 934

Per ogni POD uguale (per es i primi 3) devo copiare il valore di QUANTITA' controllando FASCIA nelle giuste righe (es. se "F1" copio 29 sotto "consumo reale F1" etc.) ma eliminando poi le righe POD (motivo per cui non riesco a farlo con le normali formule) cioè alla fine mi occorre 1 SOLA RIGA per ogni POD. Naturalmente il ciclo di controllo va fatto per tutte le righe del foglio (che cmq è 1 solo).
cioè così:

POD Fascia consumo reale f0 consumo reale f1 consumo reale f2 consumo reale f3 Quantità
IT001E04188090 F1 29 18 27

alla fine cancellerò la colonna FASCIA e la colonna QUANTITA'

Grazie...
Zuc
superzuc
Newbie
 
Post: 1
Iscritto il: 09/12/13 10:49

Sponsor
 

Re: Excel Copia valori da colonna a riga con controllo

Postdi Dylan666 » 17/12/13 14:34

Potresti impaginare bene le colonne con l'intestazione con i Tab o mettere uno screenshot?
http://postimage.org/
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

Re: Excel Copia valori da colonna a riga con controllo

Postdi wallace&gromit » 17/12/13 15:05

assumendo che i tuoi POD siano nelle celle da A2 a A1000, gli Fx in colonna B e i valori in colonna C; con la lista dei POD in colonna H puoi usare una formula matriciale:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(SE($A$2:$A$1000=$H2;1;0);SE($B$2:$B$1000="F0";1;0);$C$2:$C$1000)
da confermare con Ctrl+Maiusc+Enter
e da modificare con "F1", "F2" e "F3" nelle colonne successive
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1421
Iscritto il: 16/01/12 14:21


Torna a Applicazioni Office Windows


Topic correlati a "Excel Copia valori da colonna a riga con controllo":


Chi c’è in linea

Visitano il forum: Nessuno e 18 ospiti