Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

formula buoni pasto

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

formula buoni pasto

Postdi losito84 » 01/12/13 15:22

Ciao
E' possibile creare con Excel una formula che mi permetta di calcolare il buono pasto in base alle ore lavorate dal dipendente:
- Ho diritto al ticket a partire da una presenza minima di 4 HH (Questo è il caso che mi serve), quindi se in una giornata faccio minimo 4 HH ne ho diritto. Il tutto si basa dalle timbrature del dipendente
Occorre usare una macro (che non so come si usa) oppure è necessaria una semplice formula di Excel???? :D
Grazie Mille
Marco
losito84
Utente Junior
 
Post: 30
Iscritto il: 29/11/13 19:50

Sponsor
 

Re: formula buoni pasto

Postdi CANAPONE » 01/12/13 16:07

Ciao,

basta scrivere bene le ore.

Una formula è sufficiente, in b1 ora uscita, in a1 ora entrata

=SE(B1-A1>=1/6;1;0)

oppure

=SE(B1-A1>=1/6;"buono pasto";"")

1/6=4/24 le 4 ore limite per aver il buono pasto.

Spero sia d'aiuto
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: formula buoni pasto

Postdi losito84 » 01/12/13 16:15

Ciao Canapone
Grazie per la tua risposta
Visto che non conosco Excel, puoi spiegarmi questa formula =SE(B1-A1>=1/6;1;0)??? Sono davvero asino con Excel
Grazie mille
Marco
losito84
Utente Junior
 
Post: 30
Iscritto il: 29/11/13 19:50

Re: formula buoni pasto

Postdi Anthony47 » 02/12/13 10:57

Per comprendere la formula devi considerare che in Excel un orario e' rappresentato da un numero compreso tra 0 (ore 0:00) e 1 (ore 24:00); quindi ogni ora e' pari a 1/24.
Per dettagli potresti guardare l' help on line di excel alla voce "Informazioni sulle date e i sistemi di data".

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: formula buoni pasto

Postdi losito84 » 08/12/13 19:10

Ciao Canapone - Anthony47
Vi ringrazio tantissimo per il vostro aiuto.
Vorrei sottoporvi un nuovo quesito riguardante sempre i buoni pasto:

Dove lavoro il tk viene calcolato sul teorico (GG meno sabati/dome/fest) di 2 mesi successivi - le assenze del mese;
Quindi se parlo di novembre, prendo in considerazione i GG di Gennaio meno le assenze di novembre.

Con una formula di Excel, posso calcolarli?
Grazie Infinite!!!!!!!
losito84
Utente Junior
 
Post: 30
Iscritto il: 29/11/13 19:50

Re: formula buoni pasto

Postdi Anthony47 » 10/12/13 02:22

Puoi combinare le funzioni FINE.MESE e GIORNI.LAVORATIVI.TOT.
Ad esempio, se in A2 hai una data di Novembre 2013, con questa formula otterrai i giorni Lu-Ven presenti nel periodo 1 dic 2013 - 31 gen 2014:
Codice: Seleziona tutto
=GIORNI.LAVORATIVI.TOT(FINE.MESE(A2;0)+1;FINE.MESE(A2;2))
GIORNI.LAVORATIVI.TOT consente anche di non conteggiare le giornate festive, che elencherai in un intervallo da inserire poi in formula; come da informazioni contenute nell' help on line di excel, a cui ti rimando per la descrizione delle funzioni.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "formula buoni pasto":


Chi c’è in linea

Visitano il forum: Nessuno e 17 ospiti