Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

(excel) Trasformare un numero

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

(excel) Trasformare un numero

Postdi risso79 » 03/11/13 10:48

Salve a tutti :) , premetto come prima cosa che con excel sono un disatro :undecided: , per questo ho bisogno di voi.
Allora io ho una colonna con una serie di lettere e numeri derivanti da un codice a barre:
es:
1 it029568974
2 it028759821
3 25096874
4 25068974
5 25068974
6 hu345675443

come potete vedere ci sono alcune celle che all'inizio hanno lettere, ed altre no. Le celle con solo numeri dovrei modificarle eliminando il 250 (che è un numero fisso) e mettendo al suo posto FR.
es.
1 it029568974
2 it028759821
3 fr96874
4 fr68974
5 fi68974
6 hu345675443
SPERO DI ESSERMI SPIEGATO ............ :roll:
risso79
Newbie
 
Post: 4
Iscritto il: 03/11/13 10:25

Sponsor
 

Re: (excel) Trasformare un numero

Postdi CANAPONE » 03/11/13 11:49

Ciao,

in attesa di migliori soluzioni:


Codice: Seleziona tutto
=SE(SINISTRA(A2;3)="250";"FR"&STRINGA.ESTRAI(A2;4;LUGHEZZA(A2));A2)


Saluti
---------------
Excel 2004 su Mac
Excel 2010 su Windows 8
CANAPONE
Utente Senior
 
Post: 425
Iscritto il: 22/11/10 15:43
Località: Firenze

Re: (excel) Trasformare un numero

Postdi risso79 » 21/11/13 19:15

non funziona!!!!!! azzzz
risso79
Newbie
 
Post: 4
Iscritto il: 03/11/13 10:25

Re: (excel) Trasformare un numero

Postdi mezzodestro » 21/11/13 20:22

=SE(SINISTRA(RifCell;3)="250";"fr"&STRINGA.ESTRAI(RifCell;4;LUNGHEZZA(RifCell)-3);RifCell)

mancava il "-3"
mezzodestro
Xp + Office 2003 Ita
mezzodestro
Utente Junior
 
Post: 24
Iscritto il: 16/11/13 18:36

Re: (excel) Trasformare un numero

Postdi Anthony47 » 22/11/13 00:58

Ciao risso79, benvenuto nel forum.
Nella formula di canapone mancava una "N": errato LUGHEZZA, corretto LUNGHEZZA; quindi
Codice: Seleziona tutto
=SE(SINISTRA(A2;3)="250";"FR"&STRINGA.ESTRAI(A2;4;LUNGHEZZA(A2));A2)

(ovviamente va bene anche la fomula di mezzodestro, che la N non l' ha dimenticata!)

Ciao a tutti.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: (excel) Trasformare un numero

Postdi risso79 » 24/11/13 10:46

YEEESSSSSSSSSS...........FUNZIONA!!!!!! :lol: :lol: :lol: :lol:
GRAZIE MILLEEEEEEEEEEEEEEEE A TUTTTTTTIIIIII
ma che ci sono VI SFRUTTO :diavolo: :diavolo: :diavolo: ,se diciamo il "250" fosse tutto a destra basterebbe semplicemente cambiare sinistra con destra?
risso79
Newbie
 
Post: 4
Iscritto il: 03/11/13 10:25

Re: (excel) Trasformare un numero

Postdi risso79 » 24/11/13 10:48

comunque della N NON ME NE ERO PROPRIO ACCORTO!!!!!!
risso79
Newbie
 
Post: 4
Iscritto il: 03/11/13 10:25

Re: (excel) Trasformare un numero

Postdi wallace&gromit » 24/11/13 11:51

risso79 ha scritto:basterebbe semplicemente cambiare sinistra con destra?


eh no! in Excel non è mica così facile come in politica :lol: :lol: :lol:

la seconda parte: stringa estrai... non funzionerebbe così,
in questo caso dovresti togliere dalla lunghezza del testo 3 valori.
Provaci, non è difficile e se trovi la soluzione da te probabilmente la capisci e te ne ricordi meglio che a buttartela lì già fatta.
stato 2014: Office2003/2013 su win7
Avatar utente
wallace&gromit
Utente Senior
 
Post: 1419
Iscritto il: 16/01/12 14:21


Torna a Applicazioni Office Windows


Topic correlati a "(excel) Trasformare un numero":


Chi c’è in linea

Visitano il forum: Nessuno e 10 ospiti