Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Problema Avvio Windows & Virus

Risolvi qui i tuoi problemi legati a Windows '95, '98, ME, NT, 2000, XP, 2003, Vista...

Moderatori: -> EleKtrA <-, antoo69

Problema Avvio Windows & Virus

Postdi Jack123 » 25/08/09 22:23

Salve a tutti.
Stamattina ho acceso il pc e il mio avast ha rilevato parecchi virus pericolosi, ho provato a fare una scansione con HiJackThis ma niente (apparte 1 file), ho provato con ProcessScanner niente, con Ad-Aware SE Personal niente, ho provato con Spybot Search&Destroy e mi ha trovato parecchi file pericolosi ma appena clicco su "RIPARA" si blocca.
Ok, allora ho deciso di fare una scansione in modalità provisoria, invece di premere F8 all'avvio, da msconfig ho messo /safeboot. (-.-')
Riavvio il pc e mi esce: "Avvio di Windows non riuscito" e mi escono 4 opzioni:
Modalità Provisoria
Modalità Provisoria con rete
Modalità provisoria con prompt dei comandi
Avvia Windows in modalità normale

Non funge nessuno dei 4, si riavvia sempre...
Allora ho deciso di partizionare l'HD, installare sulla nuova partizione Windows, recuperare i files che mi servono, cancellare le due partizioni e reinstallare di nuovo Windows.
Ho provato dall'installazione di Windows e mi escono:
- Mia Partizione
-Altra Partizione (8MB)

Non mi fa creare una nuova...
Allora scarico Gparted, lo masterizzo, lo faccio partire e lo stesso: non mi fa creare una nuova partizione, ma mi fa dividere quella mia dove ho windows xp.
Devo fare così?

Comunque continuo...ho rimesso il cd di windows e ho ripristinato il sistema, ma quando si riavvia, esce la modalità provisoria ma esce: "Impossibile continuare l'installazione di Windows in modalità provisoria." (Così ricordo la frase)
Allora su google trovo di dare questo comando dalla console di ripristino: Bootcfg /rebuild
Apro la console, mi esce C:\Windows\_ provo a dare il comando, ma niente!
Dice che dopo questo passaggio (?) posso usare quei comandi.


Consigli? Aiuti?
Vi ringrazio anticipatamente.
Jack123
Utente Junior
 
Post: 13
Iscritto il: 25/08/09 22:09

Sponsor
 

Re: Problema Avvio Windows & Virus

Postdi Jack123 » 26/08/09 12:26

Scusate il doppio post...
oltre quel problema nel precedente post...
Se non riesco a creare una nuova partizione, dovrei ripristinare il file boot.ini dalla console di ripristino.
Ho letto che bisogna dare il comando Bootcfg /rebuild e poi fixboot ma esce: "Impossibile completare il rilevamento di installazioni di Windows nei dischi. Il file system potrebbe essere danneggiato e potrebbe impedire il rilevamento di Bootcfg.
Allora dovrei ripristinare il file system, come faccio dalla console?
Jack123
Utente Junior
 
Post: 13
Iscritto il: 25/08/09 22:09

Re: Problema Avvio Windows & Virus

Postdi Anlan » 26/08/09 12:43

Ciao Jack,
per aiutarti sarebbe utile sapere quale versione di Windows stai usando : XP ? Vista ?
Inoltre ... il riavvio della macchina quando avveniva ? Prima che apparisse la finestra di login ? Il tuo computer è impostato con il login automatico dell'utente ? Almeno per un attimo prima del riavvio vedi una schermata blu (BSOD) oppure il pc si spegne e riparte da solo ?

Per il momento lascerei perdere la ripartizione del disco.

Se stai usando Windows XP ti consiglio di avviare il pc con il CD di Windows inserito e far partire la modalità Recupero (Recovery Console). Quando richiesto inserisci la password di amministratore (se l'avevi inserita) e premi invio.
Dal prompt di comando della recovery console come prima cosa esegui un controllo del disco con :
CHKDSK /F
Poi fai eseguire un controllo degli eventuali file di sistema danneggiati/mancanti con :
SFC /SCANNOW

Fai sapere i risultati.
Anlan
Utente Senior
 
Post: 129
Iscritto il: 20/08/08 12:02

Re: Problema Avvio Windows & Virus

Postdi Jack123 » 26/08/09 13:20

Ciao Anlan.
Ho Windows XP SP2.
Il riavvio del pc avveniva dopo che sceglievo una delle 4 opzioni.
Comunque non è comparsa mai una BSOD.
La recovery console sarebbe la console di ripristino no?
Ho provato il comando: CHKDSK /F ma dice che è un paramentro non valido e nemmeno SFC /SCANNOW. :(
Ho provato con: CHKDSK /P e dopo il controllo dice che uno o più file sono danneggiati, ma non dice quali.
Jack123
Utente Junior
 
Post: 13
Iscritto il: 25/08/09 22:09

Re: Problema Avvio Windows & Virus

Postdi Anlan » 26/08/09 13:55

Bè ... è già qualcosa: questo ci dice che ci sono file danneggiati.

Dunque ... riparti nuovamente con la modalità Console di Ripristino ed esegui:
CHKDSK /r

La procedura è lunga ... quindi dagli tempo : verrà eseguita una esaustiva scansione del disco e verrà tentato il recupero dei dati leggibili. Al termine della procedura avremo almeno "sistemato" l'HD.
Adesso si tratta di reinserire i file di sistema mancanti. Prima cosa da fare :

Recupero dell'installazione di Windows :
1. Avvia il pc con il CD di Windows inserito (premi Invio per partire da CD)
2. Al momento della scelta premi Enter "Per installare Windows" (NON scegliere la console di recupero con R)
3. Accetta il contratto di licenza. Subito dopo verranno cercate le installazioni di Windows sul disco fisso
4. Seleziona l'installazione di Windows che vuoi riparare e premi R. SE NON HAI R COME OPZIONE INTERROMPI SUBITO L'INSTALLAZIONE E POSTA NUOVAMENTE QUA.
5. L'installazione copierà i file necessari e si riavvierà automaticamente. Al riavvio NON premere enter per avviare da CD ma lascia avviare dal disco fisso.

Nota! ... se durante il processo di copia dei file ricevi dei messaggi di "file non trovato" controlla che il cd sia integro e non sporco ed eventualmente chiudi tutti i messaggi di file non trovato e continua con l'installazione.

Se dopo il recupero dell'installazione il pc si avvia (anche se con qualche errore) NON CONNETTERTI SUBITO AD INTERNET. Prima assicurati che il firewall di Windows sia attivo e poi:
1. Apri un prompt di comando ed esegui "SFC /SCANNOW"
2. Controlla lo stato di Antivirus ed eventuali altri sw di protezione che avevi installato. Se non funzionano scarica il package di installazione da un'altra macchina, portali sul pc non funzionante con una chiavetta usb o altro e poi reinstallali
3. Connettiti ad internet ed esegui SUBITO un Windows Update: applica anche la SP3 già che ci sei.

Fai sapere gli esiti.
Anlan
Utente Senior
 
Post: 129
Iscritto il: 20/08/08 12:02

Re: Problema Avvio Windows & Virus

Postdi Jack123 » 26/08/09 16:36

Ho fatto: CHKDSK /r
ora sembra tutto ok.
Prima di tutto questo l'avevo fatto anche io il ripristino del sistema per non perdere i dati, files ecc...
ma quando si riavviava siccome all'inizio avevo impostato "/SAFEBOOT" accedevo in modalità provisoria e mi diceva: impossibile continuare l'installazione in modalità provisoria.
Dopo quella scansione per recuperare l'HD che faccio?
Jack123
Utente Junior
 
Post: 13
Iscritto il: 25/08/09 22:09

Re: Problema Avvio Windows & Virus

Postdi Anlan » 27/08/09 09:43

Jack123 ha scritto:ma quando si riavviava siccome all'inizio avevo impostato "/SAFEBOOT" accedevo in modalità provisoria e mi diceva: impossibile continuare l'installazione in modalità provisoria.


Non capisco questa parte: perchè e dove hai impostato /SAFEBOOT ?
Dopo che hai fatto il ripristino del sistema l'avvio successivo NON deve essere fatto in modalità provvisoria ... altrimenti i passi successivi (come correttamente ti viene notificato) non vengono eseguiti.
Devi fare la procedura di ripristino, fare riavviare la macchina (sempre con il CD inserito ma con l'avvio da Hard-disk) e fargli completare la procedura di installazione. Se al primo riavvio ti chiede in quale modalità ripartire devi selezionare "Avvia Windows normalmente"
Anlan
Utente Senior
 
Post: 129
Iscritto il: 20/08/08 12:02

Re: Problema Avvio Windows & Virus

Postdi Jack123 » 27/08/09 10:07

Ho messo /safeboot da msconfig quando windows funzionava per entrare nella modalità provisoria, invece di premere F8 all'avvio di windows ( non l'avessi mai fatto -.-'').
E ora non posso cambiarlo, a meno che sovrascrivo il file boot.ini.

-------------------------------------------------------------------------------------------------------------------------------------------------

Apparte questo, su un forum mi hanno detto questo: "meglio la distro di linux, ne scarichi una, la lanci da boot e hai già il sistema funzionante e non installato su hdd, fai il backup e poi formatti, non vedo difficoltà...molto più semplice che cercare di riparare il file system"

Però non so come fare...non c'è una guida o non so a riguardo?
Jack123
Utente Junior
 
Post: 13
Iscritto il: 25/08/09 22:09

Re: Problema Avvio Windows & Virus

Postdi Anlan » 27/08/09 10:49

Iniziano a saltare fuori le magagne eh ???
Perchè modificare le opzioni di avvio quando c'è sempre F8 per la modalità provvisoria ? Mah.

Comunque ... quello che ti hanno detto sul forum in linea di principio è corretto ma poi, a parte il salvataggio di TUTTO quello che ti serve su un'altra unità, dovrai comunque reinstallarti windows, tutti gli aggiornamenti, tutti i programmi e ricopiarti i dati. Un lavoraccio.
Dai non arrenderti che quasi ci siamo.

Adesso rimuoviamo l'opzione /SAFEBOOT da boot.ini.

1. Riavvia il pc in modalità recovery console (console di ripristino)
2. Al prompt di comando digita : ATTRIB -R -H -S boot.ini
3. Copiati il file boot.ini su un dischetto floppy: COPY boot.ini A:
4. Portati con il dischetto su un altro computer e con notepad apri il boot.ini dal dischetto
5. Elimina l'opzione /SAFEBOOT dalla riga di avvio di Windows
6. Salva
7. Ritorna sul computer (CHE NEL FRATTEMPO NON AVRAI RIAVVIATO) e ricopiati il nuovo boot.ini : COPY A:\boot.ini C:\
8. Se ti richiede di sovrascrivere conferma
9. Riapplichiamo le impostazioni corrette a boot.ini : ATTRIB +H +S boot.ini
10. Riavvia il computer e riparti con la procedura di "RECUPERO DELL'INSTALLAZIONE DI WINDOWS" (quella che ti ho descritto sopra e che avevi fatto anche tu).
11. Fai completare l'intera procedura.

Posta poi i risultati.
Anlan
Utente Senior
 
Post: 129
Iscritto il: 20/08/08 12:02

Re: Problema Avvio Windows & Virus

Postdi Jack123 » 27/08/09 11:32

Ho provato a fare : ATTRIB -R -H -S boot.ini ma esce: Parametro non valido. Provare /? per ottenere la guida.
Ho provato anche (per prova) a fare: COPY boot.ini A: ma esce: Impossibile trovare il file specificato.


:neutral: :neutral:
Jack123
Utente Junior
 
Post: 13
Iscritto il: 25/08/09 22:09

Re: Problema Avvio Windows & Virus

Postdi Jack123 » 27/08/09 12:46

Ho risolto con ubuntu (vecchia versione).
Sono riuscito ad entrare nel mio HD, ora da USB porto tutto sul portatile, cancello tutto e reinstallo windows.
Grazie ancora per l'aiuto. ;)
Jack123
Utente Junior
 
Post: 13
Iscritto il: 25/08/09 22:09

Re: Problema Avvio Windows & Virus

Postdi Anlan » 28/08/09 09:32

Jack123 ha scritto:Ho provato a fare : ATTRIB -R -H -S boot.ini ma esce: Parametro non valido. Provare /? per ottenere la guida. Ho provato anche (per prova) a fare: COPY boot.ini A: ma esce: Impossibile trovare il file specificato.


Ciao Jack,
mi devo scusare perchè non ti ho dato una indicazione corretta. Infatti quando avvii ed entri in modalità console di ripristino ti trovi su una lettera di unità che è quella del CD, non l'hard disk.
Quindi i miei punti precedenti andavano corretti come segue:
2. ATTRIB -R -H -S C:\boot.ini
3. COPY C:\boot.ini A:
9. ATTRIB +H +S C:\boot.ini

Mi dispiace ... per questa disattenzione dovrai reinstallare tutto. Sorry.
Anlan
Utente Senior
 
Post: 129
Iscritto il: 20/08/08 12:02

Re: Problema Avvio Windows & Virus

Postdi Jack123 » 28/08/09 13:40

Non importa, grazie lo stesso.
Tanto pure se riuscivo ad entrare in windows, dovevo formattarlo lo stesso, perchè è più di 2 anni che non lo faccio, ed era incasinato.
Ciao. ;)
Jack123
Utente Junior
 
Post: 13
Iscritto il: 25/08/09 22:09


Torna a Sistemi Operativi Windows


Topic correlati a "Problema Avvio Windows & Virus":


Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti