Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Ripristino BIOS Award dopo aggiornamento errato

Se il modem non funziona, hai problemi con la scheda video o non sai che processore scegliere entra qui!!

Moderatore: Caffey

Ripristino BIOS Award dopo aggiornamento errato

Postdi Sachiel » 20/03/07 22:55

(Innanzitutto scusate per la lunghezza e la pesantezza del post, so che rischio un ban a vita, ma sono quasi del tutto disperato.)

Ciao ragazzi, mi è successo un fattaccio: dopo aver aggiornato e riavviato il bios di un mio vecchio computer ho ricevuto un bip lungo e il monitor nero (non riceve segnale video).

Motivo: devo montare sulla scheda madre (una DFI P5BV3+ con bios Award, processore AMD K6-III 350 Mhz -300 senza overclock- e 64 MB DIMM) un paio di porte USB, su socket predisposto (non su scheda di espansione PCI). Windows 98SE riconosce suddette porte (USB Host in Gestione Periferiche), ma non le periferiche ad esse collegate (ho provato con stampanti e USB flash), nemmeno avviando Ricerca nuovo hardware.

Su microsoft.com leggo:
I dispositivi USB (Universal Serial Bus) collegati a un computer con Microsoft Windows 98 Seconda Edizione potrebbe non funzionare se nel computer sono installati i seguenti componenti hardware:
- processore AMD (350 MHz o superiore)
- controller USB di VIA Technologies

citazione

Scarico e installo: patch, update vari e i VIA 4in1 alla versione 4.35 (consigliata per chipset datati).

Risultato: la situazione non cambia. Non demordo e decido di provare il tutto per tutto aggiornando il bios all'ultima versione, così frettolosamente da non accorgermi che non dovevo prima aggiornarlo a due update precedenti e non usando come base la prima versione. Riavvio e poi giù di improperi..

Ora il pc legge i floppy da boot e riceve comandi dalla tastiera, solo il monitor rimane buio seppur "vivo". Alcuni siti (esempio) consigliano di scollegare tutte le periferiche e usare una scheda video ISA temporaneamente per il ripristino. Avrei difficoltà a reperirne una per cui vorrei sapere se qualcuno ha già avuto il dispiacere di sperimentarlo per saepre se funziona. Inoltre ho creato un disco autoboot con awdflash.exe e la vecchia rom del bios avviati da file autoexec.bat. Anche aspettando mezz'ora e riavvinado la situazione non cambia.
Ho qualche speranza di riuscita? E riuscendo a risvegliarlo e riaggornando correttamente il bios potrò finalmente usare l'usb o è destino che su tale configurazione proprio non debba funzionare?
Grazie e scusate il papiro..
Avatar utente
Sachiel
Utente Senior
 
Post: 222
Iscritto il: 01/03/02 11:17

Sponsor
 

Re: Ripristino BIOS Award dopo aggiornamento errato

Postdi Sachiel » 20/03/07 23:09

Sachiel ha scritto:...da non accorgermi che non dovevo prima aggiornarlo a due update precedenti..


pardon volevo dire: ...da non accorgermi che DOVEVO prima aggiornarlo a due update precedenti..
Avatar utente
Sachiel
Utente Senior
 
Post: 222
Iscritto il: 01/03/02 11:17

Postdi Sachiel » 23/04/07 00:25

Bene ho trovato la scheda video ISA. Ho notato che essa ha un BIOS dedicato, dunque ecco spiegato perchè si renda necessario il suo uso in casi simili. Bene, sfilo la scheda video AGP, inserisco la ISA attacco il monitor e finalmente riesco a vedere le scritte su schermo. Inserisco il discho di boot che mi ero preparato con dentro la rom di default e il flasher AWDFLSH.EXE, parte tutto, arrivo al prompt, scrivo
Codice: Seleziona tutto
awdflash.exe default.bin /py/sn/sb/cp/cc/cd

ma l'operazione viene terminata e mi restituisce un messaggio di errore del tipo:
System was not new AWARD BIOS Version! Please Update ROM BIOS first.
presumo che ciò sia dovuto al fatto che vede già un bios award aggiornato (l'aggiornamento che infatti mi ha causato il crash del bios era più recente di quello che sto tentando di reinstallare ora). Che dite? Può essere dovuto da questo? Se sì, esiste qualche programma in grado di cancellare i dati nel bios e di "ri-marchiarlo" come Award impostandone una certa data e versione?
Laptop Samsung RV510 S02 | CPU Intel Pentium T4500 @ 2.30GHz | RAM 4.0 GB Dual Channel DDR3 @ 398 MHz (6-6-6-15) | MB SAMSUNG RV510, chipset Intel GL40 rev. 9 | Graphics ATI Mobility Radeon HD 545v, 512 MB | OS MS Windows 7 Home Premium 64-bit
Avatar utente
Sachiel
Utente Senior
 
Post: 222
Iscritto il: 01/03/02 11:17

Postdi quizface » 23/04/07 17:52

Secondo me devi solo entrare nel BIOS e caricare le impostazioni di defoult "Load Defoult Setting" o qualcosa del genere, poi controlla che la voce "AGP-2X Mode" sia su enabled
Se non siete sicuri di quello che scrivete, non scrivete niente, nessuno vi obbliga ed eviterete di confondere chi gia' e' confuso. Ciao..ciao

Immagine
Avatar utente
quizface
Utente Senior
 
Post: 14160
Iscritto il: 03/10/04 00:36

Postdi quizface » 23/04/07 18:12

Noto anche che ci sono tre revisioni A - B - e C hai preso quella giusta?
BV3PA0103.ZIP
BV3PB0103.ZIP
BV3PC0103.ZIP
Se non siete sicuri di quello che scrivete, non scrivete niente, nessuno vi obbliga ed eviterete di confondere chi gia' e' confuso. Ciao..ciao

Immagine
Avatar utente
quizface
Utente Senior
 
Post: 14160
Iscritto il: 03/10/04 00:36

Postdi Sachiel » 30/04/07 20:54

Si, la lettera di revisione è giusta: uso è la B.
Purtroppo ho letto tardi il file README nell'archivio dell'ultimo aggiornamento in cui veniva accennato che si sarebbe dovuto fare prima l'aggiornamento ad una versione intermedia e non partendo dalla prima (quella che possedevo io e che sto tentando di ripristinare).

P5BV3+ R.A,R.B,R.C BIOS CHANGE NOTICE
(P5BV3+ R.A FROM 02/26/1999 TO 01-03-2000)
(P5BV3+ R.B FROM 02/24/1999 TO 01/03/2000)
(P5BV3+ R.C FROM 05/03/1999 TO 01/03/2000)

1. Added AMD K6-2+ CPU ID.
2. Support large size hard disk.
3. Solve linux 6.0 problem.
4. Solve copy large size file from CD-ROM to HD.

Non ho ancora provato a premere CANC per entrare nella configurazione, ma dubito sia possibile: l'unica cosa che fa dopo l'accensione è spararmi tre lunghi bip acuti e chiedermi un floppy bootable. Cmq farò sapere, nel frattempo grazie..
Laptop Samsung RV510 S02 | CPU Intel Pentium T4500 @ 2.30GHz | RAM 4.0 GB Dual Channel DDR3 @ 398 MHz (6-6-6-15) | MB SAMSUNG RV510, chipset Intel GL40 rev. 9 | Graphics ATI Mobility Radeon HD 545v, 512 MB | OS MS Windows 7 Home Premium 64-bit
Avatar utente
Sachiel
Utente Senior
 
Post: 222
Iscritto il: 01/03/02 11:17

Postdi Sachiel » 30/04/07 23:53

Dunque, faccio il riassunto della situazione:
Computer un po' datato con scheda madre DFI P5BV3+ Revisione B, Windows 98SE non vede la chiavetta USB, dopo aver invano aggiornato windows e drivers USB, decido di aggiornare la BIOS (ferma ancora alla versione originale, datata settembre 1998).
Scarico l'ultimo aggiornamento controllando che il modello e revisione corrispondano a quelli della mia scheda madre e leggendo eventuali avvertenze. Non avendone individuate preparo il floppy di sistema, riavvio, faccio l'update salvando l'immagine della BIOS esistente.
Al riavvio spiacevole sorpresa: il BIOS è corrotto, il drive floppy funziona ancora ma il monitor non visualizza più niente. Scopro solo successivamente che prima di portarlo all'ultimo aggiornamento avrei dovuto fare l'update ad una versione intermedia (un bel avviso in rosso vicino al link del download non sarebbe stata una cattiva idea).
Leggendo su internet consigliano di resettare la CMOS tramite jumper o togliendo la batteria tampone per qualche minuto. Provo entrambi i metodi e il problema rimane. Provo a riaggiornare la bios digitando i comandi a monitor spento, il programma di aggiornamento sembra partire, ma ad un certo punto si blocca. Dato che il buio del monitor mi angoscia, reperisco da un povero martire una scheda video con slot ISA (praticamente di quelle montate sui 286 e 386..)e la collego al monitor che (miracolo!) ora funziona. Appena avviato il pc fa un bip lungo e 3 bip più corti, poi visualizza la scritta

AWARD BootBlock BIOS v.1.0
Copyright (c) 1998, Award Software, Inc.

BIOS ROM checksum error

Detecting floppy drive A media...
INSERT SYSTEM DISK AND PRESS ENTER

Alché faccio del mio meglio per riportare tutto come prima, cercando di reinstallare la versione del bios originale (salvata nel file default.bin), allora:
inserisco il disco boot e al prompt scrivo
Codice: Seleziona tutto
awdflash.exe default.bin /py/sn/sb/cc/cd/cp

ma mi appare questo messaggio

System was not new AWARD BIOS Version! Please Update ROM BIOS first.
Provo con versioni successive di awdflash (sono arrivato alla 8.22f) ma senza successo: il messaggio restituitomi è sempre lo stesso.
Provo inoltre a premere CANC al momento del boot per poter entrare nella setup del bios, ma è come se non avessi premuto nulla: stoicamente continua a visualizzare

AWARD BootBlock BIOS v.1.0
Copyright (c) 1998, Award Software, Inc.

BIOS ROM checksum error

Detecting floppy drive A media...
INSERT SYSTEM DISK AND PRESS ENTER

Prima di spendere danaro per cambiare chip, vorrei provare a riportare la bios alla versione originale. Accetto qualsiasi suggerimento... Grazie..
Laptop Samsung RV510 S02 | CPU Intel Pentium T4500 @ 2.30GHz | RAM 4.0 GB Dual Channel DDR3 @ 398 MHz (6-6-6-15) | MB SAMSUNG RV510, chipset Intel GL40 rev. 9 | Graphics ATI Mobility Radeon HD 545v, 512 MB | OS MS Windows 7 Home Premium 64-bit
Avatar utente
Sachiel
Utente Senior
 
Post: 222
Iscritto il: 01/03/02 11:17


Torna a Assistenza Hardware


Topic correlati a "Ripristino BIOS Award dopo aggiornamento errato":


Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti