Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

CD drive invisibile all'avvio

Se il modem non funziona, hai problemi con la scheda video o non sai che processore scegliere entra qui!!

Moderatore: Caffey

CD drive invisibile all'avvio

Postdi fdd » 16/04/05 23:28

Recentemente un amico ha formattato il suo PC, senza prima verificare che l'avvio da floppy si svolgesse regolarmente, cioè con tanto di supporto CD-ROM (stiamo parlando di un computer un po' vecchiotto su cui era installato Windows 98 SE). Nella fattispecie quando fa l'avvio da floppy si presentano due errori:
1. Quando carica i driver generici per il CD-ROM (mi riferisco al file oakcdrom.sys), gli da come errore "drive not found"
2. Quando carica i driver generici per controller SCSI (in particolare mi riferisco al file aspi2dos.sys), gli da come errore "installation failed"
Dopo di che terminato l'avvio, naturalmente non gli vede nè lettore CD, nè masterizzatore.
Premesso che lui ha un controller SCSI Adaptec (modello ignoto), un lettore CD SCSI della Pioneer (modello ignoto) ed un masterizzatore SCSI Yamaha modello crw4416s.
Scartate le seguenti ipotesi:
1. I drive sono morti: Durante il POST vengono regolarmente trovati (si accende la lucina tanto per intenderci)
2. Spinotti allentati: non ha mai mosso il computer (inoltre vedi punto 1)
3. Bypassare il problema facendo il boot da CD: il computer è vecchio e il BIOS non lo prevede
4. Floppy di avvio danneggiato o file corrotti: al controllo sia il floppy che il suo contenuto risultano perfetti.
Deduco quanto segue (in virtù dei forum e siti visionati sulla rete):
L'errore numero 2 (quello sull'aspi2dos.sys) risulterebbe solo in virtù dell'errore precedente. L'errore numero 1 risulterebbe invece dal fatto che i suoi drive CD (e nella fattispecie il masterizzatore, che risulterebbe come primo elemento della catena SCSI), non sono supportati dai driver generici presenti sul floppy di avvio. Sarebbe quindi necessario: a) procurarsi driver ad hoc; b) modificare il config.sys di modo che carichi quelli.
Le mie domande sono quindi:
1. Secondo voi sono sulla strada giusta o ho trascurato qualche altra possibile causa del problema?
2. Se il problema è quello ci sono metodi risolutivi alternativi? Lo domando perchè il mio amico non riesce a trovare i driver (se mai gli sono stati dati) e neanche riesco a reperirli in giro. Nel caso qualcuno saprebbe dove trovare i driver per un Yamaha crw4416s?
Grazie anticipatamente per l'aiuto che potrete darmi.
(scusate la carenza di dati più specifici (nonchè l'esagerata lunghezza del post), ma sono geograficamente lontano dal computer in questione e quindi mi devo accontentare delle informazioni che riesco a ricevere).
fdd
Utente Junior
 
Post: 31
Iscritto il: 10/04/05 01:14

Sponsor
 

Postdi GAD » 17/04/05 13:10

Sei in un circolo vizioso, se non sai il nome delle periferiche non puoi trovare i driver e senza driver non puoi installare le periferiche...acida.
Io per non complicarmi la vita col boot di quella macchina farei cosi:
1) cavo l'hd dell'amico e lo monto sul mio pc dove so che il boot da cd e' possibile
2) installo windows sul suo hd e lo configuro con già un bel po' di driver generici e in piu' ci metto anche everest home edition (che serve dopo)
3) rimonto l'hd sul computer dell'amico e faccio il boot tralasciando eventuali errori sulle unità scsi
4) apro everest e da li' ottengo il nome di tutte le periferiche
5) dato il nome dei modelli che ora sappiamo mi reco su internet ,scarico i driver giusti e li installo
6) faccio un ghost cosi' se riformatta non bisogna piu' riaffrontare tutti sti passi da capo :D
Quando l'ultimo albero sarà abbattuto,l'ultimo pesce catturato,l'ultimo fiume avvelenato,
soltanto allora gli uomini si accorgeranno chei soldi non possono essere mangiati
GAD
Moderatore
 
Post: 2184
Iscritto il: 22/09/02 14:36
Località: Nebbiosa

Postdi fdd » 17/04/05 16:12

Grazie per la risposta, e devo dire l'idea sarebbe anche buona, ciò non toglie che la distanza geografica, di cui accennavo nel mio post, la rende poco praticabile.
Fosse stato più vicino, avrei reperito anche il nome di battesimo di ogni singola periferica, a costo di svitare ogni vite di quel dannato computer. :diavolo:
fdd
Utente Junior
 
Post: 31
Iscritto il: 10/04/05 01:14

Postdi piercing » 17/04/05 17:55

non è che il bios non preveda il boot da cd... è che il cd non c'è... perchè è scsi...

la scheda scsi ha un bios?

esistono floppini di avvio con i driver scsi per le adaptech... non credo che importi il modello...
Avatar utente
piercing
Moderatore
 
Post: 7569
Iscritto il: 10/04/02 10:34
Località: Roma

Postdi fdd » 17/04/05 20:31

Non ho idea se la sua scheda SCSI abbia il bios. Purtroppo non ho modo di verificare personalmente il modello della scheda.
Ho chiesto a questo mio amico di cercare tra i floppy e cd che gli erano stati dati all'acquisto e lui ha reperito due floppy che a sua detta contenevano i driver SCSI. Mi sono fatto mandare il contenuto via email, ma uno era un normalissimo floppy di avvio (controllato in ogni suo aspetto non differiva da quello che crea il Windows 98), l'altro conteneva un file di help compresso, facente chiaramente parte di una routine di installazione (il nome era ONLINREF.HL_).
Proverò a vedere sul sito Adaptec se trovo qualcosa di utile, anche se a rigore nel normale floppy di avvio di Windows sono presenti i driver aspi*.sys che sono proprio driver Adaptec generici per il supporto di unità CD-ROM in modalità reale.
Grazie della segnalazione
fdd
Utente Junior
 
Post: 31
Iscritto il: 10/04/05 01:14


Torna a Assistenza Hardware


Topic correlati a "CD drive invisibile all'avvio":


Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti