Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

VB2010 - Impostare versione .Net minima richiesta

Problemi di HTML? Di PHP, ASP, .NET, JSP, Perl, SQL, JavaScript, Visual Basic..?
Vuoi realizzare programmi in C, C++, Java, Ruby o Smalltalk, e non sai da che parte cominciare?
Entra qui e troverai le risposte!

Moderatori: Triumph Of Steel, archimede

VB2010 - Impostare versione .Net minima richiesta

Postdi maxmula » 28/09/10 10:29

Ciao a tutti.
ho letto che in .Net si può configurare il compilatore in modo che il codice sia compatibile con una specifica versione di .Net (non necessariamente l'ultima).

Sapreste dirmi dove impostare questi parametri?
Dovrei fare in modo che il mio programma possa funzionare anche su macchine che non hanno installato .Net 4.0 (dovrebbe bastare una 2.x, in effetti) ma non saprei dove cercare...


Grazie!
MAx
Avatar utente
maxmula
Utente Senior
 
Post: 965
Iscritto il: 18/08/04 18:28
Località: N44°59'45 E09°00'34

Sponsor
 

Re: VB2010 - Impostare versione .Net minima richiesta

Postdi hydra » 28/09/10 10:35

Quando crei un nuovo progetto, nella finestra dove scegli il tipo di progetto, il percorso ecc. poi scegliere la versione del FW, in alto a destra. Lo puoi comunque impostare anche nelle proprietà del progetto (Esplora soluzioni, properties, Applicazione), ma ti conviene farlo dall'inizio quando crei il progetto, perchè se sviluppi col il FW 4.0 potrebbe essere che quando cambi ad esempio al 2.0 alcune classi o controlli non sono disponibili e devi ripassarti tutta la soluzione a mettere a posto tutto.
Avatar utente
hydra
Moderatore
 
Post: 7002
Iscritto il: 19/07/04 08:06
Località: Vallis Duplavis

Re: VB2010 - Impostare versione .Net minima richiesta

Postdi maxmula » 28/09/10 11:30

Risolto :D

Per la cronaca, in VB2010 (ed anche in VB 2008, credo) il percorso corretto per l'impostazione è:
    Solution Explorer -> My Project -> Compile -> Advanced Compile Options

Fortunantamente, i cambamenti che ho dovuto fare in tutta la soluzione (anzi, in due soluzioni) sono stati solo 4. PEr il resto, ora la mia applicazione gira tranquillamente con FW 3.5.

Ciao e grazie 1000!!!
MAx
Avatar utente
maxmula
Utente Senior
 
Post: 965
Iscritto il: 18/08/04 18:28
Località: N44°59'45 E09°00'34


Torna a Programmazione


Topic correlati a "VB2010 - Impostare versione .Net minima richiesta":


Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti