Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

apache e suexec

Problemi di HTML? Di PHP, ASP, .NET, JSP, Perl, SQL, JavaScript, Visual Basic..?
Vuoi realizzare programmi in C, C++, Java, Ruby o Smalltalk, e non sai da che parte cominciare?
Entra qui e troverai le risposte!

Moderatori: Triumph Of Steel, archimede

apache e suexec

Postdi pumetto » 22/12/05 12:54

Sto' sclerando alla grande visto che non sono ancora riuscito (per la 50 volta di seguito) a settare suexec per permettere l'esecuzione degli script cgi sulla document root di apache. Uso apache-1.3.34.
Nel file httpd.conf ho:
1 nobody come utente e nobody come group
2 document root /usr/local/apache/htdocs
e ho configurato suexec con queste impostazioni:
--enable-suexec --suexec-caller=nobody
----suexec-docroot=/usr/local/apache/htdocs
--suexec-logfile=/usr/local/apache/logs/suexec.log
--suexec-uidmin=100
--suexec-gidmin=100
--suexec-userdir=/usr/local/apache/htdocs
--suexec-safepath=/usr/local/bin:/usr/bin:/bin
Ho creato la dir cgi-bin sotto htdocs. Niente, continua a darmi il solito errore:non ho i permessi per accedere alla cartella.
Se potete aiutatemi. Grazie e Ciao
pumetto
Newbie
 
Post: 2
Iscritto il: 19/12/05 10:53

Sponsor
 

Postdi Heba » 23/12/05 17:19

ti premetto che non sono esperta di suexec, ma mi sembra a prima vista che l'errore sia su questa riga:

--enable-suexec -- suexec-caller=nobody

mi sembra che hai disabilitato suexec e utilizzando nobody su caller gli hai detto di non abilitare nessuno, forse dovresti mettere il nome dell'utente abilitato ad utilizzarlo al posto di nobody, per la prima invece non so se è da cambiare, vediamo se altri più informati di me, ti possono aiutare
In internet il saper leggere equivale al saper ascoltare nella realtà.
Chi sa ascoltare possiede le chiavi di molte porte.
Heba
Utente Senior
 
Post: 509
Iscritto il: 16/06/05 15:09
Località: Cremona


Torna a Programmazione


Topic correlati a "apache e suexec":


Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti