Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[html] problema con immagini

Problemi di HTML? Di PHP, ASP, .NET, JSP, Perl, SQL, JavaScript, Visual Basic..?
Vuoi realizzare programmi in C, C++, Java, Ruby o Smalltalk, e non sai da che parte cominciare?
Entra qui e troverai le risposte!

Moderatori: Triumph Of Steel, archimede

[html] problema con immagini

Postdi steej » 10/12/05 10:01

salve a tutti
ho inserito un immagine nel mio sito ed ho notato un comportamento strano
la pagina è: http://www.oraema.altervista.org/prova.php
l'immagine non estende il <div> ed esce fuori dal suo contenitore

come posso risolvere?

grazie in anticipo
powered by Ubuntu - Linux
steej
Utente Junior
 
Post: 21
Iscritto il: 24/12/04 11:47

Sponsor
 

Postdi Mikizo » 10/12/05 13:32

Credo proprio che dipenda da come FF interpreta i div. (infatti su IE si vede come nelle tue intenzioni, su FF no).
D'altronde non so se i div, utilizzati in questo modo, siano corretti: la separazione dei contenuti avviene a livello, appunto di contenuti, ma graficamente non credo che il browser sia obbligato ad una certa rappresentazione.
Per stabilire quale debba essere il layout dovresti usare altro codice.
Avatar utente
Mikizo
Download Admin
 
Post: 8517
Iscritto il: 05/01/02 01:00
Località: Outside

Postdi steej » 10/12/05 14:26

non avevo notato che con ie viene visualizzato correttamente

hai qualche idea da suggerirmi in proposito?
powered by Ubuntu - Linux
steej
Utente Junior
 
Post: 21
Iscritto il: 24/12/04 11:47

Postdi archimede » 12/12/05 16:09

Prova
Codice: Seleziona tutto
<div id=content>
<h2>Prova:</h2>
<p><img style="vertical-align: top;" src="prova.jpg" alt="La mia foto">
lsgjpdjgdngvgndighgdig ipdhgpvhd hgv pdijgd dpjv</p>
</div>
HTH.

Alessandro
archimede
Moderatore
 
Post: 2755
Iscritto il: 07/11/02 12:41
Località: Genova

Postdi steej » 13/12/05 13:15

perfetto, ora funziona! Grazie ;)
quindi ne deduco che è buona norma utilizzare sempre i css per definire lo "stile" di un qualsiasi oggetto, giusto?
powered by Ubuntu - Linux
steej
Utente Junior
 
Post: 21
Iscritto il: 24/12/04 11:47

Postdi archimede » 13/12/05 14:49

steej ha scritto:quindi ne deduco che è buona norma utilizzare sempre i css per definire lo "stile" di un qualsiasi oggetto, giusto?
Sì. E non solo lo stile, anche il posizionamento. Visto che ci sei, ti consiglierei anche di rivedere il doctype passando a HTML 4.01 Strict (invece di Transitional) o, ancor meglio, XHTML 1.0 Strict.

Alessandro
archimede
Moderatore
 
Post: 2755
Iscritto il: 07/11/02 12:41
Località: Genova

Postdi steej » 13/12/05 21:32

grazie per il consiglio.
Appena ho un po' di tempo cerco le differenze tra HTML 4.01 "transitional" e "strict" e poi magari anche l'XHTML

grazie ancora, ciao ;)
powered by Ubuntu - Linux
steej
Utente Junior
 
Post: 21
Iscritto il: 24/12/04 11:47

Postdi steej » 23/12/05 12:58

guardando un po' meglio ho notato che "vertical-align" non risolveva il mio problema, perchè allinea solo il primo rigo del testo
cercando un po' su internet ho trovato la soluzione: http://www.html.it/layout_css/layout_css_34.htm

ciao ;)
powered by Ubuntu - Linux
steej
Utente Junior
 
Post: 21
Iscritto il: 24/12/04 11:47

Postdi archimede » 23/12/05 13:04

steej ha scritto:"vertical-align" non risolveva il mio problema, perchè allinea solo il primo rigo del testo
E' vero, sorry.

Grazie per aver postato la soluzione corretta.

Alessandro
archimede
Moderatore
 
Post: 2755
Iscritto il: 07/11/02 12:41
Località: Genova


Torna a Programmazione


Topic correlati a "[html] problema con immagini":

Problema Windows 10
Autore: asso1998
Forum: Software Windows
Risposte: 1

Chi c’è in linea

Visitano il forum: Nessuno e 6 ospiti

cron