Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

programma fotoritocco

Problemi di HTML? Di PHP, ASP, .NET, JSP, Perl, SQL, JavaScript, Visual Basic..?
Vuoi realizzare programmi in C, C++, Java, Ruby o Smalltalk, e non sai da che parte cominciare?
Entra qui e troverai le risposte!

Moderatori: Triumph Of Steel, archimede

Postdi Mikizo » 14/04/05 21:08

Triumph Of Steel ha scritto:No Mikizo, per quanto spiegato da lui, la cartella FOTO e le pagine HTML sono tutte sullo stesso livello, dentro la cartella amontillado

all'inizio avevo capito anch'io così, ma rileggendo mi è sorto il dubbio..

e poi guarda il percorso assoluto:
pollicino ha scritto:<img src="c:documenti/cose di paolo/foto/sauniere.jpg>.


dov'è finita la cartella amontillado?? ;)
Avatar utente
Mikizo
Download Admin
 
Post: 8517
Iscritto il: 05/01/02 01:00
Località: Outside

Sponsor
 

Postdi pollicino » 16/04/05 11:53

Scusate i due giorni d’assenza, ma la batteria difettosa m’impone riposi forzati.
Tornando all’intoppo.
La disposizione giusta delle cartelle è in effetti quella intuita da Mikizo.
La ribadisco: i file htm sono in “Amontillado”; le immagini sono in foto; entrambe le cartelle sono in “Cose di Paolo”. Forse mi ero spiegato male.
Stando alla spiegazione di Dylan sul topic di Dreamweaver (grazie tante del link segnalato, Dylan, altrimenti non avrei capito il suggerimento di Mikizo), avrei dovuto effettivamente inserire i due punti prima della sbarra.
Ebbene, l’ho fatto. Il problema resta. Oltretutto (scusate se insisto su questo punto, ma credo sia importante), fino a poco tempo fa le immagini venivano visualizzate regolarmente, anche senza aver inserito i due punti, e la disposizione delle cartelle è sempre stata quella!
Ecco perché mi pare (da sprovveduto quale sono) che la pista del percorso errato non sia forse quella giusta. Magari l’inghippo si trova più a monte. E di certo per voi, da lontano, non è facile scoprire di che si tratta.

A questo punto vi riporto un messaggio speditomi da un amico di penna al quale avevo esposto lo stesso problema. Io non ci ho capito molto. Se ci date un’occhiata anche voi, magari potete darmi una mano in più:. "Tu usi blocco
note per costruire la pagina html (miiinchia, che manico) e poi, quando te
la vedi in explorer, ti cadono i link? Se è così, c'è solo un problemuccio
di sintassi da qualche parte, probabilmente un carattere bizzarro (magari un
bellissimo apice, un backslash o fringuelli simili) che hai inserito da
qualche parte e ti manda in panico l'intera pagina. In questo caso, ti
consiglio di leggere la pagina in frontpage, che dovrebbe aiutarti a
visualizzare il punto di errore. Sono molto propenso a credere che si tratti
di questo". Voi che mi consigliate? Siccome non ho più frontpage, dovrei riscaricarmelo apposta per questo...
pollicino
Utente Senior
 
Post: 109
Iscritto il: 19/02/05 20:14

Postdi Dylan666 » 16/04/05 13:17

pollicino ha scritto:La disposizione giusta delle cartelle è in effetti quella intuita da Mikizo.
La ribadisco: i file htm sono in “Amontillado”; le immagini sono in foto; entrambe le cartelle sono in “Cose di Paolo”. Forse mi ero spiegato male.


Vediamo di fare chiarezza. Lasciamo stare la prima parte del percorso (c:/documenti)

In cima c'è “Cose di Paolo”.
Dentro ci sono “Amontillado” (contenente i file HTM) e “foto” (con dentro le immagini).

Dico bene?

Comunque noto che ogni tanto sbagli a scrivere i percorsi:

pollicino ha scritto: <img src="foto/sauniere.jpg">, ora porto scritto così: <img src="c:/documenti/cose di paolo/foto/sauniere.jpg">.


Tutte le parti in rosso te le eri dimenticate. Non è che pure ora ti scervelli per un paio di virgolette non chiuse?
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

Postdi Mikizo » 16/04/05 14:48

Sono convinto al 200% che è come dice Dylan, vista la poca dimestichezza che hai con i percorsi è probabile che l'errore sia sempre diverso ma sempre dello stesso tipo.
Avatar utente
Mikizo
Download Admin
 
Post: 8517
Iscritto il: 05/01/02 01:00
Località: Outside

Postdi pollicino » 16/04/05 18:12

Beh, la geografia delle cartelle è quella.
Riguardo agli errori di ortografia dei tag... sì, è vero, qualche volta ho dimenticato una virgola. Ma sta di fatto che ho corretto i punti incriminati, controllato tutti gli altri...
vabbé, dai, adesso proverò a fare tutto ex novo. Testo in blocco note e foto da scaricare. Vediamo che succede. Batteria permettendo.
Però non mi avete detto niente su quegli errori di sintassi di cui parla il mio amico...
pollicino
Utente Senior
 
Post: 109
Iscritto il: 19/02/05 20:14

Postdi Dylan666 » 16/04/05 18:17

errore di sintassi = ti scordi le virgolette

Se le cartella stanno come ho cercato di riassumere io sopra, il percorso è e non può che essere questo, come ha già scritto Mikizo:

Codice: Seleziona tutto
<img src="../foto/sauniere.jpg" align="right" vspace=4 hspace=8>
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

Postdi Mikizo » 16/04/05 18:18

Il tuo amico dice le stesse cose che diciamo noi.
Avatar utente
Mikizo
Download Admin
 
Post: 8517
Iscritto il: 05/01/02 01:00
Località: Outside

Postdi pollicino » 17/04/05 09:41

Ho trasferito i file su un altro computer, stando bene attento ai percorsi, e finalmente tutto va bene. L'altro nel frattempo è inutilizzabile, per via della batteria. Vedremo.
Grazie ancora dell'aiuto.
pollicino
Utente Senior
 
Post: 109
Iscritto il: 19/02/05 20:14

Precedente

Torna a Programmazione


Topic correlati a "programma fotoritocco":


Chi c’è in linea

Visitano il forum: Nessuno e 6 ospiti