Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

problema con win2000, ODBC e database mdb...

Hai problemi con i file Zip, vuoi formattare l'HD, non sai come funziona FireFox? O magari ti serve proprio quel programmino di cui non ricordi il nome! Ecco il forum dove poter risolvere i tuoi problemi.

Moderatori: Dylan666, hydra, gahan

problema con win2000, ODBC e database mdb...

Postdi Ragnar » 30/09/02 18:34

salve,
da qualche settimana sto sbattendo la testa su un problema che non riesco a risolvere:
ho un sito fatto in ASP e che usa dei database MDB di Access; per testare il sito in locale ho installato IIS (uso Win 2000 pro) e messo le connessioni ai database nell'ODBC. Tutto funzionava alla perfezione fino ad un paio di giorni fa, dopodichè, inspiegabilmente, ogni volta che apro le pagine relative al database mi compare un messaggio di errore riferito alla stringa di connessione (come se non ci fossero le connessioni ODBC).
Premetto che non ho cambiato nè la configurazione di IIS, nè quella dell'ODBC; però inspiegabilmente ora non parte nulla!
Tra l'altro IIS funziona benissimo... ho fatto di tutto ... reinstallato IIS, provato con le connessioni DNS-less, attivati tutti i permessi utente ... inoltre il sito online gira correttamente ... ironia della sorte ho anche la stessa identica configurazione nel PC del lavoro e lì tutto è OK!!!

aiutatemiiiii!!! :))))
grazie!

Daniele
Ragnar
Utente Junior
 
Post: 13
Iscritto il: 16/07/02 14:54
Località: Ragusa

Sponsor
 

Postdi Frengo78 » 30/09/02 21:13

Postaci l'errore. Vb (dovrebbe) è pane per i miei denti
Knowledge is a weapon
Frengo78
Utente Senior
 
Post: 8985
Iscritto il: 16/07/02 08:41
Località: Torino

Postdi Ragnar » 01/10/02 17:31

Frengo78 ha scritto:Postaci l'errore. Vb (dovrebbe) è pane per i miei denti


Ecco l'errore:


Impossibile visualizzare la pagina
Si è verificato un problema a livello della pagina che si desidera visualizzare che ne impedisce la visualizzazione.

--------------------------------------------------------------------------------

Please try the following:

Fare clic sul pulsante Aggiorna o riprovare più tardi.

Aprire la ragnar home page e cercare i collegamenti alle informazioni desiderate.
HTTP 500.100 - Errore interno del server - errore ASP
Internet Information Services

--------------------------------------------------------------------------------

Informazioni tecniche (per il personale del supporto tecnico)

Tipo di errore:
Provider (0x80004005)
Errore non specificato.
/brain_twisting/sitoweb_v2.0/index2.asp, line 15


Tipo di browser:
Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Pagina:
GET /brain_twisting/sitoweb_v2.0/index2.asp

Ora:
martedì 1 ottobre 2002, 18.32.43


Informazioni aggiuntive:
Supporto Microsoft


la linea 5 a cui fa riferimento è la stringa di connessione ... sia se metto quella con i DNS che quella DNS-Less...

grazie!
Ragnar
Utente Junior
 
Post: 13
Iscritto il: 16/07/02 14:54
Località: Ragusa

Postdi piercing » 02/10/02 18:54

che fosse stato un 500 non avevo dubbi :D

il motivo??? boh!

la cartella del DB ha i permessi di scrittura?
la faccenda è semplice... se su un altro computer IDENTICO funziona la cosa deve funzionare anche su questo...

quindi o non è identico, o la connessione non va bene.

Cosa è successo da quando funzionava a quando non ha più funzionato? hai installato programmi, aggiunto utenti... qualcosa deve essere pur successo...

Come saprai inoltre la stringa di connessione è molto delicata... nel senso che vuole le cose in maniera molto precisa (apici, spazi e compagnia bella...)

So che già avrai fatto tutte ste verifiche, ma la stupidaggine è sempre dietro l'angolo...

Se puoi e vuoi zippami i file e mandameli per posta... (DB e pagina di connessione).

Ciao ciao...
Avatar utente
piercing
Moderatore
 
Post: 7569
Iscritto il: 10/04/02 10:34
Località: Roma

Postdi Frengo78 » 02/10/02 22:52

Brancolo nel buio pure io. Fosse stato un errore un po' piu spiegato... Ma cribbio!!!!
Knowledge is a weapon
Frengo78
Utente Senior
 
Post: 8985
Iscritto il: 16/07/02 08:41
Località: Torino

Postdi piercing » 03/10/02 01:15

FrengOT ha scritto:Ma cribbio!!!!


Ma mi consenta!!! :) (sorriso ampio e disteso)
Avatar utente
piercing
Moderatore
 
Post: 7569
Iscritto il: 10/04/02 10:34
Località: Roma

Postdi Ragnar » 03/10/02 14:00

proprio così ... le stesse pagine su un altro PC funzionano! Mah! Comunque grazie lo stesso per l'interessamento!

bye!
Ragnar
Utente Junior
 
Post: 13
Iscritto il: 16/07/02 14:54
Località: Ragusa

Postdi Ragnar » 08/10/02 18:00

8) HO RISOLTO!! YEAH!!! 8)

...era un maledetto errore di permessi! Io li impostavo e loro si toglievano!!! (forse quando cercavo di aprire il db!)
Alla fine comunque sembra che tutto sia tornato normale!

grazie per l'aiuto!

a presto,
Ragnar
Utente Junior
 
Post: 13
Iscritto il: 16/07/02 14:54
Località: Ragusa

Postdi piercing » 08/10/02 19:35

;) ... era ora! :lol: :lol:
Avatar utente
piercing
Moderatore
 
Post: 7569
Iscritto il: 10/04/02 10:34
Località: Roma


Torna a Software Windows


Topic correlati a "problema con win2000, ODBC e database mdb...":

Problema Windows 10
Autore: asso1998
Forum: Software Windows
Risposte: 1

Chi c’è in linea

Visitano il forum: Nessuno e 6 ospiti