Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

boot Loader di Windows Xp

Hai problemi con i file Zip, vuoi formattare l'HD, non sai come funziona FireFox? O magari ti serve proprio quel programmino di cui non ricordi il nome! Ecco il forum dove poter risolvere i tuoi problemi.

Moderatori: Dylan666, hydra, gahan

boot Loader di Windows Xp

Postdi Andrea87 » 04/05/02 20:58

Ho 3 partizioni sul mio hd. Una fat32 primaria con win me, una fat32 estesa con dati, e una ntfs estesa con win xp. All’avvio mi parte il boot loader di win xp e mi chiede se usare win me o win xp. Io ora vorrei cancellare la partizione primaria di win me per installare linux ma mi pongo queste domande:
1)Se cancello quella attualmente primaria, la partizione di win xp (estesa) diventerà automaticamente primaria o devo fare qualcosa.
2)Il boot loader si incazza (nel senso che non funziona più) se levo la partizione di win me?

Avevo pensato di disattivare il boot loader dal panello di controllo di Win xp, cancellare la partizione di Win me (con fdisk), fare un fdisk /mbr e poi (con un fdisk un po’ modificato che ho trovato su internet che legge anche le ntfs) rendo attiva la partizione di Win Xp. Infine installo Linux Mandrake 8.2 (appena trovato con Linux & Co. in edicola) e comincio a rompere le scatole a quelli dell’altro forum.

Sono giuste le mie intuizioni o devo fare altro?
Andrea87
Utente Senior
 
Post: 857
Iscritto il: 03/09/01 01:00
Località: Venezia

Sponsor
 

Postdi kyara » 05/05/02 20:14

La partizione estesa rimane estesa e xp non parte piu non trovando i file adatti per farlo ripartire sulla partizione primaria (winme).
Poi a che ne so io, xp non va molto d'accordo con linux (non ho provato ma qualcuno dice che xp non permetta molto volentieri la cosa), (aspetto nota contraria a discarico di quanto detto, onde poter poi essere sicura del contrario).
Personalmente installerei xp su una partizione primaria e poi nasconderei la partizione e installerei linux su un'altra partizione precedentemente lasciata vuota apposta per questo, indi a sto punto con un bootloader (dovrebbe andare bene anche lilo ma aspetto conferme da qualcuno) faccio riconoscere i due SO e amen.
kyara
Utente Senior
 
Post: 923
Iscritto il: 07/08/01 01:00
Località: web

Postdi Andrea87 » 05/05/02 21:08

kyara ha scritto:Personalmente installerei xp su una partizione primaria...

Lo devo reistallare o basta trasformare la partizione di Windows Xp da estesa a primaria (con partition magic)?
Andrea87
Utente Senior
 
Post: 857
Iscritto il: 03/09/01 01:00
Località: Venezia

Postdi zello » 06/05/02 14:06

Posso aggiungere poco sulla compatibilità XP/linux.
Quello che è certo è che forse conviene usare il boot loader di XP, e non
lilo.

Se ancora il bl di XP è simile a quello di Win2k, basta che lilo lo si installi da una qualche parte (ogni installazione linux lo chiede) che non sia la partizione attiva - per esempio, la seconda partizione estesa del master del primo canale EIDE (hda6, direi). Dopodiche, si fa da linux un bel (sto supponendo che il disco con i file di boot - C in terminologia Dos - sia montato sotto /mnt/C)

dd if=/dev/hda6 of=/mnt/C/boot.lnx count=1

e poi si aggiunge una bella riga a boot.ini (file nascosto nella directory principale del file di boot)

c:\boot.lnx="Linux your personal Unix"

[non giurerei sulla sintassi, sono lontano dal computer di casa]
Il faut être toujours ivre. Tout est là : c'est l'unique question. Pour ne pas sentir l'horrible fardeau du Temps qui brise vos épaules et vous penche vers la terre,il faut vous enivrer sans trêve...
Avatar utente
zello
Moderatore
 
Post: 2351
Iscritto il: 06/05/02 13:44

Postdi Andrea87 » 07/05/02 19:14

Se io cancellassi tutte le partizioni, installassi Linux, poi nascondessi le partizioni di linux (con fips) e poi installassi Windows che boot loader mi farebbe usare? Se fosse quello di Windows riuscirei a far partire Linux?
Andrea87
Utente Senior
 
Post: 857
Iscritto il: 03/09/01 01:00
Località: Venezia

Postdi Nemok » 10/05/02 23:29

Perchè complicarsi la vita quando si può far gestire tutto a Lilo!
Io per un periodo li ho fatti convivere e non mi ha dato nessun problema.Il modo più semplice probabilmente è installare XP e poi installare linux con Lilo,che se non siamo stati cattivi e nessuno ci ha fatto il malocchio riconosce subito la presenza di zio Bill e da la possibilità anche a lui di partire.

Riguardo il tuo ultimo post Andrea è buona norma installare Linux sempre per ultimo.

Se hai problemi specifici chiedi pure(anche se tornerò domenica sera.....)
Nel 1968 la potenza operativa di 2 C-64 hanno portato un razzo sulla luna. Oggi la potenza operativa di un Athlon 4000+ viene usata per far girare Windows XP....Qualcosa deve essere andato storto....
--Powered by Debian Sid/unstable on 2.6.10--
Nemok
Utente Senior
 
Post: 1420
Iscritto il: 04/09/01 01:00
Località: Roma

Postdi Arpeda » 11/05/02 08:15

Nemok ha scritto:Riguardo il tuo ultimo post Andrea è buona norma installare Linux sempre per ultimo.


Per il semplice fatto che windows non permette nient'altro di estraneo nel MBR, per cui trovando lilo o chi per lui, lo toglie e ci si mette lui!!
quindi se non state attenti (dischetti di boot o di lilo) vi giocate la possibilità di usare il pinguino ...
Ciao
Arpeda
Arpeda
Utente Junior
 
Post: 91
Iscritto il: 23/11/01 01:00
Località: Roma

Postdi Andrea87 » 12/05/02 11:30

Domani proverò a levare la partizione del me, rendere quella dell'xp attiva e quindi installare linux. Se non funziona levo tutto e metto prima linux e poi Windows. Se ancora non funziona verrò qui a chiedere (con Windows, perchè mi sa che col mio Conexant HCF V90 56K Data Fax PCI Modem non posso navigare con Linux :( ... a meno che qualcuno qui sappia come farlo funzionare :D )
Andrea87
Utente Senior
 
Post: 857
Iscritto il: 03/09/01 01:00
Località: Venezia

Postdi Andrea87 » 17/05/02 17:45

Alla fine ci sono riuscito cmq ora vi spiego come è andata.
Ho esordito cancellando la partizione di Windows Me con Partition magic. Al riavvio, mentre mi stava applicando le modifiche mi dice che è avvenuto un errore e la partizione non è stata cancellato correttamente. Allora resetto e mi appare la meravigliosa scritta “Windows non ha trovato NT** (non mi ricordo bene com’era ma non è nè NTFS nè NTSC (che non c’entra niente con windows)).
Allora metto su il dischetto d’avvio di win XP e faccio fdisk \mbr. Non me lo accetta poiché nel disco di ripristino di Win Xp non c’è Fdisk (la Microsoft avrà pensato : “gli utenti sono troppo stupidi per saperlo usare quindi è meglio non metterglielo del dischetto d’avvio”). Allora metto quello del 98 “fatto in casa” (aggiungendo dei file consigliati da Wintricks) ma mi dice che la versione di fdisk non va bene. Fortunatamente avevo nello stesso dischetto quel Fdisk modificato che fortunatamente ma inutilmente funziona. Inutilmente perché al riavvio mi mostra sullo schermo 2 alternative da attivare con i tasti F2 e F3 ma tutti e du portavano allo stesso risultato. “Windows non ha trovato NT**”.
Allora, a quel punto decido di installare Linux. Dopo la semplice installazione decido di reinstallre Windows Xp formattando la vecchia partizione dov’era, poiché nemmeno LILO riusciva a farlo partire. Finita l’installazione di Windows provo a vedere se questa volta LILO riusciva a farlo partire. Ci riece! Allora provo a far partire Linux ma… la partizione swap è corrotta. Bene, penso, la solita prepotenza di Windows!
Allora reistallo Linux e tutto torna normale. Riesco quindi con LILO ad avviare sia Lnux sia Windows.
È stata dura ma alla fine ci sono riuscito!
Andrea87
Utente Senior
 
Post: 857
Iscritto il: 03/09/01 01:00
Località: Venezia

Postdi DarkAngel » 17/05/02 23:44

Veramente io ho installato Win2000 + WinXP + Debian sul portatile, il tutto gestito da lilo e non ho mai avuto i problemi di MBR evidenziati da Arpeda....

E' sempre buona norma installare Linux per ultimo così modifichi una sola volta lilo e non ci pensi +, non vedo perchè ci si debba complicare enormemente la vita con Partition Magic, installazioni acrobatiche di Windows e trucchi effimeri, quando con 2 righe del lilo.conf fai il boot di qualsiasi sistema operativo....
DarkAngel
Utente Senior
 
Post: 453
Iscritto il: 09/08/01 01:00

Postdi Andrea87 » 18/05/02 18:37

Si, ma io adoro il rischio :D
A parte gli scherzi, il problema non stà in partition magic ma nel fatto che il boot loader di Win Xp erà nell'MBR che era all'inizio della partizione di Win me che ho voluto cancellare. Quindi non penso che avrei potuto fare diversamente.
Andrea87
Utente Senior
 
Post: 857
Iscritto il: 03/09/01 01:00
Località: Venezia

Postdi iamj » 19/05/02 20:30

Andrea87 ha scritto:Alla fine ci sono riuscito cmq ora vi spiego come è andata.
Ho esordito cancellando la partizione di Windows Me con Partition magic. Al riavvio, mentre mi stava applicando le modifiche mi dice che è avvenuto un errore e la partizione non è stata cancellato correttamente. Allora resetto e mi appare la meravigliosa scritta “Windows non ha trovato NT** (non mi ricordo bene com’era ma non è nè NTFS nè NTSC (che non c’entra niente con windows)).
Allora metto su il dischetto d’avvio di win XP e faccio fdisk \mbr. Non me lo accetta poiché nel disco di ripristino di Win Xp non c’è Fdisk (la Microsoft avrà pensato : “gli utenti sono troppo stupidi per saperlo usare quindi è meglio non metterglielo del dischetto d’avvio”). Allora metto quello del 98 “fatto in casa” (aggiungendo dei file consigliati da Wintricks) ma mi dice che la versione di fdisk non va bene. Fortunatamente avevo nello stesso dischetto quel Fdisk modificato che fortunatamente ma inutilmente funziona. Inutilmente perché al riavvio mi mostra sullo schermo 2 alternative da attivare con i tasti F2 e F3 ma tutti e du portavano allo stesso risultato. “Windows non ha trovato NT**”.
Allora, a quel punto decido di installare Linux. Dopo la semplice installazione decido di reinstallre Windows Xp formattando la vecchia partizione dov’era, poiché nemmeno LILO riusciva a farlo partire. Finita l’installazione di Windows provo a vedere se questa volta LILO riusciva a farlo partire. Ci riece! Allora provo a far partire Linux ma… la partizione swap è corrotta. Bene, penso, la solita prepotenza di Windows!
Allora reistallo Linux e tutto torna normale. Riesco quindi con LILO ad avviare sia Lnux sia Windows.
È stata dura ma alla fine ci sono riuscito!


Vedi purtroppo fdisk /mbr sulla console non funziona (perche quello può sembrare un ambiente simildos ad un occhio inesperto, ma è stato solo creato per poter fare alcune operazioni di recupero sul sistema pur non avendo nessuna compatibilità con il vecchio prompt dei comandi di win 9x)
Cmq il comando adeguato era fixboot nel tuo caso, o fixmbr in caso si rovini l'mbr e non si cambiano le proprietà delle partizioni...

Il file che non trovava si chiama ntldr e si trova nella root della partizione d'avvio che tu hai formattato.....
Per rimettere tutto a posto ti bastava ripristinare l'installazione di xp...

Ciao! ;)
Your life is very short, a little while!!
^_^ ----Enjoy Yourself !!---- ^_^


Asus A7V266E+raid / XP 1800+ / 512 DDR !!!
iamj
Utente Senior
 
Post: 280
Iscritto il: 21/08/01 01:00
Località: C/mare di Stabia

Postdi Andrea87 » 20/05/02 18:55

Ho provato a ripristinare l'installazione ma non ne ero capace. Come si fa?
(così se mi capita un'altra volta evito di buttare tutto)
Andrea87
Utente Senior
 
Post: 857
Iscritto il: 03/09/01 01:00
Località: Venezia

Postdi iamj » 21/05/02 18:03

Andrea87 ha scritto:Ho provato a ripristinare l'installazione ma non ne ero capace. Come si fa?
(così se mi capita un'altra volta evito di buttare tutto)


Fai bootare il cdrom da bios, nel senso che metti come primo boot il cdrom...
Riavvii dopo aver inserito il cdrom di win, parte l'installazione e durante la modalità testo scegli di installarlo esattamente dov'è adesso.... ;)

Ciao! :)
Your life is very short, a little while!!
^_^ ----Enjoy Yourself !!---- ^_^


Asus A7V266E+raid / XP 1800+ / 512 DDR !!!
iamj
Utente Senior
 
Post: 280
Iscritto il: 21/08/01 01:00
Località: C/mare di Stabia

Postdi Andrea87 » 21/05/02 20:59

Ma se faccio così non mi formatta la partizione prima di installarlo? Mi pare ci fosse un'opzione RESUME ma mi apriva una finestra dos e non sapevo cosa dovevo fare
Andrea87
Utente Senior
 
Post: 857
Iscritto il: 03/09/01 01:00
Località: Venezia


Torna a Software Windows


Topic correlati a "boot Loader di Windows Xp":


Chi c’è in linea

Visitano il forum: tigre16 e 9 ospiti