Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Comando xcopy con parametro /d

Hai problemi con i file Zip, vuoi formattare l'HD, non sai come funziona FireFox? O magari ti serve proprio quel programmino di cui non ricordi il nome! Ecco il forum dove poter risolvere i tuoi problemi.

Moderatori: Dylan666, hydra, gahan

Comando xcopy con parametro /d

Postdi iucaa » 11/01/05 21:42

Ho due Hard Disk esterni USB dei quali uno è il backup dell'altro, quindi contengo la stessa struttura di directoy e files, ora ogni tanto effettuo, anzi vorrei, effettuare un backup da un disco ad un'altro, usando il comando xcopy, ma non mi sembra che il flag /d (data) funzioni correttamente, a meno che non sbaglio qualcosa io, questo è il comando che inserisco :

xcopy e:\*.* f:\*.* /s/d:<data> nel formato (Come indicato dall'help) mm-dd-yyyy

vengono copiati tutti i files!, senza discriminazione di data, ammesso che io abbia sbagliato, ripetendo il comando, non si dovrebbe ottenere nessun file in copia, invece vengono copiati gli stessi files!! dove sbaglio?.
Ho anche provato (Come indicato dall'help) ad inserire solo il flag /d senza data:


xcopy e:\*.* f:\*.* /s/d

Stesso risultato, vengono copiati tutti i files indistintamente, ed inoltre, ripetendo il comando windows copia sempre gli stessi files, forse devo aggiungere un'altro flag?.


Dall'help di xcopy

/D:m-d-y Copia i file modificati a partire dalla data specificata.
Se non sono indicate date, copia solo i file con
ora di origine pi— recente dell'ora di destinazione.



:aaah
iucaa
Utente Senior
 
Post: 488
Iscritto il: 23/10/03 12:03
Località: Roma

Sponsor
 

Postdi pjfry » 11/01/05 21:52

prima le domande sceme:
il tuo esempio è con la d minuscola, hai provato con la maiuscola?
hai provato senza la /s? e mettendo uno spazio tra i 2 flag?
Avatar utente
pjfry
Moderatore
 
Post: 8240
Iscritto il: 19/11/02 17:52
Località: terni


Torna a Software Windows


Topic correlati a "Comando xcopy con parametro /d":


Chi c’è in linea

Visitano il forum: Nessuno e 9 ospiti