Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

help publisher 98 to 2003

Hai problemi con i file Zip, vuoi formattare l'HD, non sai come funziona FireFox? O magari ti serve proprio quel programmino di cui non ricordi il nome! Ecco il forum dove poter risolvere i tuoi problemi.

Moderatori: Dylan666, hydra, gahan

help publisher 98 to 2003

Postdi maximumpw » 27/10/04 18:31

Ciao,
ho un sito creato con publiscer 98 e salvato con estensione .pub
questo sito, una volta pubblicato occupa circa 3mb...

recentemente ho dovuto cambiare il pc a causa di un fulmine che ha devastato l'hardware e di conseguenza ho dovuto installare anche i software aggiornati alle versioni 2003

il mio problema:
riaprendo lo stesso file creato con publisher 98.
e pubblicandolo con publisher 2003
mi occupa 25mb anziche' 3mb!!!! (tra l'altro con una risoluzione di immagine molto piu'scadente di quanto non facesse gia' la versione 98 )

qualcuno mi puo' dare un consiglio su come settare publisher 2003 in maniera tale da ottenere un risultato simile a quello di publisher 98?

grazie raga! sono disperato!!!
Saluti
Max
maximumpw
Utente Junior
 
Post: 42
Iscritto il: 02/04/04 19:52
Località: Bergamo

Sponsor
 

Postdi Dylan666 » 27/10/04 21:15

File > Salva con nome e in "Tipo di file" scegli "File di Publisher 98 (*.pub)".

PS: fare un sito con Publisher è una assurdità, forse è peggio che farlo con Word....
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

grazie dylan

Postdi maximumpw » 28/10/04 12:38

grazie Dylan ora faccio una prova e poi ti so' dire se funziona..
in quanto alla scelta del programma (publisher) è dovuta al fatto che gia' avevo il programma e poi io non conosco l'html e di conseguenza publisher mi ha aiutato molto lavorando solo con la parte visuale e non programmata...
non so' se mi sono spiegato bene...
a tra poco
Max
maximumpw
Utente Junior
 
Post: 42
Iscritto il: 02/04/04 19:52
Località: Bergamo

come temevo...

Postdi maximumpw » 28/10/04 12:56

purtroppo Dylan, il tuo consiglio non mi puo' aiutare...
ecco cosa succede:

il comando salva con nome:
salva un file di archivio di publisher di tutto il lavoro svolto su un progetto
con estensione pub che rimanne su hd per riprendere il lavoro da dove si è arrivati oppure per fare future modifice

il comando pubblica sul web, crea i file che andranno su internet per poi poter essere letti dai browser

il comando che serve a mè e' il secondo(pubblica sul web) il quale, indifferentemente dal tipo di salvataggio 98,2000, 2003 mi crea una versione html (filtrata) che nel mio caso mi servirebbe di contenere in un massimo di 3mb (come accadeva nella versione 98 e non di 20 e più mb come adesso mi succede con la versione 2003)
mah! chissa' se trovero' una soluzione...
mi affido a voi amici del forum che ne sapete piu' di me
bye bye
fiducioso
Max
maximumpw
Utente Junior
 
Post: 42
Iscritto il: 02/04/04 19:52
Località: Bergamo

Postdi Dylan666 » 28/10/04 14:02

Devi riuscire a capire a cosa è dovuto il cambio di dimensione del sito: non è che vengono duplicati dei file inutitli?
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

esatto!!!

Postdi maximumpw » 28/10/04 14:30

esatto!
una componente di errore è sicuramente il salvataggio di file immagine che non sebbrano indispensabili per il funzionamento.

per rendere l'idea:
un'immagine chiamata image01 si trova 2 volte con un nome diverso,
la differenza tra i 2 file è che uno e' in risoluzione bassa (utilizzato e visualizzato nel sito) e l'altro è in alta risoluzione ma sembra che non venga utilizzato in alcun modo per la corretta visualizzazzione del sito!!!

forse devo cercare nelle opzioni e disabilitare la copia di queste immagini ad alta risoluzione!?

io provo a dare un'occhiata ma non so' dove sbattere la testa.. se qualcuno mi sa' dare una dritta è sempre ben accetta!
bye
Max
maximumpw
Utente Junior
 
Post: 42
Iscritto il: 02/04/04 19:52
Località: Bergamo

Postdi Dylan666 » 28/10/04 14:34

Beh sì, quella è una soluzione. Mi è capitato di vedere che anche Word fa 2 copie di immagini di cui 1 è inutile se gli si chiede di salvare in HTML un documento che era DOC, ma non mi ci sono scervellato più di tanto.

L'altra soluzione è eliminare a mano i file superflui, o dal web o dal disco fisso prima di mettere il progetto on-line
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

ho fatto una prova...

Postdi maximumpw » 28/10/04 14:50

nel frattempo ho provato a cancellare manualmente tutti i file image che non sembrano essere utilizzati per il corretto funzionamento e visualizzazzione del sito ed effettivamente il peso complessivo e' calato da 20mb a 5mb

e poi ho trovato un file a me sconosciuto denominato:
index_oledata.mso (x un totale di 3.699kb)
ho provato a togliere anche questo file e risultato....
3mb di struttura completa di tutto cio' che occorre per farla girare in rete!!!!

io sono molto perplesso... non dovro fare un'operazione del genere ogni volta che modifico il sito vero? altrimenti mi sparo!(con la pistola ad acqua si intende ;-)
maximumpw
Utente Junior
 
Post: 42
Iscritto il: 02/04/04 19:52
Località: Bergamo

Postdi Dylan666 » 28/10/04 14:54

Beh, se non trovi l'opzione adatta al tuo scopo (guarda pure l'help... ma hai salvato il progetto nel formato del nuovo Publisher prima di esportarlo in HTML?) non vedo altra alternativa... Magari se i file hanno delle costanti puoi cavartela con qualche file BAT.
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

Postdi maximumpw » 28/10/04 15:41

ho provato a salvarlo in tutti i formati(98-2000-2003)
e per ogni formato ho fatto la prova di conversione in html per vedere se c'erano risultati differenti ma niente! le differenze sono minime!

che help mi hai consigliato di guardare? sul forum o sul programma?

e per le costanti e i file bat non saprei proprio dove mettere meno...
ci rinuncio a priori

bye
maximumpw
Utente Junior
 
Post: 42
Iscritto il: 02/04/04 19:52
Località: Bergamo

Postdi Dylan666 » 28/10/04 16:10

Per costanti e bat intendo dire che se ti accorgi che tutti i file inutili sono PNG o cominciano con un trattino (dico per dire) li puoi individuare e cancellare in un colpo solo. Come help mi riferivo a quello del Publisher. Nella mia versione (2002) il problema non si presenta (ma partedndo da PUB creati sempre col 2002). Se vuoi puoi spedirmi il file o uno con lo stesso problema (ti mando il mio indirizzo via MP) e vedo se riesco a eliminare la duplicazione ma non assicuro nulla anche perché non ho mai creato siti da file PUB prima d'ora...
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

:-!

Postdi maximumpw » 28/10/04 16:21

secondo te faccio una stupidata a provare ad installare publisher 98 su win_xp_sp2?

per l'invio tramite mail del file pub non sono sicuro che la mia posta supporti 30.000kb di file
ho una casella con tin.it
che ne dici?
maximumpw
Utente Junior
 
Post: 42
Iscritto il: 02/04/04 19:52
Località: Bergamo

Postdi Dylan666 » 28/10/04 16:33

Sinceramente non lo so, guarda se sul sito trovi le limitazioni della tua casella per gli allegati uscenti...

Installare il Publisher 98 di per se non è una cavolata ma sarebbe sconfortante pensare che il 2002 faccia regredire il tuo lavoro invece di progradire...

PS: leva un po' di immagini al tuo progetto, fai un "salva con nome" e mandami casomai questa versione "versione ridotta" del PUB difettoso, purché abbia lo stesso problema dell'originale.
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

sconforto totale

Postdi maximumpw » 28/10/04 17:36

effettivamente sono molto sconfortato nel vedere che la versione 2003 è regredita invece che progredita...

ora devo abbandonare la nave(devo andare al lavoro)
non credo di riuscire a fare altre cose con il pc questa settimana perche' nei giorni prossimi sono un po' impegnato ma appena riesco vedo di inviarti il materiale per fare la prova con la vers 2002

grazie di tutto e a presto!
maximumpw
Utente Junior
 
Post: 42
Iscritto il: 02/04/04 19:52
Località: Bergamo

proprio non riuscivo a dormire...

Postdi maximumpw » 29/10/04 03:28

non riuscivo a dormire e cosi' mi sono messo di nuovo a smanettare su publisher...risultato?
sono riuscito a ripristinare le dimensioni dei file quasi come all'origine:
vi spiego cosa ho combinato:

dal menu "strumenti seleziona opzioni
seleziona la cartella web e togli le opzioni seguenti:
X utilizza vml
X consenti formato grafico png

gia' con queste modifiche si ottengono mediocri risultati in fatto di pesantezza dei file. Ma per rendere ancora piu' snello il tutto
mi sono modificato i file immagine riducendo le dimensioni e salvandoli tutti nel formato jpg al 55%

a seguire ho convertito il progetto in html e finalmente ci siamo!
peso forma 2,65mb!!!
evvivaaaaaaaaaaa!!!!

peccato che nel frattempo ho riscontrato un'altro problema :-(

Problema n°2:
i file o le immagini collegate con un link a pulsanti,parole,immagini non vengono riportati nel progetto finale (html)

mi spiego meglio:
se io ad un'anteprima di immagine collego un'immagine in fomato originale, quest'ultima non viene esportata insieme al progetto html ma rimane nell'hd...in questo modo quando si fanno le prove sul pc sembra tutto funzionare a meraviglia ma poi una volta trasportato su internet i link non funzionano piu' perche' i link si riferiscono alle cartelle del pc!!!!

forse hanno cambiato procedura perche' nei vecchi publisher i file legati con un link venivano copiati nella cartella dove si salvava la versione html.Ma ora questo non accade piu'...
halp me

gia' che ci sono spiego come sbrigo la procedura...
dal menu "file"
"pubblica sul web"
seleziono una cartella tipo "C:\pubblica"
"salva"
ora apro "smart ftp" e trasporto il tutto su ftp


ho provatoanche a pubblicare direttamente da publisher
dal menu "file"
Pubblica sul web
seleziono"aggiungi modifica percorsi ftp"
compilo "ftp"
"user"
"Password"
e invio
ma il risultato e' identico!!!

ho pensato anche di precaricare i file che mi servono preventivamente su ftp e poi di collegarli con il link definitivo della rete internet tipo http://miosito/immagini/file.jpg
in questo modo dovrebbe funzionare dico bene?

ora non riesco piu' a connettere...vado a nanna!
appena posso vi faccio sapere cosa sono riuscito a fare :-)
Bye

pero' ho parecchi link da sistemare in questa maniera!!!
maximumpw
Utente Junior
 
Post: 42
Iscritto il: 02/04/04 19:52
Località: Bergamo

Postdi Dylan666 » 29/10/04 09:42

Devi trovare come poter mettere i percorsi relativi (e non assoluti e del tuo PC) ai file. Ma 'sto benedetto help lo hai guardato?
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

Help esaminato:

Postdi maximumpw » 29/10/04 13:54

ho consultato più volte l'help di publisher e sinceramente non ho trovato delle grandi delucidazioni del caso.

cio' che riguarda il collegamento ipertestuale di file o immagini viene cosi' descritto:

Creazione di un collegamento ipertestuale che rimanda a una pagina o a un file

Selezionare del testo o un'immagine.
Fare clic su Inserisci collegamento ipertestuale .
Selezionare File o pagina Web esistente nell'elenco Collega a.
Procedere in uno dei seguenti modi:
Per selezionare un file dalla cartella Documenti, fare clic su Cartella corrente.
Per selezionare un file visualizzato di recente nel browser, fare clic su Pagine visualizzate.
Per selezionare uno degli ultimi file aperti, fare clic su File recenti.
Spostarsi sul file o sulla pagina desiderata.

poi c'è un piccolo accenno anche ai collegamenti assuluti e relativi
che riporto di seguito:

Differenza tra collegamenti ipertestuali assoluti e relativi

Un URL assoluto contiene un indirizzo completo composto da protocollo, server Web, percorso e nome di file.

Un URL relativo non include tutte le parti. Le informazioni mancanti vengono derivate dalla pagina che include l'URL. Se, ad esempio, non sono specificati il protocollo e il server Web, vengono utilizzati il protocollo e il dominio (.com, .org, .edu) della pagina corrente.

Nelle pagine di un sito Web vengono spesso utilizzati URL relativi contenenti solo un percorso parziale e il nome di file. Se i file vengono spostati in un server diverso, i collegamenti ipertestuali continueranno a funzionare correttamente a condizione che le posizioni relative delle pagine non vengano modificate. Si supponga, ad esempio, che la pagina Prodotti.htm includa un collegamento ipertestuale che fa riferimento alla pagina mela.htm contenuta nella cartella Alimenti. Se entrambe le pagine vengono spostate in una cartella Alimenti in un server diverso, l'URL del collegamento ipertestuale continuerà a funzionare correttamente.

Questo e' quanto... io non ho trovato altro
anche cercando nei problemi di visualizzazzione ai collegamenti ipertestuali non viene citato niente del mio caso...

Considerazione:
ho notato che ci sono molte impostazioni per inviare via e-mail la creazione di una pagina in formato html
è probabilmente per questo motivo che sono state disattivate le funzioni che allegavano i file relativi ad un link?!?! infatti in una e.mail non puoi collegare un file non residente in internet e nemmeno allegarlo alla stessa!
o forse sto solo farneticando!!!

bye max
maximumpw
Utente Junior
 
Post: 42
Iscritto il: 02/04/04 19:52
Località: Bergamo

Re: Help esaminato:

Postdi Dylan666 » 29/10/04 14:02

maximumpw ha scritto:ho notato che ci sono molte impostazioni per inviare via e-mail la creazione di una pagina in formato html
è probabilmente per questo motivo che sono state disattivate le funzioni che allegavano i file relativi ad un link?!?! infatti in una e.mail non puoi collegare un file non residente in internet e nemmeno allegarlo alla stessa!
o forse sto solo farneticando!!!


la prima parte non credo di averla ben capita, ma quella che ho evidenziato in grassetto (se l'ho interpretata bene) è assolutamente falsa. Le mail HTML possono avere riferimenti a immagini sul web o ad file incorporati nella mail stessa.

Comunque devi usare i percorsi relativi. Questo vuol dire che se hai la pagina HTML in C:\documenti e il file immagine.jpg nella stessa cartella (e sul server use sarà così) nel codice ci deve essere scritto solo

<img src="immagine.jpg">

e non

<img src="C:\documenti\immagine.jpg">
Avatar utente
Dylan666
Moderatore
 
Post: 38040
Iscritto il: 18/11/03 16:46

ok

Postdi maximumpw » 29/10/04 15:57

Comunque devi usare i percorsi relativi. Questo vuol dire che se hai la pagina HTML in C:\documenti e il file immagine.jpg nella stessa cartella (e sul server use sarà così) nel codice ci deve essere scritto solo

<img src="immagine.jpg">

e non

<img src="C:\documenti\immagine.jpg">


ok, sono d'accordo con te sull'utilizzo di percorsi relativi
ma resta il fatto che i file collegati ipertestualmente a questi "percorsi relativi" me li devo esportare manualmente perche' il programma non me li gestisce!

ma io vorrei sapere perchè sucede questo?
nelle altre versioni ha sempre funzionato correttamente e la metodologia di collegamento ipertestuale a file non è variata di molto anzi, è quasi identica.per mè c'è un bug nel software!!!!

era tutto implicito.
Si collegava un testo o una foto con un collegamento ipertestuale ad un file e questo veniva riportato sul web insieme alle pagine web! cosa c'è di complicato in tutto cio'????


Faccio un'appello a tutti i fruitori di publisher 2003!!!
nessuno di voi ha riscontrato questo problema?
e' possibile che solo io mi stia dannando?

mah!
bye Max
maximumpw
Utente Junior
 
Post: 42
Iscritto il: 02/04/04 19:52
Località: Bergamo

ho ceduto!!!

Postdi maximumpw » 29/10/04 22:13

dopo 4 giorni a cercare di capire come far funzionare sto publisher 2003
ho rinuncato e ho installato la versione 98!
mi vergogno a dirlo ma solo in questo modo sono riuscito a pubblicare il sito cosi' come intendevo modificarlo!

Volevo ringraziare Dylan per la sua pazienza e per il suo aiuto...
e' l'unica persona che ho trovato in questi giorni che si è messa a completa disposizione per aiutarmi
Grazie Dylan mi sei stato di grande aiuto oltre che di grande conforto!
maximumpw
Utente Junior
 
Post: 42
Iscritto il: 02/04/04 19:52
Località: Bergamo

Prossimo

Torna a Software Windows


Topic correlati a "help publisher 98 to 2003":


Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti