Condividi:        

cerca ultime

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

cerca ultime

Postdi rombotuono » 24/12/23 10:37

buongiorno,
utilizzo questa formula matriciale per calcolare quante partite ha vinto in totale la squadra presente in ag3.
vorrei utilizzare la stessa formula per poter calcolare le ultime 10 partite vinte sempre da ag3.


SE($AG3="";"";MATR.SOMMA.PRODOTTO(--(sq_casa=$AG3);--(ris_casa_f>ris_fuori_f)))
grazie
rombotuono
Utente Senior
 
Post: 112
Iscritto il: 09/11/18 17:27

Sponsor
 

Re: cerca ultime

Postdi Anthony47 » 25/12/23 02:08

Forse:
Codice: Seleziona tutto
=SE($AG3="";"";MATR.SOMMA.PRODOTTO(--(sq_casa=$AG3);--(ris_casa>ris_fuori);--(RIF.RIGA(sq_casa)>=GRANDE(RIF.RIGA(sq_casa)*(sq_casa=$AG3);10))))
E se dai tuoi collaudi non funziona allora allega un file dimostrativo per farci le prove sopra.
Avatar utente
Anthony47
Moderatore
 
Post: 19238
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: cerca ultime

Postdi rombotuono » 26/12/23 09:49

grazie,
Anthony
ho provato ma di dati non corrispondono.
allego file
https://uploadnow.io/files/Y0HHz5T
rombotuono
Utente Senior
 
Post: 112
Iscritto il: 09/11/18 17:27

Re: cerca ultime

Postdi Anthony47 » 26/12/23 11:32

Il link mi porta a una pagina dove mi viene proposto di creare un account, mentre non vedo nessuna opzione per scaricare il file; riprova per favore
Avatar utente
Anthony47
Moderatore
 
Post: 19238
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: cerca ultime

Postdi rombotuono » 26/12/23 13:18

rombotuono
Utente Senior
 
Post: 112
Iscritto il: 09/11/18 17:27

Re: cerca ultime

Postdi Anthony47 » 26/12/23 15:03

Scaricato file, ok; ma che cosa non torna?
Avatar utente
Anthony47
Moderatore
 
Post: 19238
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: cerca ultime

Postdi rombotuono » 26/12/23 15:17

in colonna aj i dati sono corretti
in colonna ah da errati con la formula da te suggerita
la lettura deve partire dall'alto
rombotuono
Utente Senior
 
Post: 112
Iscritto il: 09/11/18 17:27

Re: cerca ultime

Postdi Anthony47 » 26/12/23 19:36

Ma hai controllato?
Leeds, io conto 7 vinte tra le ultime 10 giocate in casa, e non 8
Middlesbrough, io conto 5 vinte, e non 6

Da qui io deduco che colonna AH e' giusta e colonna AJ e' sbagliata

Ma credo che la chiave sia "la lettura deve partire dall'alto"... Vuoi dire che le ultime partite sono quelle elencate per prime? :-?
Avatar utente
Anthony47
Moderatore
 
Post: 19238
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: cerca ultime

Postdi rombotuono » 26/12/23 20:09

le ultime giocate sono le prime, quindi il conteggio deve partire dalla riga 3
i dati in colonna aj sono presi dal sito betexplorer
il link è nel foglio allegato.
rombotuono
Utente Senior
 
Post: 112
Iscritto il: 09/11/18 17:27

Re: cerca ultime

Postdi Anthony47 » 27/12/23 10:42

le ultime giocate sono le prime
Insomma hai applicato al contrario il principio evangelico "beati gli ultimi perché saranno i primi"...

Invece di Grande useremo Piccolo:
Codice: Seleziona tutto
=SE($AG3="";"";MATR.SOMMA.PRODOTTO(--(sq_casa=$AG3);--(ris_casa_f>ris_fuori_f);--(RIF.RIGA(sq_casa)<=PICCOLO(SE((sq_casa=$AG3);RIF.RIGA(sq_casa);9999);10))))
Avatar utente
Anthony47
Moderatore
 
Post: 19238
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: cerca ultime

Postdi rombotuono » 27/12/23 14:37

Insomma hai applicato al contrario il principio evangelico "beati gli ultimi perché saranno i primi"...
si spera.
grazie tutto ok
sempre gentilissimo
ti faccio gli auguri di un ottimo 2024
grazie ancora
rombotuono
Utente Senior
 
Post: 112
Iscritto il: 09/11/18 17:27


Torna a Applicazioni Office Windows


Topic correlati a "cerca ultime":


Chi c’è in linea

Visitano il forum: Nessuno e 9 ospiti